Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2017 (PC) Microstuttering at High Refresh Rate Potential Workaround

Recommended Posts

@Ho3n3r any chance you could try deleting the temp folder, rebooting and trying it.
Good idea, will do that tonight. Thanks.

Share this post


Link to post
Share on other sites
@Ho3n3r any chance you could try deleting the temp folder, rebooting and trying it.
Coming back to this (LOL I know, right).

I never did this, totally slipped my mind, but I started a new custom grand prix season instead, with weather disabled - career amount of rain just got boring so I abandoned it til I can find a way to disable career weather.

And guess what - no microstutters at all, so I'm still convinced that the recording of career progress in the background is causing the microstutters. I am one race further than where I stopped in career (career - Mexico season 1, dry season - Brazil), and I have done mid-race saves, jumped in mid-race save after exiting, after not exiting etc. and no microstutters at all.

Previously in career I was getting them in dry, light rain, heavy rain, doesn't matter.

Share this post


Link to post
Share on other sites
You might be on to something regarding career mode causing the stutters but I'm wondering if it could be linked to using flashback and mid-session save.

I have only had one online race microstutter since I did the "delete the temp folder" I have mentioned previously so all other modes have been very good however at the same time have also stopped using flashbacks.

The reason I have mentioned this is the other day I did a mid-session save (Australia).  When I went back to it i wasn't sure how to restart.  It plays a replay of the last few seconds and like flashback you can restart from anywhere the replay allows.  I restarted somewhere in the middle of the replay.  I was getting stutter everywhere, the worst I have ever had it.  So I quit the race and reloaded the mid-session save again.  This time I let the replay play to the end before taking over the car and no stutter at all.  I quit again and tried to replicate the stutter by starting half way through the the replay, this time however when I pressed the key to take control my car everything jumped to the end of the replay and I had no stutter (I could not take control mid-replay like before).  I tried a few times but could not start from the midpoint of the replay, every time it jumped to the end and there was no stutter so I am wondering if there could be a syncing error between where you start from when using flashback/mid-session save and where the game thinks you are, just like lag spikes in multiplayer but for the whole track.

This "memory" then stays within the career save for the following races.

Share this post


Link to post
Share on other sites
I'm not sure it's related to mid-session save or flashbacks, as I use them in both modes(flashbacks for stupid backmarkers) and I only get stutters in career mode.

Share this post


Link to post
Share on other sites
Just my theory and we could be having different issues.

To confirm I used to only get microstutters (might still get) in career mode and online with races over 5 laps.

Share this post


Link to post
Share on other sites
Just wanted to post an update since my original post back in August. I've just switched from Asus Z270 IX Hero and i7 7700K to a Gigabyte Z370 Gaming 7 board + i7 8700K. My GPU is the same GTX 1080 Ti. The micro stutter has completely vanished for me. I'm back using G-sync at 144hz refresh rate and disabled GPU power monitoring in EVGA Precision (this did not help with my Z270 Asus build). I didn't even re-install Windows 10, simply installed all Gigabyte drivers and re-installed the latest Nvidia driver. My build prior to Z270 was also an Asus Z170 board and I also had stutter with F1 2016 as mentioned earlier. Not saying moving to Gigabyte for Z370 or 8700K is the answer, but for some reason unknown to me this game is finally butter smooth at 144hz + 1440p w/ G-sync. I'm running Windows 10 Pro version 1709. 

Share this post


Link to post
Share on other sites
Was hoping this wouldn't still be occurring, hadn't played the game for a month after just taking a break from it, everything is fine for me bar multiplayer with stutters, impossible really to play enjoyably with stutters every so often :/

Share this post


Link to post
Share on other sites
Had same issue with i7 6700k, ssd, 1080, 16gb, 165hz setup. Set power profile to maximum performance in windows and also in Nvidia Graphics setting (global). Stuttering gone and fps now around 100-120 from 60-70. 

Share this post


Link to post
Share on other sites

×