Jump to content Jump to content

Thrustmaster T3PA pedal not working with F1 2017


Arrowheadrocker

Recommended Posts

Hi, I'm new here on the forum and just bought F1 2017. With all my other games I use the combined mode for the pedals but that doesn't seem to work in F1 2017. If I use the seperate mode the Throttle goes from 0 -100 very abrupt, so not lineair. The game is unplayable this way. In the combined mode I try to assign the throttle and brake pedals and it marks it as Y + and Y -. When I save this setting and go into the edit menu again it both has the Y- mark with a ! warning. When I throttle in the game the brake activates as well. I use the T3PA with a T300RS wheel and steering and knobs work. Does anybody has/had this problem and know how to solve this?
Link to post
Share on other sites
Hi, I'm new here on the forum and just bought F1 2017. With all my other games I use the combined mode for the pedals but that doesn't seem to work in F1 2017. If I use the seperate mode the Throttle goes from 0 -100 very abrupt, so not lineair. The game is unplayable this way. In the combined mode I try to assign the throttle and brake pedals and it marks it as Y + and Y -. When I save this setting and go into the edit menu again it both has the Y- mark with a ! warning. When I throttle in the game the brake activates as well. I use the T3PA with a T300RS wheel and steering and knobs work. Does anybody has/had this problem and know how to solve this?
Recalibrate the T3PA pedals in Control Panel|Devices and Printers and set the in-game Throttle / Brake Linearity / Saturation to 0.
Link to post
Share on other sites
Thanks for your advice. However, if I try to calibrate the throttle in the separate mode it behaves like an on/off switch. In the combined mode it goes smooth up (in the middle break bar) so I guess the pedal/pot is okay.  I use the latest firmware and drivers. Still hoping for a solution... :#
Link to post
Share on other sites
I have the same wheel and pedals. 

Download the driver updater from Thrustmasters website and then plug your wheel into the PC and update it. You can adjust all of your steering and pedal input from there.
Link to post
Share on other sites

On the right side of the 3 pedal bars you see 2 boxes that you can choose. The first is separate (Afzonderlijk) and the second is combined (Gecombineerd). For all my other games I use combined (Project cars, R3E, Dirt games, rFactor2 etc) and works fine, but in F1 2017 this does not seem to work. So then I choose separate and the pedals are assigned correctly but the throttle behaves like an on/off switch... so if I gradually push the throttle it first does nothing and then suddenly it goes to 100% (and full throttle in the game). Hope it's clear.
Link to post
Share on other sites
I managed to solve it with the combined mode and changing some text in the action map file. Then I had to change the saturation and linearity in the game settings and finally it worked. Crazy  :#
Thank you guys for trying to help me out. To bad Max Verstappen had trouble again today (I'm a Dutchie)
Link to post
Share on other sites
I managed to solve it with the combined mode and changing some text in the action map file. Then I had to change the saturation and linearity in the game settings and finally it worked. Crazy  :#
Thank you guys for trying to help me out. To bad Max Verstappen had trouble again today (I'm a Dutchie)
Can you post what you altered (copy and paste the action map section)?
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...