Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

[PC] Keyboard buttons not working

Recommended Posts

Instructions on the flashback screen are telling me to press F7, F8, etc. but none of them work. 

This means i'm stuck in the screen and my only way out is Alt+F4



I am using a G27/thrustmaster shifter/keyboard control scheme.
I have modded my G27 and therefore have no buttons on my wheel that i could try.

I also noticed i cannot skip cinematics during a Grand Prix.
I pressed every thinkable key on my keyboard.

Share this post


Link to post
Share on other sites
Is your keyboard selected in the control mappings (ticked)? You can have two or more controllers configured.
On my G920 A is the default camera button is the one to skip video, try your camera button or whatever you mapped to 'Advance' in menu navigation.

Share this post


Link to post
Share on other sites
Thanks for your reply.

Yes, keyboard is part of my custom control scheme


I tried mapping the "advance" function to a keyboard button, but it wont let me


Share this post


Link to post
Share on other sites
I found a workaround, by connecting an additional controller (xbox360 controller), that i use just to navigate the menus, while still using the wheel for driving.

Share this post


Link to post
Share on other sites
Simplest solution:

DO NOT USE ANY KEYBOARD-KEYS IN A CONTROLLER PROFILE!! NEVER EVER DO THIS!!

Had the same problem, tried the above & voila, problem solved.

Share this post


Link to post
Share on other sites
Same problem here on PC, Time Trial, replay mode.
The axis of the wheel become functions. As I steer left, I look left, if I brake I look back etc.
F2 and TAB work but these are the only two. I have to go to taskmanager and kill the game.
Ensiferrum what do you mean? I have to do everything with the 6 buttons on my wheel?

Share this post


Link to post
Share on other sites
Ensiferrum, I have unbound all the keys in the profile, saved it. Restarted the game but it doesn't matter at all, still the same problem. I also cannot skip ingame movies and I will post other intances where the keyboard doesn't work.

Share this post


Link to post
Share on other sites
Ensiferrum, I have unbound all the keys in the profile, saved it. Restarted the game but it doesn't matter at all, still the same problem. I also cannot skip ingame movies and I will post other intances where the keyboard doesn't work.

And you have re-enabled Keyboard Preset 1?

Share this post


Link to post
Share on other sites
Having the same issue, using a Simraceway SRW-S1. Won't let me control around flashbacks (however will let me switch into screenshot mode and take a photo) but controls for navigating flashback won't work on either wheel or keyboard. So once I am in flashback mode it won't let me exit it which means if I crash then I have to shut down the game entirely and reboot

£45 for this and wasn't picked up in beta testing ... not such CodeMasters as CodeMorons

Share this post


Link to post
Share on other sites
Same problem here. I have a Saitek R440. Biggest issue for me is that the wheel only has 6 button, so I can't possibly map everything on there.
I solved the issue so far with a workaround: mapped some of the Replay-control functions on my wheel buttons. It's far from perfect, but at least I can get out of replays, use flashbacks and flip through the cut scenes.

Still needs fixing from Codemasters tho!

Share this post


Link to post
Share on other sites
Angus513 said:
Having the same issue, using a Simraceway SRW-S1. Won't let me control around flashbacks (however will let me switch into screenshot mode and take a photo) but controls for navigating flashback won't work on either wheel or keyboard. So once I am in flashback mode it won't let me exit it which means if I crash then I have to shut down the game entirely and reboot

£45 for this and wasn't picked up in beta testing ... not such CodeMasters as CodeMorons
Same problem here. I have a Saitek R440. Biggest issue for me is that the wheel only has 6 button, so I can't possibly map everything on there.
I solved the issue so far with a workaround: mapped some of the Replay-control functions on my wheel buttons. It's far from perfect, but at least I can get out of replays, use flashbacks and flip through the cut scenes.

Still needs fixing from Codemasters tho!

Bad luck for you guys. Haven't found your wheels on the official list of supported peripherals.
But this doesn't mean that there are now workarounds for this.

Share this post


Link to post
Share on other sites
Sorry, there are two 'keyboard' posts active now which is probably my fault...

Solution found on the Steam Forum posted by  EcLiPsE !
Take a Keyboard Preset and edit that one for the wheel. So add your axis and buttons in it. For me it worked with Keyboard Preset 1.  A bit confused with adding the steering axis since it says X+ and you think it counts from a 'middle point' but it doesn't (in my case) it's just one axis. It will not add a X-.
After saving it says: Keyboard,Wheel instead of the other way around. Keyboard functions now.
Thanks Ensi and other for replying!
Have to set a fast time at Spa now... later.

Share this post


Link to post
Share on other sites
Bad luck for you guys. Haven't found your wheels on the official list of supported peripherals.
But this doesn't mean that there are now workarounds for this.


The wheel works fine in all other aspects
It functions fully for menu changes etc and if I enter flashback mode it will let me switch across to screenshot mode which also works without a hitch on both wheel and keyboard. It is just on the flashback section that none of the buttons function for anything which doesn't point to the wheel being an issue but rather the flashback coding.

Share this post


Link to post
Share on other sites
Angus513 said:
Bad luck for you guys. Haven't found your wheels on the official list of supported peripherals.
But this doesn't mean that there are now workarounds for this.


The wheel works fine in all other aspects
It functions fully for menu changes etc and if I enter flashback mode it will let me switch across to screenshot mode which also works without a hitch on both wheel and keyboard. It is just on the flashback section that none of the buttons function for anything which doesn't point to the wheel being an issue but rather the flashback coding.

You might be right.
I never use flashback

Share this post


Link to post
Share on other sites
Ensiferrum, I have unbound all the keys in the profile, saved it. Restarted the game but it doesn't matter at all, still the same problem. I also cannot skip ingame movies and I will post other intances where the keyboard doesn't work.

And you have re-enabled Keyboard Preset 1?

Well there ARE two controllers enabled.

This is how I have mine configured and it works, I don't have any of the problems here. I didn't change anything in the keyboard preset and I created a custom G920 profile because I use the clutch to brake (spring mod as well). I also use an MK330 Desktop set. I map Discord PTT to the flashback because I play MP and flashback isn't needed.

Having two controllers enabled is normal. If you have custom, delete them and start over from the presets making only essential changes and do not input keys into the wheel profile and vice versa. If there are issues AFTER that, then you can file a bug report.

Share this post


Link to post
Share on other sites
I found the solution!
What I did wrong was that I used the existing thrustmaster profile and then modify that to my prefered settings. What I did now to fix it, I took the keyboard profile and edited that one, so for instance accelerate, brake, settering, drs, MFD all configured as wheel buttons. Now the menu buttons al remain keyboard buttons and everything works fine!

@6e66o So use keyboard preset 1 and then edit the controls for steering etc on your wheel


good luck


Share this post


Link to post
Share on other sites

×