Jump to content Jump to content

Dirt 3 - Steam with GFWL - error 10038 crashes game at end of **each** race


Recommended Posts

Hello, :smile:
I've bought Dirt 3 and a whole bunch of other CodeMaster titles off of steam this weekend. Everything works but Dirt 3.
 Everything runs beautifully  till, I hit the end of the race where the game freezes and I get the following message box:

sendto failed with error 10038: An operation was attempted on something that is not a socket

I have Win 7 x64, AMD phenom x4 960 BE, ATI R9 290. My nephew ran a copy of his NON-steam version beautifully in the exact same PC while he was living here. After the crash, I see steam was trying to upload a snapshot from race, don't know if it's related. Game benchmarks at 60 (min) to 90 (max) FPS on ULTRA without crashing. Tried running on ULTRA low preset, still crashed. Tried delete hardware_settings_config.XML - no love. Tried to disconnecct internet, so that GFWL and steam run offline, still crashes.

Again, the steam free version ran perfectly but I bought this from steam so I'm stuck with it.

Is there a fix for this?

Link to post
Share on other sites
It is a known bug with the motion support in Dirt 3.

Are you using any for of motion or gauges or Sim Vibe?

See my post here for more info.

http://forums.codemasters.com/discussion/183/dirt-3-telemetry-and-motion-simulator-bug

Check your settings in the hardware_settings_config.xml file in your \Documents\My Games\DiRT3\hardwaresettings folder

and make sure this line is set like this.

<motion enabled="false" ip="dbox" port="20777" delay="1" extradata="0" />

Link to post
Share on other sites
  • 2 months later...
I didn't realize you answered me.... lololol .... I actually went back to play Dirt 3 tonight, got error 10038, did a google search for it and found the thread I started three months ago!!! 

Anyways, thank you for getting back to me. changing the line begining with <motion enabled... to:

<motion enabled="false" ip="dbox" port="20777" delay="1" extradata="0" />

worked perfectly! thanks!
Link to post
Share on other sites
Codemaster should really fix this Issue with Dirt 3 and Dirt Showdown, as the issue was in GRID 2 also and got fixed! so it can't be that hard to fix this issue without disabling any external gauges or motion sim features!!  because that is what we would like to use!!! and there are a couple of people that would like to use this!
Link to post
Share on other sites
Can someone PLEASE help??? I'm having the exact same sendto failed error when I cross the finish line.. I have the STEAM version as well.. I go into the hardware settings as see everything as you guys explain it except I cannot change anything... Why? I want to change as you've guys suggested but cannot edit the text... How do I do it??? Pls I'm diing to race!! Thank you
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...