Jump to content
  • 0
Sign in to follow this  

F1 2017 Voice Communication in Multiplayer doesnt work

Question

Hello, i searched through some forums already but noone seemed to  have the problem i have..
My problem is about the Online Voice communication between the players. i can see that they talk, for example in the lobby i see their icon blink if they talk and ingame i see the name who talks, but i cant hear them at all. the ingame sound is fine, i can hear the cars, i can hear everything just fine (idk if something maybe sounds a bit different since its a new game but the game gives sound to my headset) 
The other players can hear me, i tested that with friends in the lobby, they told me via steam that they hear me. 
I checked my options few times, my push to talk is ON and i tried changing the audio from automatic "standart" to my headset only. I use a headset but an extra mic, idk if that has anything to do with it just an extra info..
I tried to repair the installation but, nothing was found and after starting it it didnt fix it. 
Idk what i can do to fix it.. 

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0
Got the same Problem, Are you using Windows 10 too? Maybe there must be anything checked on, we have to wait for codies for give us a possible solution. 

Share this post


Link to post
Share on other sites
  • 0
Yes I use win10..I play using my own logitech g430, all sounds work except the vocal chat on multiplayer...i tried to use lg 5.1 speakers but I did the same..i have fx8350 4ghz / gtx1080ti fe..mobo gigabyte.

Share this post


Link to post
Share on other sites
  • 0
Well if i have the time i will try to Check some things with win10 things i Turned off. I think that this is something spezial on win10

Share this post


Link to post
Share on other sites
  • 0
Our league use Discord for in-game comms. It's free. You can set Voice Activity or PTT channels.

You should adjust the Control Panel|Sounds|Communications "When Windows detects communications activity to 'Do nothing'" if you dislike the auto mixer levels and then set them yourself.

We then mute the in-game lobby audio and set PTT to On (map it to something you don't really use). You can still give Jeff voice commands.

Share this post


Link to post
Share on other sites
  • 0
Same problem with Logitech G930, Ryzen 5 1600, RX580, Win10 1703. Another user posted that we should plug te headset into the output from the sound card instead of using the usb.

Share this post


Link to post
Share on other sites
  • 0
I have the same problem. Win 10, GTX 1070, RIG 500 headset.
There is 2 post without answers
http://forums.codemasters.com/discussion/59282/voice-in-multiplayer#latest
http://forums.codemasters.com/discussion/59213/i-expect-no-players-online#latest



Share this post


Link to post
Share on other sites
  • 0
Our league use Discord for in-game comms. It's free. You can set Voice Activity or PTT channels.

You should adjust the Control Panel|Sounds|Communications "When Windows detects communications activity to 'Do nothing'" if you dislike the auto mixer levels and then set them yourself.

We then mute the in-game lobby audio and set PTT to On (map it to something you don't really use). You can still give Jeff voice commands.
As I posted in another thread, voice control randomly broke. Restoring from backup fixed it.

Share this post


Link to post
Share on other sites
  • 0
I've passed this to our test team to see if they can work out what is happening. If you find any other workarounds in the meantime then please let us know.

Share this post


Link to post
Share on other sites
  • 0
Hoo said:
I've passed this to our test team to see if they can work out what is happening. If you find any other workarounds in the meantime then please let us know.
Dear @Hoo

the problem seems appearing on pc as following:

If aplayer uses a usb device - output sign as "standard communicationdevice" ... no voices of the ingame Push to talk hearable.
If u change it to digital output or chinch output...no problems appearing.

Hope you can follow this description,

Greetings.

Share this post


Link to post
Share on other sites
  • 0
Thanks for the reply @Far1an. I'd be keen to know if this helps anyone else who is experiencing this issue!

Share this post


Link to post
Share on other sites
  • 0
Far1an said:
Hoo said:
I've passed this to our test team to see if they can work out what is happening. If you find any other workarounds in the meantime then please let us know.
Dear @Hoo

the problem seems appearing on pc as following:

If aplayer uses a usb device - output sign as "standard communicationdevice" ... no voices of the ingame Push to talk hearable.
If u change it to digital output or chinch output...no problems appearing.

Hope you can follow this description,

Greetings.
USB devices are separate sound controllers. The game always picks up the new sound controller if the game is set to 'default sound device' (which it is by default). Windows 10 almost always sets a new sound controller as the default. This seems then to upset the game until you toggle the game back to the specific device you want to use. This is also what @Far1an is saying.

This I think is also part of the issue with Bluetooth headsets as they appear as a new sound device as well.

@Hoo 

Share this post


Link to post
Share on other sites
  • 0
meme avec le péréphérique par défaut, j'ai aucune voix joueur.

even with the default device, I have no player voice.

Share this post


Link to post
Share on other sites
  • 0
aladinfr said:
meme avec le péréphérique par défaut, j'ai aucune voix joueur.

even with the default device, I have no player voice.

Default device doesn’t work well if there are two or more devices. Select a specific device.

Share this post


Link to post
Share on other sites
  • 0
deja fait, mais rien. je crois que je suis pas le seule dans se cas.
already done, but nothing. I think I'm not alone in this case.

Share this post


Link to post
Share on other sites
  • 0
I'll see if I can find the hardware that you are using and pass this over to our test team.

Share this post


Link to post
Share on other sites
  • 0
Hoo said:
I'll see if I can find the hardware that you are using and pass this over to our test team.
I can replicate it with Realtek HD and GPU audio (I have Nvidia GTX but AMD has HDMI Audio too). Same but worse with SB X-Fi and even worse if I use the USB part of a G430. Any Bluetooth audio or USB headset should replicate it too.

Windows 10 16299.192 and game patch 1.11

Share this post


Link to post
Share on other sites
  • 0
Bonjour, j'ai essayer avec les versions précédentes f1 2016, f1 2014 et j'attends bien les voix des autres joueurs, donc il y a bien quelque chose qui ne vas pas sur f1 2017.
Hello, I try with the previous versions f1 2016, f1 2014 and I'm waiting for the voices of other players, so there is something wrong with f1 2017.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×