Jump to content Jump to content

Black screen when starting the game F1 2017?


Vmwar

Recommended Posts

When the game opens pres Alt + Enter, that'll put the game in windowed mode and it should start fine, at least, it did for me. Unfortunately the fullscreen seems to be bugged if the resolution of the game is different to the resolution of the monitor. Best bet is to do that then change resolution settings, and to be sure it doesn't black screen anymore use either "borderless (fullscreen)" or "windowed" mode, don't use the "fullscreen" mode
Link to post
Share on other sites
TorqueZ31 said:
Looks like you have F1 2016 running at the same time you're trying to start F1 2017?  Reboot, launch F1 2017.

Calling for a patch when you haven't even performed troubleshooting on your own PC?  That's shameful in my book.
It's funny. I run in the window and nothing works. Is it in my pc? All games go except this one. Maybe still a patch. There was no crash dump in the steam folder. super!
Link to post
Share on other sites
Your screenshot shows two games running at the same time, are you sure you don't have F1 2016 running in the background and you're trying to start F1 2017?  That could definitely cause an issue with it not starting or only getting to the black screen.

Off the top of my head without more information, try the following options:

Try verifying the game cache in Steam.

Try going to My Documents\My Games and delete the F1 2017 folder, then try starting the game again.  

Try setting sound options to 48000hz.  This game seems to be more picky about that setting on my system, but it may just be my setup.

Try going into the F1 2017 install location and running the DirectX and Visual C++ installers again, use the Repair option if available. (if installed on C: drive in  the typical Steam location, the installers I'm talking about reside here -- C:\Program Files (x86)\Steam\steamapps\common\F1 2017\_CommonRedist)

Try reinstalling your Nvidia driver, utilizing the "clean install" option.

Lastly, if nothing else else seems to be working, you could try uninstalling the game entirely and reinstalling it via Steam.

If I think of anything else I'll come back and write it out.
Link to post
Share on other sites
TorqueZ31 said:
Your screenshot shows two games running at the same time, are you sure you don't have F1 2016 running in the background and you're trying to start F1 2017?  That could definitely cause an issue with it not starting or only getting to the black screen.

Off the top of my head without more information, try the following options:

Try verifying the game cache in Steam.

Try going to My Documents\My Games and delete the F1 2017 folder, then try starting the game again.  

Try setting sound options to 48000hz.  This game seems to be more picky about that setting on my system, but it may just be my setup.

Try going into the F1 2017 install location and running the DirectX and Visual C++ installers again, use the Repair option if available. (if installed on C: drive in  the typical Steam location, the installers I'm talking about reside here -- C:\Program Files (x86)\Steam\steamapps\common\F1 2017\_CommonRedist)

Try reinstalling your Nvidia driver, utilizing the "clean install" option.

Lastly, if nothing else else seems to be working, you could try uninstalling the game entirely and reinstalling it via Steam.

If I think of anything else I'll come back and write it out.
Good news. It was run in windowless mode. I did all those points that you said. I thought the schedule was worse or it seems to me? 
Link to post
Share on other sites
TorqueZ31 said:
Your screenshot shows two games running at the same time, are you sure you don't have F1 2016 running in the background and you're trying to start F1 2017?  That could definitely cause an issue with it not starting or only getting to the black screen.

Off the top of my head without more information, try the following options:

Try verifying the game cache in Steam.

Try going to My Documents\My Games and delete the F1 2017 folder, then try starting the game again.  

Try setting sound options to 48000hz.  This game seems to be more picky about that setting on my system, but it may just be my setup.

Try going into the F1 2017 install location and running the DirectX and Visual C++ installers again, use the Repair option if available. (if installed on C: drive in  the typical Steam location, the installers I'm talking about reside here -- C:\Program Files (x86)\Steam\steamapps\common\F1 2017\_CommonRedist)

Try reinstalling your Nvidia driver, utilizing the "clean install" option.

Lastly, if nothing else else seems to be working, you could try uninstalling the game entirely and reinstalling it via Steam.

If I think of anything else I'll come back and write it out.

Remove the driver using DDU then Clean Install.

48000Hz is available at 2 resolutions, 16 and 24-bit on my driver (RealtekHD v2.82 W10)

Otherwise, great list of suggestions.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...