Jump to content
  • 0
Sign in to follow this  

F1 2017 minnimum requirements too low fps

Question

Hi,
I've had some issues regarding the F1 2017 game (Pc), at first i couldn't even change the settings cause i had a black screen i couldn't avoid, in the end i uninstalled the game, downloaded it again and reinstaled.
That seem to solve the issue. But my surprise comes when i find the game is running at maximum 5 fps everything is super slow motion. I checked the Minnimum Requirements and i pass them so i couldn't understand how i cannot run a game at least at lower graphics with my specs, as i could run everything i tried at high or max:

RX480
i5 6500 3.2Ghz
8Gb Ram

If someone can find what is going on i can add a Dxdiag to check if everything is alright on my part.
(I installed latest Radeon drivers, DirectX and vc_redist64).

Thanks for the help.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0
Can you try to delete the folder F1 2017 in MyDocuments/My Games/ and give it another try ?

Share this post


Link to post
Share on other sites
  • 0
Well it´s not the first thread where Radeon Cards are struggeling with F1 2017. Maybe it´s a Driver Thing?!?


Share this post


Link to post
Share on other sites
  • 0
Pilon said:
Well it´s not the first thread where Radeon Cards are struggeling with F1 2017. Maybe it´s a Driver Thing?!?


I actually was looking for this when i had the black screen issue, here:
http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-17.8.2-Release-Notes.aspx

It explains that the

Radeon Software Crimson ReLive Edition 17.8.2 Highlights

Support For

  • F1™ 2017
    • Up to 4% performance improvement measured on Radeon RX Vega 64 graphics when compared to Radeon Software Crimson ReLive edition 17.8.1(1)
i don't think it's related but maybe they find something and release another version of this. I don't know. Thanks for sharing your view.

Share this post


Link to post
Share on other sites
  • 0
Definitely something wrong with your PC, you should be able to run Ultra High @ 1080p at 60+ FPS.  What does CPU and GPU utilization look like when you're running the game?  Are other games affected?  What resolution are you playing at?

Share this post


Link to post
Share on other sites
  • 0
TorqueZ31 said:
Definitely something wrong with your PC, you should be able to run Ultra High @ 1080p at 60+ FPS.  What does CPU and GPU utilization look like when you're running the game?  Are other games affected?  What resolution are you playing at?
Hi TorqueZ31. The resolution of my screen (ultrawide), is 2560x1080
None other games affected at the moment.

GPU core clock goes from 300Mhz to 1280Mhz
GPU memory clock from 300Mhz to 2000Mhz
all fans start to spin much faster but everything else stays stable.


Share this post


Link to post
Share on other sites
  • 0
Varoken said:
Pilon said:
Well it´s not the first thread where Radeon Cards are struggeling with F1 2017. Maybe it´s a Driver Thing?!?


I actually was looking for this when i had the black screen issue, here:
http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-17.8.2-Release-Notes.aspx

It explains that the

Radeon Software Crimson ReLive Edition 17.8.2 Highlights

Support For

  • F1™ 2017
    • Up to 4% performance improvement measured on Radeon RX Vega 64 graphics when compared to Radeon Software Crimson ReLive edition 17.8.1(1)
i don't think it's related but maybe they find something and release another version of this. I don't know. Thanks for sharing your view.


At least it's not just Nvidia making the drivers for latest cards and not mainstream ones.

You can count the players using that card on this game on one finger probably.

Share this post


Link to post
Share on other sites
  • 0
Varoken said:
TorqueZ31 said:
Definitely something wrong with your PC, you should be able to run Ultra High @ 1080p at 60+ FPS.  What does CPU and GPU utilization look like when you're running the game?  Are other games affected?  What resolution are you playing at?
Hi TorqueZ31. The resolution of my screen (ultrawide), is 2560x1080
None other games affected at the moment.

GPU core clock goes from 300Mhz to 1280Mhz
GPU memory clock from 300Mhz to 2000Mhz
all fans start to spin much faster but everything else stays stable.


What are the CPU and GPU usage percentages?  What happens if you drop the video settings to Ultra Low, any change in FPS?

Share this post


Link to post
Share on other sites
  • 0
For what it's worth, I'm using an RX470 and an i5-4690k and I'm able to run it at 1080p on the high preset (texture streaming on ultra high though) and my Anti-Aliasing is on TAA, I get 60FPS all the time except in the pitlane and the pre-race bits. Have you tried running the game fullscreen/borderless windowed? Is the game staying as the foreground task on your PC? I've not got the latest driver version.

Share this post


Link to post
Share on other sites
  • 0
If you can, try to Power the Resolution zu 16:9 Resolution (1920*1080). When the frames are Not a Problem there, i think, that is maybe a Performance bug in f1 2017.

Share this post


Link to post
Share on other sites
  • 0
Varoken said:
Thanks for the help.
Hi @Varoken
Are you sure, you chose the right gfx card for running the game. Had this two years ago that my system did not recognize the game and therefore used my build in Intel gfx chip, so the results were horrible. I had to choose the option to run the game with my real gfx card in the gfx cards settings. Hope that helps you! 

Share this post


Link to post
Share on other sites
  • 0
@TorqueZ31 The percentage of Cpu and Gpu both were max 50 to 58%
@Pilon I can change the aspect ratio but it doesn't seem to work properly, and i cannot change the resolution at all... maybe it has something to do with my screen.
@heideldrum i used the gfx app and it didn't change anything, appearently.

Thanks again, i'm gonna check if everything about my screen is fine and working.

Share this post


Link to post
Share on other sites
  • 0
Varoken said:
Hi,
I've had some issues regarding the F1 2017 game (Pc), at first i couldn't even change the settings cause i had a black screen i couldn't avoid, in the end i uninstalled the game, downloaded it again and reinstaled.
That seem to solve the issue. But my surprise comes when i find the game is running at maximum 5 fps everything is super slow motion. I checked the Minnimum Requirements and i pass them so i couldn't understand how i cannot run a game at least at lower graphics with my specs, as i could run everything i tried at high or max:

RX480
i5 6500 3.2Ghz
8Gb Ram

If someone can find what is going on i can add a Dxdiag to check if everything is alright on my part.
(I installed latest Radeon drivers, DirectX and vc_redist64).

Thanks for the help.
Shut down the game, delete the hardware_settings_config file, disable the onboard GPU in UEFI and restart the game.

That will definitely make your GPU run the game.

Share this post


Link to post
Share on other sites
  • 0
The thing i've found is that the game always starts at the same resolution and aspect ratio, no matter if i delete the "hardware_settings_config" file, or even changing in that file the resolution and aspect ratio. I am using the AMD app (image), to launch the game so it doesn't use the incorrect GPU. Nevertheless i cannot find a way to prevent the computer to use the built in graphic device, it seems there isn't any in the device manager (image2).



Don't really know what else to do. Thanks again for all the responses.

Share this post


Link to post
Share on other sites
  • 0
In the end, i asked Codemasters support for some help, and after tryinbg everything they asked for, this worked just fine:

1) Uninstall the game
2) Clear out your C:\Windows\Temp folder. Also clear out your c:\Documents and settings\[username]\Local settings\Temp folder
3) Run Disk Error Checking. Right click on your hard drive and select properties then tools to do this.
4) Run Defragmentation from the same menu.
5) Ensure that no background programs or utilities are running - particularly anti-virus software - by right clicking on any icons in your system tray and selecting disable/exit or the equivalent option
6) Disable your soundcard, from the device manager (let us know if need further help doing this)
7) Re-install the game
8) Re-enable your soundcard

Thanks to all for the help.
Cheers.

Share this post


Link to post
Share on other sites
  • 0
Varoken said:
In the end, i asked Codemasters support for some help, and after tryinbg everything they asked for, this worked just fine:

1) Uninstall the game
2) Clear out your C:\Windows\Temp folder. Also clear out your c:\Documents and settings\[username]\Local settings\Temp folder
3) Run Disk Error Checking. Right click on your hard drive and select properties then tools to do this.
4) Run Defragmentation from the same menu.
5) Ensure that no background programs or utilities are running - particularly anti-virus software - by right clicking on any icons in your system tray and selecting disable/exit or the equivalent option
6) Disable your soundcard, from the device manager (let us know if need further help doing this)
7) Re-install the game
8) Re-enable your soundcard

Thanks to all for the help.
Cheers.
WTF is that about reinstalling the game with the sound card disabled all about? :smiley:

And thanks for posting what worked for you.

Share this post


Link to post
Share on other sites
  • 0
Varoken said:
In the end, i asked Codemasters support for some help, and after tryinbg everything they asked for, this worked just fine:

1) Uninstall the game
2) Clear out your C:\Windows\Temp folder. Also clear out your c:\Documents and settings\[username]\Local settings\Temp folder
3) Run Disk Error Checking. Right click on your hard drive and select properties then tools to do this.
4) Run Defragmentation from the same menu.
5) Ensure that no background programs or utilities are running - particularly anti-virus software - by right clicking on any icons in your system tray and selecting disable/exit or the equivalent option
6) Disable your soundcard, from the device manager (let us know if need further help doing this)
7) Re-install the game
8) Re-enable your soundcard

Thanks to all for the help.
Cheers.
**** is that about reinstalling the game with the sound card disabled all about? :smiley:


In fact what really got the problem solved was to delete those temp folders... i wonder why some temp archives may cause so many problems...
The sound card was disabled beacuse there was some noise at the beginning, to prevent it to interfere.


Share this post


Link to post
Share on other sites
  • 0
Good day, can you help me? I also have very few FPS.
 Laptop configuration
Windows 8.1 64x
Pocessor intel I5 3210m 2, 5GHZ Turbo Bust 3,1ghz

Videocard AMD radeon 7600m 2gb and Intel hd 4000
Ram 8gb 

Hdd 1tb


Is it possible to disconnect shadows and people?

Share this post


Link to post
Share on other sites
  • 0
Yagub said:
Good day, can you help me? I also have very few FPS.
 Laptop configuration
Windows 8.1 64x
Pocessor intel I5 3210m 2, 5GHZ Turbo Bust 3,1ghz

Videocard AMD radeon 7600m 2gb and Intel hd 4000
Ram 8gb 

Hdd 1tb


Is it possible to disconnect shadows and people?

In the Advanced Graphics Settings you can turn Shadows and Crowd to Low.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×