Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

Scripted / Generated AI lap times in Qualifying

Recommended Posts

Just noticed another issue with times. In practice session theoretical best (which should be best sectors combined) shows as 1:41.2 even though 3 drivers have lap times sub 1:41. This combined w not getting fastest sector rewards (as I also mentioned in another thread, at the end if a race my best lap time on timing and scoring was over a second faster than my teammates yet at rivalry update after the race it gave him a time for fastest lap a half second faster than mine that was faster than his best lap on timing and scoring and gave him a point for fastest lap) and all the other timing issues seems to me to mean something is just totally out of whack with the games ability to properly track lap/sector times. 

(After about 10 minutes the timings sheet finally updated to reflect the proper theoretical best)

Share this post


Link to post
Share on other sites
As I posted elswhere my controller config is also not loading properly. I have to reload it any time I start a new session to restore ffb settings and every new location to restore button config. This has me wondering now if part of the problem w the times during practice and quali is that the proper AI difficulty is not getting loaded either outside of race session. Also explains why ppl at higher difficulty dont notice as much of a problem as the difficulty they are getting loaded with more closely matches their desired and chosen difficulty level. 

Edit: just wanted to add that at the beginning I was asked to import data from my f1 2016 save. To rule out that causing some sort of corruption I'm now clearing my save data and starting a new driver without importing the old save. 

Share this post


Link to post
Share on other sites
daemun said:
As I posted elswhere my controller config is also not loading properly. I have to reload it any time I start a new session to restore ffb settings and every new location to restore button config. This has me wondering now if part of the problem w the times during practice and quali is that the proper AI difficulty is not getting loaded either outside of race session. Also explains why ppl at higher difficulty dont notice as much of a problem as the difficulty they are getting loaded with more closely matches their desired and chosen difficulty level. 

Edit: just wanted to add that at the beginning I was asked to import data from my f1 2016 save. To rule out that causing some sort of corruption I'm now clearing my save data and starting a new driver without importing the old save. 

Can you update and say if this worked? Many thanks. 

Share this post


Link to post
Share on other sites
On melborne now. All I can say so far is that the times for AI in p1 seem pretty much the same whether difficulty is set to 70 (my initial season) or 80 (current season). In both cases they were running 1:26-1:28. 

Share this post


Link to post
Share on other sites
@F1Support thanks very much for responding to this. This is pretty much a game breaker for me. Especially when the AI does dry times on a wet track as a result of this. Please make sure that is also taken into account when you are looking at this bug. In the meantime. good to see there are workarounds, so I can keep playing as now that the durability issues are getting sorted, the game is otherwise amazing.

Share this post


Link to post
Share on other sites
@F1Support:
Fix isnt included in Patch 1.06 as Promised?!?
I think a huge Part of the Community expexted this! As well as you confirmed it!?!
We would be thankfull if you would give us an Update...

Share this post


Link to post
Share on other sites
JayJay686 said:
@F1Support:
Fix isnt included in Patch 1.06 as Promised?!?
I think a huge Part of the Community expexted this! As well as you confirmed it!?!
We would be thankfull if you would give us an Update...
This is honestly the part that annoyed me the most, is that @F1Support said it would be worked on for 1.6, then the patch comes and it's not in there. Now as far as I know there is no word at all on when this is going to be fixed. Is it coming in the 1.7 patch? Has anybody said? Is it too great a bug that we might not see a fix for some time? Like others have said, this bug, along with the AI being too fast overall in Quali, is destroying career mode. An update would be appreciated...

Share this post


Link to post
Share on other sites
I have just played a Short Qualifying and time was out, I choosed back to garage (on 4th place) ,time table appears.... 8th!!! Massa have had a 1:13:566 and now he overtook me. Game scripted him a 1:11:621 ....! 2 sec faster...
Nothing new but every time it happens I'M GETTING SO ANGRY!!!!
Who the f*** is porgraming this?!?
And I really dont get it: the 4th patch will be released this week amd this issue still isnt fixed!
I dont know what to say anymore...

Share this post


Link to post
Share on other sites
JayJay686 said:
@F1Support:
It was already mentioned in a few Threads and I thought the most worst annoying thing are the blurred textures but after starting my career its definately the damn scripted AI times! They are destroying the whole experience and "work" in qualifying! The AI level 74 is just perfect for me. If I watch AI driving the lap times are fine. But every time thw drivers gets scripted times its annoying!
Please change it as it was in 2016 game where it was fine!

Its Q2 and I'm on 7th... its starts to rain.. I choose back to the pits.. I'm still on 7th.. only a few Seconds left.. I choose "go to track" (driving out of pits)... I see on my steering wheel I'm still on 7th when  I choose back to Garage again (still raining) .. the time is over of course because the game simulates the way back to pits.. and then the time table appears... I'm on 11! 

...its even simulated if you are in pit and watching "live".. when time is 0:00 it immediately stops and the time table appears even if there are still AI on a hot lap!! And what happened? Yes the times are simulated and I fall down from 8th to 15th!

THE SIMULATED TIMES ARE 1-1,5 SECONDS FASTER THEN THE AI IS DRIVING REAL!!

PLEASE CM LET US KNOW IF YOU ARE AWARE OF IT AND IF A FIX IS PLANNED!

This is a gamebreaker for me :-(

gamebreaker for me too 

Share this post


Link to post
Share on other sites
I just had the case that I crashed in Raikkonen in a race and both of us lost a wheel. I quit the race and in the end result Raikkonen was on 4th place.... come on...this is ridicolous!!!!

Share this post


Link to post
Share on other sites
JayJay686 said:
I just had the case that I crashed in Raikkonen in a race and both of us lost a wheel. I quit the race and in the end result Raikkonen was on 4th place.... come on...this is ridicolous!!!!
This one is just awesome. Fully reveals the extent to which ai simulation os broken and not being tracked properly by the game. 

Share this post


Link to post
Share on other sites
JayJay686 said:
I just had the case that I crashed in Raikkonen in a race and both of us lost a wheel. I quit the race and in the end result Raikkonen was on 4th place.... come on...this is ridicolous!!!!
that was already in last years game...

Share this post


Link to post
Share on other sites
You're mixing up the fix isn't in the patch with fix isn't in the patch notes. I'll get that omission corrected.

Share this post


Link to post
Share on other sites
F1Support said:
You're mixing up the fix isn't in the patch with fix isn't in the patch notes. I'll get that omission corrected.
So is it fixed in 1.6 or Not?
Sorry I didnt get it :neutral:

Share this post


Link to post
Share on other sites
JayJay686 said:
F1Support said:
You're mixing up the fix isn't in the patch, with fix isn't in the patch notes. I'll get that omission corrected.
So is it fixed in 1.6 or Not?
Sorry I didnt get it :neutral:
You're mixing up the fix isn't in the patch, with fix isn't in the patch notes. I'll get that omission corrected.
 
Yes it's fixed.

I work in a school so I fixed his punctuation.  :D

Share this post


Link to post
Share on other sites
*edit* just seen post above, nice one.

I think @F1Support means yes it was fixed in 1.6, just wasn't included in the notes. I can't speak for anyone else but my game no longer has this issue since the patch, so yeah well done CM.

Share this post


Link to post
Share on other sites
can we get any information what exactly got fixed? Has quali made easier in general? Or has only the laptimes with wrong weathercondition in changeable conditions been fixed?

Share this post


Link to post
Share on other sites
I've tested on 3 races now and all I know is all AI is now consistent in their times throughout all sessions, so FP is same as Quali is same as race. And generated lap times also appear to be consistent with nobody jumping in front of my time at the last minute any more. Speeding the game up has no adverse effect, so i'm back to doing full qualifying. I don't know about the weather variable as I haven't tested that. I only tested on dry tracks. Would be nice to get more info on exactly what was fixed and see if anyone else is still having the issue, but it does seem to have gone a lot quieter since 1.6.

Share this post


Link to post
Share on other sites
Kinda sad I paid for this again this year honestly. Handling is much better but I kinda think thats more due to regulation changes. Its just another copy paste of f1 from codemasters for the last 5+ years. All they did was add some pointless cut scenes w the same terrible character models (while still retaining old cutscenes with nothing changed but some texture or lighting, ffs theres even a scene where you have to sit and wait for someone to take a fracking phone call) and chopped upgrades up into more options. Broken as evidenced by mclaren. Same old gameplay, same bugs year after year. Same crap scripted ai times. Codemasters? More like Copymasters. 

Share this post


Link to post
Share on other sites

×