Jump to content Jump to content

D3D device was removed


Killerbob

Recommended Posts

@F1Support
 Anyone looking into this issue seems to be happening for a lot of users.

I have sent you my DXDiag and crash dumps in a pm

Steps I have tried are:

Lowering all graphic settings to Ultra Low - Same error
Reinstalling graphics drivers
Removing all Nvidia software and only installing Graphics driver and PhysX
Removing graphics driver and letting Windows updates install it
Reverting back to driver 384.76

The problem is better than it was but it still crashes with the same error after I go back to Garage from the pause menu.
Link to comment
Share on other sites

This happened to me too, I fixed it by going to some older drivers.

AMD R9 Nano.

With the latest 17.8.2 drivers, I got the 'D3D device has been removed' error and the game would not start.

I installed 17.4.4 instead and the game runs fine.

I hope this can be fixed as I prefer to use more recent drivers.
Link to comment
Share on other sites

  • 3 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...