Jump to content Jump to content

Steering issues after patch


crudeterminator

Recommended Posts

I have been playing F1 2017 since it's release and been enjoying the game. After the patch that was released on the 4th September the steering has been messed up. I use a Thrustmaster 458 Italia steering wheel. The issue is that the car steers on it's own to a certain level, almost like a weak steering assist but it fights me in most places and causes me to swerve around rather than be able to actually drive the car.
Link to post
Share on other sites
kingmjj said:
I always thought that was the wind blowing on the shark fin because it would do a minor steer in a straight line 
I am sure it isn't the wind due to the fact the driver is turning the wheel on the straight without me doing anything, plus it was not an issue before the latest patch.

I have gone through all of the settings I can find but can't find anything to do with a steering assist.
Link to post
Share on other sites
Exact same issue but with PS4 controller. I also thought it was wind at first but it can't be because it only ever swerves to the left and never the right. Also when turning, I will be applying full lock then all of a sudden the wheel straightens out for half a second. I've had to turn flashbacks on because it happens at least 3 times per race.
Link to post
Share on other sites
I made an identical thread earlier this week explaining the exact same issue.

The car suddenly drifts off to one side of its own free will.

Other commenters suggested it might be the wind, but my observations don't tally with that.

I assumed it was the circuit, perhaps a camber issue, which sees the car start to drift off line as the track drops away to one side ever so slightly. 

That is the only logical conclusion I have, assuming it is an organic incident caused by realistic physics and not a bug.

It is easily corrected and isn't as severe as it could be if there were a bug, so I'm thankful for that.
Link to post
Share on other sites
I made an identical thread earlier this week explaining the exact same issue.

The car suddenly drifts off to one side of its own free will.

Other commenters suggested it might be the wind, but my observations don't tally with that.

I assumed it was the circuit, perhaps a camber issue, which sees the car start to drift off line as the track drops away to one side ever so slightly. 

That is the only logical conclusion I have, assuming it is an organic incident caused by realistic physics and not a bug.

It is easily corrected and isn't as severe as it could be if there were a bug, so I'm thankful for that.
I have tried various tracks and it occurs on all tracks almost all the way around. I also tried using a controller just to test and it did not happen at all, therefore I believe it is a bug introduced with the last patch that affected my wheel. I really don't know what to do about it
Link to post
Share on other sites
So I've done a bit of testing, and I've found that it is definitely a bug rather than a problem with the controller. Baku in particular is a lot worse than any of the other tracks. On the straights the driver will randomly swerve to the left but quite sharply compared to other tracks. If you leave it and don't correct it, it carries on swerving as if you are pushing the analog stick to the left unlike how a "gust of wind" would blow a car slightly offline in reality. Also, at the chicane just before the castle section, when you turn left and then have to do the quick right, the car doesn't turn at all even though you are applying full lock. It happens at all speeds. but only at that particular turn. It doesn't happen at Spain at the final chicane which is a very similar set of turns so it can't be hardware related.
Link to post
Share on other sites
I don't have any game capture hardware so I can't post a video, sorry. I'm using my PS4 controller on my PC. I first noticed it after patch 1.6 went live in my career mode. Then did some tests in Grand Prix mode and its the same as in the career mode. Also, did some calibration tests using ds4 software and the controller input seems perfect. The controller also works perfectly with other games. Which leads me to believe it has to be a bug.
Link to post
Share on other sites
Have you tried recalibrating the controllers?
After the patch got released today I had a go hoping that that had fixed the issue. It hasn't. I have updated the drivers for my wheel, re-calibrated it, it seems to be working perfectly. The issue occurs on any mode I try to drive, as I said earlier I don't have the issue with a controller although I know others here have (Xbox 360 controller I used for the test). The game in unplayable as the car swerves down the straight and fights me in the corners, it is every track, all track.
Link to post
Share on other sites
I had this issue with 2016 and now 2017, was hoping it was just a 2016 issue, sadly not. It really does make the game pretty much unplayable. Will there be a fix for this? The car just veers violently to the left. It's even worse around other cars. You invest so much time in a race and then have to pit for a damaged wing because of a bug. Lot of money for a game with such a bad bug. Was this beta tested??
Link to post
Share on other sites
  • Codemasters Staff
Hi @Jestifizzle77, have you tried running the game without the DS4 software? We believe this is what may be causing the issue in your case.

Hi @crudeterminator, do you have any other peripherals connected to your PC/console? 
Link to post
Share on other sites
CmRachel said:
Hi @Jestifizzle77, have you tried running the game without the DS4 software? We believe this is what may be causing the issue in your case.

Hi @crudeterminator, do you have any other peripherals connected to your PC/console? 
Hi @CmRachel

I have tried playing it without the DS4 software "running" (ie: there are no DS4 processes running), but still no result. Do you suggest I uninstall the DS4 software altogether and try?
Link to post
Share on other sites
Exact same issue but with PS4 controller. I also thought it was wind at first but it can't be because it only ever swerves to the left and never the right. Also when turning, I will be applying full lock then all of a sudden the wheel straightens out for half a second. I've had to turn flashbacks on because it happens at least 3 times per race.
I have the same thing, going full lock, and mid corner it just straightens. Then I have to release, and go full lock again to make it steer again. I made my own topic about it. I hope it get fixed. I use PS4 DualShock on PS4 btw
Link to post
Share on other sites
  • Codemasters Staff
Hi @Jestifizzle77, no you shouldn't need to uninstall the DS4 software altogether but it's up to you if you want to give that a go.

Hi @TheComedian97, what assists are you using? It could just be that the tyres are locking up. Turning on Anti-Lock Brakes will stop this from happening.

I hope this helps.
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...