Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

[PC] No steering weight using a G29, but other FFB effects present?

Recommended Posts

Hi, I've been having an issue since installing the Forza 7 Demo and trying it out. Afterwards, entering F1 2017, the steering weight has suddenly disappeared. All other FFB effects like the kerb vibrations still work fine, just not the steering weight. I've tried uninstalling the wheel, upgrading Logitech Gaming Software, and even cleaning the old drivers using Logitech's tool. I've changed USB ports too. I've tried deleting the control profile and creating a new one, but this doesn't solve the problem. Clearly the wheel is being recognized, but only the wheel weight is not correctly defined. Any one with a solution?

P.S. The Flashback button doesn't work properly either. I've set it to the square button on the wheel, and pushing it does activate the flashback option sequence, but I can't press square again to resume the game from the chosen point. Instead, I have to press F1. Why is this happening?

Share this post


Link to post
Share on other sites
nfshp253 said:
Hi, I've been having an issue since installing the Forza 7 Demo and trying it out. Afterwards, entering F1 2017, the steering weight has suddenly disappeared. All other FFB effects like the kerb vibrations still work fine, just not the steering weight. I've tried uninstalling the wheel, upgrading Logitech Gaming Software, and even cleaning the old drivers using Logitech's tool. I've changed USB ports too. I've tried deleting the control profile and creating a new one, but this doesn't solve the problem. Clearly the wheel is being recognized, but only the wheel weight is not correctly defined. Any one with a solution?

P.S. The Flashback button doesn't work properly either. I've set it to the square button on the wheel, and pushing it does activate the flashback option sequence, but I can't press square again to resume the game from the chosen point. Instead, I have to press F1. Why is this happening?
Join every other disappointed Logitech owner. The F1 games always end up 'floaty'. Either they don't test with our wheels or the patches do something to wreck the feel.

F1 2015 - Combined axis, brakes locked on. Didn't play the game, reverted to using F1 2013 for 1 league season. Played on F1 2015 for a short season, felt floaty by comparison (after patch cycle finished). Spent less than 80 hours on the game.
F1 2016 - Day 1 brilliant feel, round about the time of the AMD optimization patch, the feel went back to F1 2015 style. Floaty and inconsistent handling the order of the day.
F1 2017 - Beta testing was excellent in terms of wheel feel. Fixing the FFB glitch over patches 1.4-1.6 has reverted the feel to previous lows. Crock of **** (self-censored).

Played Bahrain last night, wheel decentered during qualifying, corrected for the race, understeer most of the latter stages although it didn't appear to have changed my setup, so can't blame the 'lost setup' bug or the 'default setup' bug.

Patch 1.8? *Fingers crossed* *Brain says "Of course they won't fix it"*

Share this post


Link to post
Share on other sites
Yea I have the same wheel and the exact same problem. Problems started after 1.7 patch and after installing PC2... GG codemasters

Share this post


Link to post
Share on other sites
Seems like it isn't Codemasters' fault, but PC2's fault. I had to uninstall PC2, remove all its user settings, uninstall the wheel drivers and LGS, plus clean the registry of all Logitech traces. After restarting and reinstalling LGS, the FFB in F1 2017 returns to normal.

The problem also happened for me in Euro Truck Simulator 2. Doing the above steps also fixed the problem. So, the culprit is Project Cars 2.

Share this post


Link to post
Share on other sites
But it literally works perfectly on every single other game I've tried. So I'd say that codemasters is fucking something up here. I'll stick to PC2.

Share this post


Link to post
Share on other sites
nfshp253 said:
Seems like it isn't Codemasters' fault, but PC2's fault. I had to uninstall PC2, remove all its user settings, uninstall the wheel drivers and LGS, plus clean the registry of all Logitech traces. After restarting and reinstalling LGS, the FFB in F1 2017 returns to normal.

The problem also happened for me in Euro Truck Simulator 2. Doing the above steps also fixed the problem. So, the culprit is Project Cars 2.
A controller should be capable of handling more than one profile for more games.

Many problems arise after installing F1 2017 or updating it.

Devs do realise that the G series wheels are console devices with a separate PID when used on PC don't they? e.g. G920 detects as XBox Controller (PID 0xc261) and ONLY when installing LGS does it correctly get identified as G920 (PID 0xc262).

There is a methodology for removing the traces. I've posted it previously, but unless I star all my posts, the forum database loses it, thread tracking and searching is terrible. I'm not at my gaming PC.

Share this post


Link to post
Share on other sites
dorgao said:
Same thing here, just after installing PC2 the problems begun.
Finger trouble?
Brazilian internet trouble, tried to delete the duplicate but I couldn't.

Share this post


Link to post
Share on other sites
F1Support said:
@nfshp253

Have you tried uninstalling the Forza 7 demo?
It was determined that Project Cars 2 was the culprit. There's no need to remove the Forza 7 Demo.

Share this post


Link to post
Share on other sites
Hi, same problem after installing Pcars2, but after unistalled it and deleted register files for logitech, the problem is still there . . .

Share this post


Link to post
Share on other sites
nfshp253 said:
Seems like it isn't Codemasters' fault, but PC2's fault. I had to uninstall PC2, remove all its user settings, uninstall the wheel drivers and LGS, plus clean the registry of all Logitech traces. After restarting and reinstalling LGS, the FFB in F1 2017 returns to normal.

The problem also happened for me in Euro Truck Simulator 2. Doing the above steps also fixed the problem. So, the culprit is Project Cars 2.
Can you explain step by step how you did that exactly please? Cause I'm not that good on pc.. And I have the exact problem. I deleted pc2 but still have the same problem. Thanks 

Share this post


Link to post
Share on other sites

×