Jump to content


This topic is now archived and is closed to further replies.

T80 wheel not recognised as device on PS4 after trying to set wheel to Need For Speed

Recommended Posts

Recently we tried to set up the T80 wheel on our PS4 to use with Need For Speed.  Apparently the wheel does not work with Need For Speed.  Anyway, super keen user of F1 2016 we think its great. Now we having all sorts of problems using the T80 wheel with F1 2016 and even on Project Cars.  The PS4 settings and the game settings only recognise the DualShock4 controller and in "Devices" on the pS4 setting only the DualShock Controller shows and not the T80.  I have done the bit where you unplug the usb and of the wheel, hold the PS button and plug back in to watch the red light flash etc and still no joy.  So evidently trying to set Need for Speed with the T80 has altered something somewhere.  If any one can tell me how we fix this we would be most grateful.  

Share this post

Link to post
Share on other sites