Jump to content
  • 0
Sign in to follow this  

F1 2017 (PC) - Logitech G920 - No braking/acceleration feedback/vibration

Question

 The force feedback works, but I have no vibration/feedback when my tyres are about to lock up or when i'm losing grip and about to spin out.

It only happens in F1 2016 and F1 2017. I have this feedback when playing other games.

Edit: I forgot to mention that it only happens on track... off track it works.

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0
Someone else reported the exact same thing but I'll be damned if I can find the thread. Don't think it was solved though.

Share this post


Link to post
Share on other sites
  • 0
I tested 4 wheels on console and also on PC. None wheels had feedback when slipping/braking/accelerating.
Tested 5 games, Assetto Corsa, Project Cars, American Truck Simulator, F1 2016 and F1 2017.

The "Slip Effect" was missing only in F1 2016 and F1 2017. (In F1 2017 it was working fine before last patch).
No doubt that the problem is in F1 games.

We should have individual sliders for the track effects than a single one 'On track' slider, so we could fine tune as we like.

Share this post


Link to post
Share on other sites
  • 0
There's basically only understeer enhance and rumblestrip effect apart from track effect.

AC and PCARS lean more towards Sim than the Simcade that F1 is to cater for the 'casual' player. The other games you mention have other car types entirely so are bound to have extra settings.

You want to be glad you never tried F1 2015! :)

Share this post


Link to post
Share on other sites
  • 0
Thanks for reply. I agree with you. But it was working properly before the last patch. Also for some friends of mine, it's still working properly. Once it starts to happen after the last patch, then it has something to do with the patch itself.

I no longer feel the "Understeer enhance" or any kind of grip or loss of grip.
I can barely feel the effect if I turn everything to the highest like 150, 100, 100, 100,100, on. I used to feel the effect at 90, 40, 60, 20, 100, until the lastest patch.

It's also happening on my cousin's console.

The same wheel (tested 4 wheels) should work the same in the same game. I know the FFB is not like that in this game because it was working fine before the patch.
The last patch affected some players and the @F1Support should do something about it. If they don't want, or can't do it, so give sliders to us for fine tune some specific effect. But something should be done.

Share this post


Link to post
Share on other sites
  • 0
Hello, I've spoken to the handling guys and they have used this wheel recent with no issues. Have you got the latest driver and firmware for your wheel?

Share this post


Link to post
Share on other sites
  • 0
F1Support said:
Hello, I've spoken to the handling guys and they have used this wheel recent with no issues. Have you got the latest driver and firmware for your wheel?
@F1Support Yes, the firmware and software are up to date.

My game is PC version. My cousin is having the same problem on xbox. A friend of mine is having the same problem too on PC version. And only another friend of mine is getting the proper feedback.

The feedback itself works fine. We just dont have the vibration when braking/sliding/acceleration. It's like the track effects were overlaying this effect.

We tested all 4 wheels in all machines. All the wheels works fine in 1 PC and also all 4 wheels have this problem with 2 PCs and 1 xbox.

All the 4 games was working fine before the last patch.

I found some people on internet having the same issue.

Share this post


Link to post
Share on other sites
  • 0
The PC that the wheels all worked correctly on had the 1.10 version of the game installed too? That makes no sense that it would work on one PC but not the other PCs or Xbox One.

Share this post


Link to post
Share on other sites
  • 0
I am having the same issue too with no FFB while (nearly) locking up the tires or oversteer in F1 2017.

Wheel: Thrustmaster T150

Share this post


Link to post
Share on other sites
  • 0
@F1Support as you can see, it's not happening just with the Logitech wheels. @Jarico15 is having the same problem. 

Will it be fixed on the next patch?

Share this post


Link to post
Share on other sites
  • 0

Same issue here. I'm playing on a PS4 with a Thrustmaster T150.

I really hope this will be fixed soon, @F1Support  is there any news you can share with us?

Share this post


Link to post
Share on other sites
  • 0
@F1Support any news? There's a lot of people with the same issue and you don't even answer anymore.

Are you trying to find a fix?
We need an answer. The game is unplayable like this.

Share this post


Link to post
Share on other sites
  • 0
I have the same problem. I'm playing on Xbox One with Logitech G920.
I'm using the latest firmware and game version.

Share this post


Link to post
Share on other sites
  • 0
Any new information on how to fix this problem?
I just bought F1 2017 for Xbox One using the Logitech G920 and I do not have adequate force feedback. The steering wheel is weightless.
Without a solution the game is simply useless, I lost my money :(

Share this post


Link to post
Share on other sites
  • 0
I have a similar issue that suddenly occured. I played for more than 50 hours with no issues and now, I don't get any feedback on the track. The centering spring doesn't work and there is no grip notice, only bumps what makes driving straight forward impossible as the wheel is other than that soft like the power is off. When I drive through curbs or grass it seems it's all working, back on track and  the wheel seems to be turned off again.

Also F1 2017 doesn't seem to recognize the accelleration pedal anymore correctly, when I use default settings for G920 the car is on full accelleration all the time, without me doing anything. When I customize the setting and set accelleration pedal the game only shows it as Z-Axis without the usual accelleration symbol. 

I played F1 last time about two weeks ago and everything was working fine. Yesterday I wanted to play a session with a friend and it's impossible to play. I tried a lot to fix this, re-install the game, removing all settings, re-install LGS, with latest version, older version, nothing lead to a solution. 

With this bug, the game is unplayable to me. All other games I normally play works just fine. There are no issues with Project Cars 2, Assetto Corsa, Euro Truck Sim 2. All these games work.

Share this post


Link to post
Share on other sites
  • 0
@JoeWhizer I found out that PCars2 was causing that issue to other games. It makes windows recognize the acceleration pedal as Z-Axis.

This is the only fix that I found:

1-Remove LGS using Geek Uninstaller (don't restart);
2-Install LSG (don't restart and don't play any other game);
3-Go to control panel and make sure windows is registering the pedals;
4-Play F12017.

It works for me.
The way I found to prevent PCars2 to affecting other games is to uncheck everything in LGS settings.

Hope it helps.

Share this post


Link to post
Share on other sites
  • 0
Awesome, thank you so much. This fixed it. I can't believe it, the only thing I don't get is why Assetto Corsa still had good FFB while its not working in F1.

What do you mean though by uncheck everything in LGS settings?
There is only one check I believe for "use centering spring in FFB games", right?

Share this post


Link to post
Share on other sites
  • 0
JoeWhizer said:
Awesome, thank you so much. This fixed it. I can't believe it, the only thing I don't get is why Assetto Corsa still had good FFB while its not working in F1.

What do you mean though by uncheck everything in LGS settings?
There is only one check I believe for "use centering spring in FFB games", right?
No, it's not in the wheel settings. It's in the LGS settings itself.
Look for something like a gear icon at the bottom right of the LGS.

Share this post


Link to post
Share on other sites
  • 0
Any news here? While the FFB works great in G29, it seems i cant feel the microvibrations before tire lock during braking and also during acceleration to avoid spins. Is it me only? Or it isnt simulated in F12017?

Share this post


Link to post
Share on other sites
  • 0
Lantirn said:
Any news here? While the FFB works great in G29, it seems i cant feel the microvibrations before tire lock during braking and also during acceleration to avoid spins. Is it me only? Or it isnt simulated in F12017?
If you're comparing pad to wheel, don't. If there is something missing from your wheel feel to how it used to be then maybe we can help.

Share this post


Link to post
Share on other sites
  • 0
No, nothing missing at all since the first day. 

But it I never had a pad. 

I thought that I was supposed to have that microvibrations at least. I have no idea if it’s realistic or not. 

I don’t feel any breaking vibrations. let’s say in straight line threshold braking I can’t feel when the tire is going to lock. Is it normal? 

Thanks a lot. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×