Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×


This topic is now archived and is closed to further replies.

[troubleshooting] cant launch the game(fails to update itself)

Recommended Posts

so i just bouight this game 3 days ago, and havent been able to play it yet still. at first, i was getting a black screen at launch. the solution was apparently to set the game to windowed mode, but it didnt work for me, so i tried to verify the games cache.

everytime i verify the cache, it finds missing files, and tries to reaquire them. it keeps failing, and giving me "disk read error", and points to "f1_2017.exe". i've tried removing the file and redownloading it, made sure i had permissions set properly, reinstalling the game entirely, reinstalling steam, deleting the downloading folder from steam, etc.

i still cant find a fix for my issue, and i also cant get a refund for the game, because i bought a retail version. any help? thank you!

Share this post

Link to post
Share on other sites