Jump to content

Archived

This topic is now archived and is closed to further replies.

Problem with AI pitting and not changing tyres, during weather transitions.

Recommended Posts

@danhawk1ns What is your job at codemasters?
Esports Coordinator :) nice to meet you! 


Nice to meet you. As a Esport coordinator why do you respond and try to give support in this thread? Because its an issue with AI and got little to do with esport. Correct me if aim wrong.

Iam asking this to check your intentions. Like said before by somebody else. This issue has been mentioned before with no result from codemasters. And now almost 5 months after the release we get support again. Does this mean you guys are still working on F1 2017?

We’re one team and I like to be involved in all areas :) 
Are you the same Dan Hawkins as the one on AOR? If so, respect - you are juggling a lot of whine at the same time, being on 2 forums at once.

Share this post


Link to post
Share on other sites
That also means you probably carry a lot of experience were we all can benefit from. You stated earlier to take notes. Can you also state what you are going to do with these notes? Like I said before, being here is one thing, showing that it pays of is another. Not trying to be negative or lure you into a certain comment, just cautious about my hopes.

Share this post


Link to post
Share on other sites
Some news about this issue.? Now i don t play with SC and rainy weather on ps4... 

Share this post


Link to post
Share on other sites
martbloke said:
Thanks for confirming @ihaycheese.

@nobbymilo - does the race start dry? Or is that starting at Light Rain then progressing to Heavy Rain? 
@DanHawk1ns Most likely a linked issue too is 1 I had recently:

Xbox One Career Mode, Canada, 50% race. 

Started light rain and was a wet track but there was no option to select wets/inters in Race Strategy at race start. The whole field started on dry tyres. 

Looking at both issues, it's as if there is something saying the weather is not raining when it is and so the AI and options are not allowing wet weather tyres (apart from the human racer being able to change to wet weather tyres when pitting mid race).

Had this too. It was after I had enabled the Controlled Folders Access in Windows 10 Fall Creators Update. Turned it off and it worked again.

Share this post


Link to post
Share on other sites
@danhawk1ns What is your job at codemasters?
Esports Coordinator :) nice to meet you! 

Welcome to the forums Dan. Just one small question did you replace somebody or is @F1support working as well on these forums? Constant updates on communication if it's possible from more than one active member from the codemasters team on the forums would be a nice start to build on.

If you or somebody else could pass that message on too the higher ups it would be appreciated

Thanks ;)  

Share this post


Link to post
Share on other sites
Chromatic said:
@danhawk1ns What is your job at codemasters?
Esports Coordinator :) nice to meet you! 

Welcome to the forums Dan. Just one small question did you replace somebody or is @F1support working as well on these forums? Constant updates on communication if it's possible from more than one active member from the codemasters team on the forums would be a nice start to build on.

If you or somebody else could pass that message on too the higher ups it would be appreciated

Thanks ;)  

Thanks for the welcome! Yes, @F1Support is still around and no I haven't replaced anyone. I'm just an addition to the team :) 

Share this post


Link to post
Share on other sites
Welcome @DanHawk1ns. I noticed this bug too, on the PC version of a 100% race, it's a problem on all platforms.

Share this post


Link to post
Share on other sites
mixmax83 said:
Welcome @DanHawk1ns. I noticed this bug too, on the PC version of a 100% race, it's a problem on all platforms.
Thanks for the welcome :) 

And re: all platforms - that is noted, but thanks for confirming.

Share this post


Link to post
Share on other sites
I have been watching these threads since the game came out but joined up to add my observation on the weather transitions bug. I have seen it twice now and realised it does not happen on every weather transition.....this observation might help solve the bug

This bug is somehow connected to having wet practice or qualifying. Both times, I have seen the bug we have had sustained wet periods in either qualifying or practice. It feels like the AI use down a version of tyre and then do not have it to switch to.

Last time I saw it, we had a rainy Q1, Q2 & Q3 (all on Wets).  Race started dry and then rain kicked in sending everyone onto Inters which was okay but then the weather got worse and we all switched to wets (which is where the bug kicked in). Some cars kept on coming in and putting on inters but a few, myself included changed to wets (coincidentally all cars that did not make it to Q2....so maybe had not used anymore wets). Those cars affected by the bug kept coming in for Inters until the weather changed back to intermediate conditions and then they stopped coming in.

Summary: It felt like they had no Wets to change to but they needed Wets so kept coming in and were fitted with the only tyre available which was Inters. Hope this helps with sorting the bug.

Share this post


Link to post
Share on other sites
@Nastra100 I wish all the comments in this forum would be this informative :smile:

Share this post


Link to post
Share on other sites
UP100 said:
@Nastra100 I wish all the comments in this forum would be this informative :smile:
Thanks. I felt it was worth sharing so joined. I have been a lurker for months just getting updates etc. About time I started to contribute :)

Share this post


Link to post
Share on other sites
Nastra100 said:
I have been watching these threads since the game came out but joined up to add my observation on the weather transitions bug. I have seen it twice now and realised it does not happen on every weather transition.....this observation might help solve the bug

This bug is somehow connected to having wet practice or qualifying. Both times, I have seen the bug we have had sustained wet periods in either qualifying or practice. It feels like the AI use down a version of tyre and then do not have it to switch to.

Last time I saw it, we had a rainy Q1, Q2 & Q3 (all on Wets).  Race started dry and then rain kicked in sending everyone onto Inters which was okay but then the weather got worse and we all switched to wets (which is where the bug kicked in). Some cars kept on coming in and putting on inters but a few, myself included changed to wets (coincidentally all cars that did not make it to Q2....so maybe had not used anymore wets). Those cars affected by the bug kept coming in for Inters until the weather changed back to intermediate conditions and then they stopped coming in.

Summary: It felt like they had no Wets to change to but they needed Wets so kept coming in and were fitted with the only tyre available which was Inters. Hope this helps with sorting the bug.
Thank you very much for signing up to provide this level of detail :)

Share this post


Link to post
Share on other sites
Senna755 said:
To be honest, this ranting and raving and demanding refunds is all getting a bit yawnsome.  I know the game has its issues but this crap has been droning on and on for months now.  It's time to move on with your lives.

Don't like the game?  Fine.  Go get your refund from the place you bought it from.  Simples.  We get you don't like it and I'd wager that no matter what Codemasters did you would never be satisfied.  So quit the song and dance already.
As someone who's overlooked a good share of bugs that this game has thrown out I figure it's worth pointing out that this is not exactly a minor or trivial bug. It has quite a significant negative effect on career mode and also long races against the AI in general. Failing to fix this bug would mean that it would also be present basically forever in this particular edition of the game which really hurts the prospect of replaying this game in the series and erodes confidence in future titles.

Share this post


Link to post
Share on other sites
patch 1.11 on PC
difficulty 90

i have the same problem, start dry til finish everything alrite, start dry then light or heavy rain half of the drivers goes to the pit lane change tyre but not inters or wet for every laps til the rain stop..hope codies fix this bugs :neutral:

Share this post


Link to post
Share on other sites
Can we expect a patch to fix this bug ? He appeared with the 1.11 update. Some news please

Share this post


Link to post
Share on other sites
Just to put in more info for this as it's pretty annoying. Australia 100% Career mode first race, Patch 1.11 on PC, Practice and Qualifying were completely dry. About 30 laps into the race light rain starts and about 5-6 laps later it's heavy rain. All the AI bailed in for Inters around the time DRS got disabled, but then proceeded to keep pitting every time their pitbox was empty. Some were switching to Full Wets, but some weren't as I've got Hamilton pitting for a third set of Inters in 5 laps (while it's raining cats and dogs).

Pretty frustrating as I don't want to finish that race as I think everyone other than the Ferraris are about to go for the fabled 10+ stop strategy so that race is kinda moot.



EDIT: Found a screenshot from 29th Dec, similar thing. Can't remember how the practice/qualifying weather was, but race was dry up until last 5ish laps and yeah everyone bailed out of their 2/3-stops to do this:

I think the only reason Vettel didn't copy their strategy was because I refused to pit for Inters.

Share this post


Link to post
Share on other sites
@jennyannem @danHawk1ns, since it's a problem coming out after the 1.11 patch, I hope it's the priority for the QA team to fix this bug, plus the multiplayer improvements

Share this post


Link to post
Share on other sites
All these comments and no response from anyone, doesn't look good for a patch. And saying go get a refund if you're not happy, have you tried getting a refund?! Game say it's not their problem take it up with Codemasters. Who is to blame?

Share this post


Link to post
Share on other sites
mixmax83 said:
@jennyannem @danHawk1ns, since it's a problem coming out after the 1.11 patch, I hope it's the priority for the QA team to fix this bug, plus the multiplayer improvements
@mixmax83, this problem has been there since Xbox patch 1.9.

Share this post


Link to post
Share on other sites
@danhawk1ns  if it can help, this problem occurs both on dry-wet-dry-wet, wet-dry-wet-dry and dry-wet light-wet storm races, where the AI vehicles continue to put the intermediates instead of the wet tires.

Share this post


Link to post
Share on other sites
TonyHam said:
All these comments and no response from anyone, doesn't look good for a patch. And saying go get a refund if you're not happy, have you tried getting a refund?! Game say it's not their problem take it up with Codemasters. Who is to blame?

Game are talking out their rear end and you are falling for it. Go check your statutory rights. 

Share this post


Link to post
Share on other sites

×