Jump to content Jump to content

F1 2017 doesn't work on my mac


MichaelJ98

Recommended Posts

  • Codemasters Staff
I downloaded F1 2017 onto my 2015 Mac Book Pro and when i launch the game it says i don't  meet the minimum requirements, yet my mac matches up with the minimum requirement stated on the steam website.  
Hey! 

I'm a former Mac user - my Mac never used to like games... ANY games. It was a high spec MacBook Pro 2015 model too - apparently the graphics card (or lack of) let it down! 

I managed to find this: https://www.feralinteractive.com/en/news/802/ - not sure if that will help clear things up. Otherwise you could try posting your full MacBook specs and see what everyone says. 

Sorry I can't be much more assistance (I no longer have my MacBook).
Link to post
Share on other sites
I downloaded F1 2017 onto my 2015 Mac Book Pro and when i launch the game it says i don't  meet the minimum requirements, yet my mac matches up with the minimum requirement stated on the steam website.  
The info in the linked page is inaccurate somewhere.

None of the MBPs from 2015 (3rd gen) have the Iris Pro 6200 Graphics, one has Iris Pro 6100 and the others have Iris Pro 5200 the naming reverts to Iris Plus 6xx (not 6xxx) for Skylake and KabyLake (MBP 4th gen 2016-on)

It specifically excludes the mid-2015 MBP with the AMD R9M370X (and Iris Pro 5200). These have either Broadwell or Haswell CPUs.

Refund it on Steam if you have less than 2 hours gameplay.
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...