Jump to content
Sign in to follow this  

"Steam Error Code 2" When Trying to Launch Game

Recommended Posts

Hello,
I am running into this error continually whenever I try to launch the game for the first time on PC on Steam. The game downloads fine, but when I try to launch it, it tries to go through the initial installation process, but gets to 1% and says "The Steam servers are too busy to handle your request for F1 2014. Error Code (2)", not allowing me to launch the game. I have tried many different things to resolve this issue that I have found online, including:
1. Deleting and/or renaming ClientRegistry.blob in the Steam files
2. Deleting and redownloading the game several times
3. Doing the above with all of my antivirus software disabled
4. Restarting Steam and/or my entire PC
5. Launching my PC in safe mode with networking and trying to launch/reinstall the game that way
But still, none of this has worked. I don't know what to do anymore and I am frankly at my wit's end. I just want to play this game and I can't even get it to launch. Any help in getting this game to launch would be greatly appreciated!

For what it's worth, I had none of these issues with the F1 2013 game or any other game on my Steam library.

Edit: Here are my PC specs:
Intel Core i5-2500 Processor
Sapphire Radeon HD 6870 Graphics Card
8GB DDR3 1600 PC3 12800 MHz RAM
ASRock P67 PRO3 Motherboard

Share this post


Link to post
Share on other sites
Couple of questions...

1 - What OS are you running?
2 - Are you logged in to Windows as an administrator or a user?
3 - Do you run Steam as an administrator?

These might help narrow it down a bit :smile:

Share this post


Link to post
Share on other sites
1 - Windows 7 64-bit
2 - Running it as an administrator
3 - I believe I do usually. I tried running Steam as administrator manually just to make sure and it still didn't work.

edit: For what it's worth, here's my PC specs as well:
Intel Core i5-2500 Processor
Sapphire Radeon HD 6870 Graphics Card
8GB DDR3 PC3 12800 1600 MHz RAM
ASRock P67 PRO3 Motherboard

Share this post


Link to post
Share on other sites

I'm getting pretty much the same thing. apart from my was error code 2 and is now error code 41. validate game files and deleted blob file and still the same. Paid good money for this bloody game and cannot play it, anyone from codemasters read this, it is also creating hundreds of f1_2014_932792_crash_2014_10_17T16_23_27C0.mdmp files.

AMD Phenom II X4 955 Black Edition

12Gb memory

Windows 8.1

Radeon HD 7800

Share this post


Link to post
Share on other sites
Kind of the same problem here. I have an #53/#55 Error and it says the servers a busy for hours now. I did all the same stuff up there but no help till now...
My Specs:
Intel Xeon E3-1230v3
NVidia Geforce 760
Windows 8.1 64-bit
ASRock P67 Pro 3 Motherboard

Share this post


Link to post
Share on other sites
Okay everyone, I got my game to work! Here's what I did:

1. Navigate to your Steam folder
2. Move your steamapps folder somewhere else for the moment to preserve your installs (unless you actually want to reinstall all your games for some reason)
3. Delete your entire Steam folder.
4. Delete the registries for Steam, as detailed on this Steam page for manually uninstalling Steam: https://support.steampowered.com/kb_article.php?ref=9609-OBMP-2526
5. Once that is done, redownload the Steam client and reinstall it
6. Move your steamapps folder back to the directory you installed Steam to again.
7. Start Steam up, log in, and let it go through its update process
8. Once Steam is back to normal, run F1 2014!

That's what worked for me, so if it doesn't work for you then unfortunately you might need to keep searching for solutions.

Share this post


Link to post
Share on other sites

OK so I have removed steam, backed up steamapps first, removed reg keys, rebooted, reinstalled, moved back steamapps folder, and now not only can I not run F1 2014 but I have now lost all of my junctions repointing my steam installs to another drive, using steam mover... so this has not worked and all still the same... I have even tried deleting the acf manifest file and letting F1 2014 re set itself back up, and it is still the same.... ffs... I'm going to be asking for a refund on this its ridiculous...


Share this post


Link to post
Share on other sites
Same here nothing helped yet, support seems to be helples as we ware..... never demoniezed steam like these dayss :( Its a shame!

Share this post


Link to post
Share on other sites
Thanks for the feedback everyone - I've sent this over to the team. :)

UPDATE: Ok, I've spoken to our QA department and if possible, we need a CEG log to look at.

If possible, could those experiencing the error follow the below instructions?

1.       Create a text file called “custom_log.txt” in the following location “C:\Program Files (x86)\Steam\logs”

2.       Attempt to run the game. If you have the issue then send us a copy of all of the logs within the logs directory at ‘codem@codemasters.com.’

3.       In the mail, let us know which country you are in and how you purchased your copy (for example DVD Locally, DVD from another country, Directly from Steam, CD Key website etc)

Thanks everyone. 

Share this post


Link to post
Share on other sites
Sorry Hatta, took way too long to get a reply to this. I have purchased all of the F1 games over the years, and was eagerly looking forward to this one. However after not being able to get my £30 purchase to even start, and trying all sorts to get it working, I have got a refund from steam. Suffice to say I will not be purchasing anymore F1 titles that come onto the market, and will seriously debate about buying anything further from codemasters....

Share this post


Link to post
Share on other sites
I've been suffering at this problem for 2 weeks now and i solved it with a pretty much stupid way. Before i tell you, i have to say i ve tried all the ways of the others tried (deleting something, reinstalling something, verifying, trying on registry,). I've connected with Codemasters support guys, after 6 or 7 mails i was almost about to give up.
Then i suddenly had a thought that if my second monitor (TV) making that issue? I first deleted the second monitor from the Control Panel, then plugged out the hdmi cable to my TV and i clicked Play F1 2014.
Then tataa!! That's it. It worked. Turned out my 2 monitors were causing the problem.
Actually it is still annoying, now everytime i want to play F1 2014 i have to unplug my Tv from Pc. But i am glad to solve this stupid problem.

Share this post


Link to post
Share on other sites
Excellent stuff Nehilix glad you got it sorted. I just got my money back from steam and used it to buy another game. Cheers for letting us all know though. I also have 2 monitors...

Share this post


Link to post
Share on other sites
[SOLVED] Steam Servers Are Too Busy. Error Code: 2

Okay, I've been working on this full-time for nearly a week and finally had a breakthrough. The Problem:

Many of my Steam games began failing to load. I.E.:
Bioshock Infinite
Just Cause 2
Deadpool
Borderlands: The Pre-Sequel
Saints Row IV
and probably more I haven't tried yet.

Most of them were giving me the error in the title.

I tried all of the following to cure the problem...

I verified that my edge firewall wasn't blocking traffic.
Verified that PC is plugged into the wall.
Disabled windows firewall & windows defender and my Malwarebytes Premium virus protection.
Turned off Steam Overlay.
Disabled Steam Cloud Sync.
Killed any programs that may produce OSD stuff, like FPS counters in Afterburner or EVGA Precision XOC. 
Verified cache files.
Uninstalled and re-installed problematic games
First, tried executing steam://flushconfig, reboot, run steam from the steam folder.
Exited steam and deleted clientregistry.blob and restarted steam.
Manually installed the vcredist, dotnet, and DirectX installers from game sub-directories.
Ran msconfig and rebooted in diagnostic startup and tried game.
Moved steam to C:\Program Files (x86)\, and other folders on other drives.
Installed latest geforce drivers
Installed all latest windows updates
re-ran directx 11 install
Uninstalled game and restarted windows into safemode w/networking and tried re-installing it in safemode.
Completely uninstalled steam, along with every steam game.
Manually removing all valve/steam related registry entries.
Re-installed steam & re-installed games
Run steam with admin privileges.
Create the proper steam_appid.txt files for each game.
Creating softlinks to the Steam folder in each game's executable folder.
And much, much more.

Nothing had any effect. Then I stumbled onto a page where a user named Wildstar had surmised that the error was being thrown because of some failures in the Steam CEG copy protection system that all of the failing games happen to use. It uses some algorithm to create encrypted executables that will only run under the user's account. So I played around with deleting all of the .exe and .dll files from a game and then letting a validation run to restore the missing files in the hopes that it would produce correctly encrypted binaries. Didn't work.

Finally, I decided to do everything I could to restore my Steam setup to as default a state as possible. Once I performed the following procedure, every single one of my problematic games returned to normal operation, and in some cases, I had missing saved games suddenly reappear.

In its most recent arrangement, I had my Steam folder on my E: drive because there's not enough room on my boot SSD for the 600GB of games I own. I also had an app directory on my C: drive that I tried moving some games into to see if running from the boot drive would help. So I had an E:\Steam installation dir and a C:\Steam Library dir, both paths being registered in my Steam Library Folders list.

These are the steps for fixing the CEG issues...
  1. Exit Steam.
  2. Move the SteamApps and UserData folders from your current installation to some safe directory on the same drive you currently have them stored on. Moving these folders will be WAY faster than copying them because all it really does is update each file's directory chain info without touching the actual contents of the files.
  3. Uninstall steam using Geek Uninstaller. https://geekuninstaller.com/  It will yank out any extra reg entries or junk files after the standard uninstall script ends.
  4. Reinstall Steam into your "C:\Program Files (x86)" and launch it. You will see all of your games greyed out and waiting to be installed.
  5. Pick any game you like at random and begin the install process. It will ask you where you want to install it.
  6. If you plan to have all of your Steam games on your C: Drive, then choose your default install D/L location. If you plan to install some or all of your Steam games on another drive, then choose that drive. In my case, I created a new folder on my E: drive named it SteamLibrary, within which the new SteamApps folder resides.
  7. Once Steam is done allocating space and begins the actual download process, pause the download.
  8. Right click on the game you just began downloading and choose Uninstall. The only reason we did this is to have Steam setup the default folder structure for our apps.
  9. Exit Steam.
  10. Go to the SteamApps/Common folder Steam just created for your download and delete any files or folders that the uninstall you just performed may have missed.
  11. Move the UserData folder we preserved before into the "C:\Program Files (x86)\Steam" folder, overwriting any existing files.
  12. Move the contents of the SteamApps folder we preserved before into the SteamApps folder Steam just created when we began that first game download.
  13. Launch Steam.
  14. Every one of your games now needs to be re-installed, but the way we've set it up Steam will skip downloading any files that already exist. With games that were working fine before, you should be able to click the Install button, let it verify the existing files, run all of its pre-install scripts, and then run the game.
With the games that were throwing errors, I recommend finding the starting binaries in each game directory and then deleting them. Delete the main game .exe and any Launcher type .exe's as well, and then click Install. It will download the correctly customized/encrypted main executables you need to play the game, once it sees the old ones are missing.

Every game that was giving me problems came back from the dead after following these steps.

If you should happen to click install on a game that doesn't already have its files positioned in the place you specify, it will begin downloading them. After that point, it will do you no good to copy the game directory into your intended destination. Steam will not recognize the appearance of the new files. It will keep downloading into a temp folder until it's done and then copy over the files you just moved into place.

To correct this if it happens, you must pause the download and uninstall the game, copy the complete game directory into the desired SteamApps/Common folder, and then click Install again. If you see the "Discovering Existing Files" message, rather than the downloading progress bar, you have succeeded. 

If this ends up working for anyone, let us know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×