Jump to content
  • 0
Sign in to follow this  

Can't get to staging line with drag pack

Question

Hi, I have a problem with Grid Autosport Drag Pack DLC. The game works and loads fine, and everything works as it should. The only issue i see is with the drag pack. Anytime i enter a drag race (any track, any car, any race/trial/cup), i can set the car up and enter the race as per normal. But at the beginning when there is the 30second countdown to move to the staging lane, the car is "stuck". Pushing the throttle button revs the engine up to about 2000rpm, barely off idle, and the car will not budge. Its as if the e-brake is stuck on.

I've tried everything including tapping the e-brake button to try and toggle it. tried tapping the brakes, and tried pushing every key with the throttle pressed at the same time to see if anything could release the car. I am using a PC with a normal keyboard as the controller (Razer Black Widow Keyboard)

Does anyone have a fix for this???

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×