Jump to content
  • 0
Sign in to follow this  

Dxinput Dirt4

Question

Hey Guys, I have a Siatek P2900 and the game crashes whenever its plugged in.
What's new in Dirt 4 is I think they supported dx input. 

In older games it just wasn't supported. So I emulated Xbox360 controller and it worked fine.
I just need to figure out how to make the game think I don't have any direct input devices when the game turns on. 

In the config file there is a <input device_type="auto"/>
Obviously Auto is no good. I don't know what the options are. I want to force Xbox 360 controller since I am trying to emulate it. 

Can anyone help me out. 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

  • 0
I've been trying to disable my device through here:
 <!-- Not Supported -->
  <!--
    Devices here are defined to invalid action maps so no action map is assigned by default.
  -->
  <device id="{C626046D-0000-0000-0000-504944564944}" name="space_navigator" priority="0" type="not_supported"  />
  <device id="{046DBEEF-0000-0000-0000-504944564944}" name="space_navigator_driver" priority="0" type="not_supported" /> 
  <device id="{5F0D06A3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />
  <device id="{030906A3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />
  <device id="{030906F3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />
</device_list>

I just don't want it to be initialized by the game! But I can't figure out what I am doing wrong. I tried multiple Device ID numbers but its not happening. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×