Jump to content
  • 0
Sign in to follow this  

Windows 10 version 1803 GRID Autosport won't launch

Question

I decided to purchase the season pass for GRID Autosport on Steam yesterday but when I try to run it  it just returns to the Play GRID panel.  It was working before but I just updated my Windows to 1803 from 1709 so I'm wondering if it could be connected to that.

Could someone please confirm they have it running on 1803 please?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Have you tried verifying files in Steam? Alternatively start it, chech Task Manager and of Grid Autosport is running, end task it. Then it might launch again by itself. I have to use this approach quite often with some F1 games.

I can check on my PC a bit later on, if it's still not working for you.

Share this post


Link to post
Share on other sites
  • 0
Veryfying the files worked, thanks!  Now I'm back to the old fullscreen issue playing on my TV.  It's OK on the laptop but only windowed on the TV.

Share this post


Link to post
Share on other sites
  • 0
Yes, I tried that but it didn't help.  I also deleted hardware_settings_config and hardware_settings_info and restarted the game.  I've solved this one previously, probably also with the DiRT ganes too.


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×