Jump to content
  • 0
Sign in to follow this  

F1 2017 game freezing every half lap for 2-3 seconds even though using gtx 1070

Question

I found the game freezing every half lap for about 2-3 seconds. Then I noticed in the task manager the gpu is constantly at 99%+. I changed v sync settings from off to on, decreased the resolution from 1440p to 1080P and it still stays at 99% usage.

Update: I understand that high GPU usage is normal but if the usage of the 1070 is high it shouldn't be freezing all of the time for a few seconds. Other games aren't freezing like this

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

  • 0
Make sure your pre-rendered frames in Nvidia Control Panel is on Let 3D application decide, using 1 or 2 makes the game stutter.

Check CPU/GPU temps @ Load using MSI Afterburner.
Check clock speeds are at the correct values @ Load

99% GPU usage is fine if you're running uncapped framerate, if you enable V-Sync and hit your 60fps target, the GPU usage will drop below 99% as you're no longer bottlenecked by the GPU and reaching your target framerate.

If your monitor is 144hz or higher, enabling V-Sync won't make GPU usage drop below 99% as you probably aren't hitting 144fps consistently so the GPU is still under full load trying to get there, this causes stuttering.


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×