Jump to content Jump to content

G29 Logitech on full left lock


Recommended Posts

Just bought a new wheel and when I go to time trial, it’s stuck on full left lock and doesn’t respond to movements.

In the settings, towards the bottom it’s not registering any movements and says my steering is at -100, any help appreciated.
Link to post
Share on other sites
  1. Download the latest version of the "Logitech Gaming Software" from the Logitech website and install it. Make sure your wheel is disconnected from your PC before doing that.
  2. Once the software is installed, start it up, go through the initial startup settings, connect the wheel again and let it calibrate.
  3. When the calibration is done open the "Logitech Gaming Software" window, select your wheel in the device list, click on any glowing button and double click on "Wheel" which is positioned at the top of the steering wheel picture. This will open the wheel settings.
  4. In the wheel settings you can change (from top to bottom) the turning sensitivity (I suggest you keep it at 50%), the turning degrees (I suggest no more than 375° for F1 2017), activate or deactivate the centering spring (I have it enabled, personal preference) and the amount of its strength (22% for me, personal preferenc).
  5. Start the game.
  6.  Open the control settings, adjust the scheme to your liking and make sure to save the changes.
  7. Test the wheel in any mode.
IMPORTANT: Everytime your wheel calibrates (when connecting it to the pc or, if already connected, when starting up the OS) you may have to repeat step 3 in order to initialize your settings again before starting any game. If you don't, your wheel settings may not work in any game and you will be stuck with a low turning degree and different centering spring strength. Simply open the wheel settings and click on OK. The settings from former changes should be kept anyway.
Link to post
Share on other sites
  • 1 year later...
22 hours ago, Hergamm said:

hey, I have installed the logitech gaming software but when I plug in the wheel it does'nt do any kind of calibration

Should calerbrate as soon as its plugged in. If you have a flashing light on the wheel means somethingd not plugged in right.

Link to post
Share on other sites
  • 2 months later...
  • 4 weeks later...

I had this problem. I hadn't used my wheel for a year or so. Plugged in the pedals and usb. Buttons all worked fine,  but wouldn't calibrate and just turned hard left. Tried all sorts of methods to get it to work and was about to pull it apart when i noticed the power plug.  I didn't plug the thing into power. Embarrassing to admit but hopefully might solve the problem for others. 🤦‍♂️

  • Thanks 1
Link to post
Share on other sites
10 hours ago, Fabric350 said:

I had this problem. I hadn't used my wheel for a year or so. Plugged in the pedals and usb. Buttons all worked fine,  but wouldn't calibrate and just turned hard left. Tried all sorts of methods to get it to work and was about to pull it apart when i noticed the power plug.  I didn't plug the thing into power. Embarrassing to admit but hopefully might solve the problem for others. 🤦‍♂️

 

the steering wheel is not supported by code, useless posting will never solve it.

  • Disagree 1
Link to post
Share on other sites
On 3/7/2020 at 1:26 PM, Petrowsky said:

I have the exact same problem except I only use my wheel on PS4. People suggested reinstalling drivers and stuff, but I can't do that on PS4, can I? If I install the drivers from my PC, will it work on PS4 afterwards?

You could use PC mode (PS3) to download and update the wheel if there were any updates. AFAIK, the G29 as is is fully functional with consoles (PS4/PS3) and supported games.

PC users should use G-Hub to administer the wheel, provided they are also using Windows 10.

Link to post
Share on other sites
On 3/29/2020 at 7:46 PM, Fabric350 said:

I had this problem. I hadn't used my wheel for a year or so. Plugged in the pedals and usb. Buttons all worked fine,  but wouldn't calibrate and just turned hard left. Tried all sorts of methods to get it to work and was about to pull it apart when i noticed the power plug.  I didn't plug the thing into power. Embarrassing to admit but hopefully might solve the problem for others. 🤦‍♂️

You are a life saver and I feel so dumb right now hahaha. Thanks for your USEFUL post, advanceapple can shove it

  • Thanks 1
Link to post
Share on other sites
  • 4 months later...
  • 3 weeks later...

I've got the same problem as OP, all connections are good, I checked the power brick with a meter, it's got 24vdc. I spent 10 hours across 3 pcs trying to get it to work, oldest supported software and drivers to the newest, with no diffrent outcome. One thing I noticed is that my avast keeps saying that there is a crucial jump drive hooked to my computer that does not exist. One question I have that I can't find an answer to is that if the computer isn't getting encoder feedback will it attempt a calibration? It tries, moves a few degrees, lights up the rpm leds and blinks the ps4 light. I wish I had a Playstation to hook it to, I have no way to rule out a hardware issue. 

 

Update 8/30/2020:

It was a bad power brick from the factory, I don't have access to proper electrical test equipment at the time so I didn't have a way to put a current draw on the brick and could only verify voltage. Walmart had a universal laptop power supply that would power the wheel to aid my troubleshooting. https://www.walmart.com/ip/onn-65W-Universal-Laptop-Charger-with-10-Interchangable-Tips/882312537

G29 G920 not calibrating

Edited by defcon120
update
Link to post
Share on other sites
  • 4 months later...
  • 5 weeks later...
On 3/30/2020 at 1:46 AM, Fabric350 said:

I had this problem. I hadn't used my wheel for a year or so. Plugged in the pedals and usb. Buttons all worked fine,  but wouldn't calibrate and just turned hard left. Tried all sorts of methods to get it to work and was about to pull it apart when i noticed the power plug.  I didn't plug the thing into power. Embarrassing to admit but hopefully might solve the problem for others. 🤦‍♂️

I used to be the IT guy, I even worked for years as main IT guy in a multimillion euro company.
And my main joke moto was kill it and revive it.
But yet, it's only the moment I read "I didn't plug the thing into power." my brain went like, "hot damn, ofc, I don't recall having plugged it in this time".

Was busy editing game files and whatnot just to get the steeringwheel fully operational.

Glad you didn't delete your comment after @advanceapple reply.

 

PS: created account on this forum just to thank you in this post @Fabric350 !

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...