Jump to content
Sign in to follow this  

DIRT 4 does not detect Thrustmaster TMX wheel (** SOLVED **)

Recommended Posts

I play both DIRT Rally and Assetto Corsa on PC without issue using my TMX wheel and T3PA pedals.  I was eager to try DIRT 4 and I was happy to get a bonus steam licence for "DIRT 4" as part of a bundle along with my new laptop.  I installed it using steam on my PC - much better for games.

The game seems  to start fine...but as the title suggests...there is no joy in getting DIRT 4 to offer any input option other than Keyboard.  The Wheel doesn't show up as a device in the game.

Of course windows does detect the wheel.  And other games continue to detect and use my wheel as they should.  It's only Dirt 4 that doesn't.  Funny how the older game, Dirt Rally does detect the wheel.

I've did the business of verifying the local files for Dirt 4 in steam, and they were OK.  I also tried running the game as administrator a few times.

I've checked the firmware of my wheel, and at version 7, it is the most up to date available.

I've uninstalled and reinstalled Dirt 4.

So far, I have amassed 31 minutes in game, just starting it and exiting...If I hadn't got the game "free", I would be tempted to get a refund from steam!

So ... anyone else having issues with thrust-master wheels and this game?

-- EDIT
I play this game on steam, but launch Steam in normal picture mode.

However, in Steam big picture mode there are settings you can modify you cannot see in normal mode.

The "Generic Gamepad Configuration Support" option under the "Controller Settings"  needs to be unchecked when using a wheel with Steam games (at least this game and ATS, maybe more).


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×