Jump to content
Motorsport Games, Codemasters and FIA World Rallycross Championship presented by Monster Energy partner to create the World RX Esports Invitational Read more... ×
Sign in to follow this  

F1 2014 - Lagging and stuttering after some time, GPU load locked on 100% .

Recommended Posts

Fresh start, F1 2014 is performing great. After some time (random period, mostly about 1 minute, sometimes longer) game performance will drop significantly. It seems that some routine will run cycle on GPU without end. After performance drop, GPU load will stay high (100%) too after quitting game. This is not caused by CPU/GPU throttling, temperatures are OK. I experience this behavior on Macbook Pro 17" early 2011 with i7, Radeon 6750m, 8GB ram, bootcamp Windows 7 x64 . It does not matter if i have old or latest drivers. Other games runs fine. On another computer with NVIDIA gpu is everything ok, no performance drop.

Share this post


Link to post
Share on other sites

Setup the game, ran fine...came back the next day ran the game started seeing some graphic flickering, didn't have much time.  Third session... locking up for 2,3,4 seconds then continues. Does this about every two laps. Get 40 laps into a career race it's locking up 5,6,9 seconds every lap,  then twice a lap. Got out booted came back no change. Went to Time trial, did it there as well. Came back to career again it ran a little better but within 10 laps it was as bad as before.   I ran 5 complete seasons (Career) in 2013 never had a problem.   It's unplayable.

I7 64 bit Win7 AMD Radeon R9

Share this post


Link to post
Share on other sites
In my case GPU will stay loaded too after quitting game. Logout and login again in Windows will solve GPU load problem. So after that if i am lucky i am able to do few laps before GPU will get loaded permanently again by game.

Share this post


Link to post
Share on other sites
Same problem, more comments http://steamcommunity.com/app/226580/discussions/0/619569340986328257/?tscn=1414029931 .

Share this post


Link to post
Share on other sites
I let the game run that video option to set my graphic levels and that is what screwed it up. I went back back and changed the graphics, resolution etc to the same settings I used in F-1 2013 and it worked FINE...  just as it should. NO PROBLEMS. I hope this helps.

Share this post


Link to post
Share on other sites
Update ... finally found cause! ... Steam.exe*32 process!!! I exited Steam and GPU load stayed high. After that found another Steam.exe*32 process, killed him and GPU load dropped to 0% . I experience same behavior on my desktop machine if i play Alien Isolation with difference that Steam.exe*32 process will not load GPU, but one CPU. So something with Steam is wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×