Jump to content Jump to content

F1 2014 - Lagging and stuttering after some time, GPU load locked on 100% .


Recommended Posts

Fresh start, F1 2014 is performing great. After some time (random period, mostly about 1 minute, sometimes longer) game performance will drop significantly. It seems that some routine will run cycle on GPU without end. After performance drop, GPU load will stay high (100%) too after quitting game. This is not caused by CPU/GPU throttling, temperatures are OK. I experience this behavior on Macbook Pro 17" early 2011 with i7, Radeon 6750m, 8GB ram, bootcamp Windows 7 x64 . It does not matter if i have old or latest drivers. Other games runs fine. On another computer with NVIDIA gpu is everything ok, no performance drop.
Link to post
Share on other sites

Setup the game, ran fine...came back the next day ran the game started seeing some graphic flickering, didn't have much time.  Third session... locking up for 2,3,4 seconds then continues. Does this about every two laps. Get 40 laps into a career race it's locking up 5,6,9 seconds every lap,  then twice a lap. Got out booted came back no change. Went to Time trial, did it there as well. Came back to career again it ran a little better but within 10 laps it was as bad as before.   I ran 5 complete seasons (Career) in 2013 never had a problem.   It's unplayable.

I7 64 bit Win7 AMD Radeon R9

Link to post
Share on other sites
I let the game run that video option to set my graphic levels and that is what screwed it up. I went back back and changed the graphics, resolution etc to the same settings I used in F-1 2013 and it worked FINE...  just as it should. NO PROBLEMS. I hope this helps.
Link to post
Share on other sites
Update ... finally found cause! ... Steam.exe*32 process!!! I exited Steam and GPU load stayed high. After that found another Steam.exe*32 process, killed him and GPU load dropped to 0% . I experience same behavior on my desktop machine if i play Alien Isolation with difference that Steam.exe*32 process will not load GPU, but one CPU. So something with Steam is wrong.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...