Jump to content
  • 0
Sign in to follow this  

PC Game F12017 won't start, tried everything

Question

Hello guys, 

I know i'm not the first with this Problem but i tried everything thats worked for other people.
When i click on the steam game it says "starting application" or something and after 5 seconds it closes and nothing more happens, i wasnt even in the game yet.
i verified the game files multiple times,
i updated my graficcard drivers and windows,
i reinstalled the game multiple times,
i closed every program and virus scanner imaginable.
i started it as admin,
 nothing works...

i use windows 10 64bit
AMG Radeon r9 200 grafic card
AMD 8350 8 core Processor
Thrustmaster t150 wheel

i'm so pissed, just wanna race :smiley:
Thanks in advance people

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×