Jump to content

Archived

This topic is now archived and is closed to further replies.

F1 2018 crashes on loading screen with some older CPUs (e.g. Phenom / Athlon II) [PC, version 1.04]

Recommended Posts

I have following components:
I7 2600K overclocked to 4.8 GHz
16 GB RAM
HD 7970 GHz Edition

F1 2018 quits to desktop without any error prompt, it does not matter if I try high or ultra low settings, AA/AF...

F1 2017 runs properly and smooth with 60 FPS vsync with 1920x1200 (vsync off faster).

Share this post


Link to post
Share on other sites
Hoo said:
We have a potential fix for this issue. However, as these CPUs are not officially supported by the game and haven't been through a full QA cycle, we do not want to place this fix into the main game just yet. Instead, we have set up a beta branch in Steam where you can get this fix and see if it resolves your issue. To do this, please follow these steps:
  1. Open your Steam library
  2. Right-click on the F1 2018 game and select "Properties"
  3. Select the Beta tab on the properties pop up
  4. In the text entry box ‘Enter beta access code to unlock private betas’ enter: c7EFPdFd6XADgGL7X284D4m8N6gYZmvb then click CHECK CODE.
  5. A message “Access code correct, private beta ‘phenomtest’ is now available will appear
  6. Ensure that in the drop-down menu on the Betas tab that "phenomtest" is selected (not the default NONE option) and then Close the window.
  7. The game will now update. 
  8. Launch F1 2018. This game version should now display as v1.04.1 at the Press Start Screen.
Please let us know if this resolves your immediate issues. If so, we'll roll this fix into the main game once our full QA cycle has been completed. 

Customers who do not have the affected CPUs should not get this branch as there might be unintended side effects from this change.

Customers who do not have the affected CPUs and who are experiencing problems launching the game should add a new support thread with the required information: http://forums.codemasters.com/discussion/132514/f1-games-technical-assistance-bug-reports-please-read-before-posting. This should include a summary of your core system specs and graphics driver information. 
Well just checked forum now , as i saw code works for everyone but now code is invalid im just done really first game and now this , fix ?
Edit : Ok , just i cant copy that everything works 

Share this post


Link to post
Share on other sites
Codemasters I applaud you.

I have had a very similar issue with another AAA release recently and that company (EA cough cough) has brushed it's ageing processor users under the carpet.

Where do I vote for you as developer of the year? <3 <3 <3

Share this post


Link to post
Share on other sites
My game doesn't even start, anyone got the same problem and found a workaround for it?
If i try to start the game, my screen turns black and my pc freezes completely so i need to cut the power to restart.
I tried so far, verifying gamecache, install on C (ssd) and D (hdd). Tried different Nvidia Drivers. Even completely made a fresh reinstall of my windows and it still doesn't work.

What appears to be a problem too is that my "My Games -> F1 2018 -> hardwaresettings" folder contains 2 files but these files are completely empty. Tried to use the F1 2017 files but hasn't worked.

I've also tried some suggestions from the steamforums but it still doesn't work
https://steamcommunity.com/app/737800/discussions/0/1733210552678489819/

The fix on Page 5 here does not seem to work either http://forums.codemasters.com/discussion/136974/f1-2018-crashes-on-loading-screen-with-some-older-cpus-e-g-phenom-athlon-ii-pc-version-1-04#latest

Please help me 

i5-3570k
8gb ram
1080ti
Nvidia Drivers 398.82

Share this post


Link to post
Share on other sites
Game runs now but the Game has weird graphical glitches like banners are all black and sometimes the textures are all purple until i restart the game. I have the latest Nvdia drivers ie 398.92 on my GTX 1050 Ti . Anyone else can confirm this.

Share this post


Link to post
Share on other sites
Same problem for me. I can't get it to load. The monitor just keeps going black. I can't even get to the settings.
Not happy after paying so much for this game.
Windows 10, i7 4790k, 16Gb Ram, GTX 1080Ti FTW 3. M.2 SSD.

How can this be fixed? I'm using multiple monitors but only ONE for playing games.

Cheers

AndyStrat

Share this post


Link to post
Share on other sites
Hello Intel Users and non-Phenom users,
I'm afraid the fix was only to introduce basic compatibility for AMD Phenom users.
Other CPUs and the issues reported for them are separate situations, I'm afraid, and ought to be reposted as different threads.
I'll be closing this thread off.
Thank you for your patience with this one. 
Cheers
22 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×