Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

T300 drives like a pad F1 2018 (PC)

Recommended Posts

So after starting up the game I just went into time trial to test out the handling. As soon as I start driving, I notice that the in-game wheel is jittering over bumps and kurbs like you see would happen on a pad. Also, I noticed that the force feedback felt a bit odd. I investigated this by going full lock with my T300 while moving. However, in game the car was nowhere near full lock because of which I came to the conclusion that the game recognised my T300 as a pad. Because of this I went into the controller settings where I saw, to my surprise, that the game recognised my T300 fully and treated it as such. I went to change my in game ffb settings to test out different things to find out how to fix it but nothing worked. I even tried unplugging my keyboard as I thought it might be interfering with the game inputs as I didn't have a controller connected at that time but that didn't work. I tried unplugging and replugging my wheel, I searched for wheel firmware/driver updates, which I had no success with as I very recently already updated everything so it is on the most recent version. I also tried to make a completely new control scheme, which didn't work. I have also found out that I am not the only one with the issue with the T300. Idk what else to do as I have tried everything I could.

Share this post


Link to post
Share on other sites
i use the T300RS i beleive it uses the same Servo? its only the pedals that are different? and i didnt have any issues in the game with control scheme's etc. unless im just used to it from the Beta, rather than straight from F1 2017 to the new game.

There is a glitch with the wheels animation bouncing around, but from what i can tell that doesnt affect the steering wheel bouncing around in my hands. etc.

might be worth re-installing thrusmaster drivers etc.. 

Share this post


Link to post
Share on other sites
Hey, if you guys are using the F1 addon by thrustmaster, simply set it to the Advanced Mode in your profiler, it does the job for me, I can finally play the game like it's meant, FFB is quite good too.

Some settings: PROFILER: 360 degrees, and in order: 85, 85, 85, 0, and 0 by the game. ADVANCED MODE.

In game, you can adjust to your liking.

Hopefully this will solve the problem for you guys !

Share this post


Link to post
Share on other sites
Hey, if you guys are using the F1 addon by thrustmaster, simply set it to the Advanced Mode in your profiler, it does the job for me, I can finally play the game like it's meant, FFB is quite good too.

Some settings: PROFILER: 360 degrees, and in order: 85, 85, 85, 0, and 0 by the game. ADVANCED MODE.

In game, you can adjust to your liking.

Hopefully this will solve the problem for you guys !
I have the GTE rim so can't do that

Share this post


Link to post
Share on other sites
shootm3 said:
i use the T300RS i beleive it uses the same Servo? its only the pedals that are different? and i didnt have any issues in the game with control scheme's etc. unless im just used to it from the Beta, rather than straight from F1 2017 to the new game.

There is a glitch with the wheels animation bouncing around, but from what i can tell that doesnt affect the steering wheel bouncing around in my hands. etc.

might be worth re-installing thrusmaster drivers etc.. 
Tried everything from re-installing drivers to simple things like unplugging and replugging. Still the same problem

Share this post


Link to post
Share on other sites
It's a recurring problem from the beta. We've tried everything to fix it, nothing seemingly works, if you've got it then you've got it, and if you don't then lucky you. Nobody knows the cause of it, and it's not easily replicated so God knows when we'll get a fix for it. 

Share this post


Link to post
Share on other sites
NoseyGuyy said:
It's a recurring problem from the beta. We've tried everything to fix it, nothing seemingly works, if you've got it then you've got it, and if you don't then lucky you. Nobody knows the cause of it, and it's not easily replicated so God knows when we'll get a fix for it. 
Yeah, cos that is definitely going to not make me very angry and make me feel like I just wasted my money...

Share this post


Link to post
Share on other sites
Hey, i'm having the exact same issue with my T300RS, and this is really annoying, hopefully we will have a fix soon because i basically can't really play the game in this state right now

Share this post


Link to post
Share on other sites
Please can everyone having this issue confirm the following details:
  • Platform (assuming PC for this)
  • Wheel model number and rim
  • Pedals
  • Method of hooking up pedals and wheels to your PC
  • Wheel firmware
  • TM driver version
  • TM Driver settings
  • Windows OS version
  • Steering wheel mode
  • Action map selected in game
  • In-game FFB settings
Thanks

Share this post


Link to post
Share on other sites
Update: I guess they are aware of the issue : https://twitter.com/Formula1game/status/1032987292959469568

Share this post


Link to post
Share on other sites
Hoo said:
Please can everyone having this issue confirm the following details:
  • Platform (assuming PC for this)
  • Wheel model number and rim
  • Pedals
  • Method of hooking up pedals and wheels to your PC
  • Wheel firmware
  • TM driver version
  • TM Driver settings
  • Windows OS version
  • Steering wheel mode
  • Action map selected in game
  • In-game FFB settings
Thanks
  • PC
  • Thrustmaster T300 with Ferrari GTE rim
  • T3PA
  • USB
  • 28.00
  • 2.10.9.0 (Firmware and driver are fully up to date as updated recently and reinstalled today)
  • 360 degrees, 75% strenght, 100% constant and periodic, 0% Spring and damper, auto-centre set by game
  • Windows 10
  • PS3
  • I attempted regular T300, T300 GTE and custome T300
  • Calibration all on 0, FFB: On, strenght: 120, on track, rumble strip and off track all on 20, damper at 100 and understeer is On (I have tried playing around with those settings)

Share this post


Link to post
Share on other sites
  • Platform : PC
  • Wheel model number and rim : T300RS, default rim
  • Pedals : T3PA
  • Method of hooking up pedals and wheels to your PC : USB 2.0
  • Wheel firmware : i had the version 25, and update to version 28, both have the issue 
  • TM driver version : 2.10.9.0
  • TM Driver settings : 360°deg, 75%strenght, 100% constant, 100% periodic, 100% spring, 0% dampeur
  • Windows OS version : Win10 Pro
  • Steering wheel mode : PS3
  • Action map selected in game : tried default T300 and T300 F1, and tried to use a custom T300
  • In-game FFB settings : calibration all on 0 , FFB : on, strenght : 35 on track : 0, rumble strip : 10, off track : 20, damper : 10 and underster is off (i also tried to mess with every settings but the issue was still here)

Share this post


Link to post
Share on other sites
  • Platform: PC
  • Wheel model number and rim: T300 Ferrari Integral Alcantara Edition, default rim
  • Pedals: T3PA
  • Method of hooking up pedals and wheels to your PC: USB 2.0
  • Wheel firmware:  25
  • TM driver version: 2.10.9.0
  • TM Driver settings: 360° - 75% strenght - constant, periodic, spring, damper all 100% - Auto-center through game
  • Windows OS version: Windows 10
  • Steering wheel mode: PS3
  • Action map selected in game: Custom T300 (also tried default T300)
  • In-game FFB settings: Default


Share this post


Link to post
Share on other sites
  • Platform : PC
  • Wheel model number and rim : T300RS with standard rim
  • Pedals : stock
  • Method of hooking up pedals and wheels to your PC : USB 2.0
  • Wheel firmware : 28.00
  • TM driver version : 2.10.9.0
  • TM Driver settings : 360°deg, 75%strenght, 100% constant, 100% periodic, 0% spring, 0% damper, auto-center set by game
  • Windows OS version : Win7
  • Steering wheel mode : PS3
  • Action map selected in game : default t300, custom t300
  • In-game FFB settings : overall ffb strength 60%, rest default

Share this post


Link to post
Share on other sites
  • Platform PS4
  • Wheel model number and rim T300 RS (basic normal rim)
  • Pedals T3PA
  • Method of hooking up pedals and wheels to your PS4 USB
  • Wheel firmware N/A
  • TM driver version N/A
  • TM Driver settings N/A
  • Windows OS version N/A
  • Steering wheel mode PS4
  • Action map selected in game T300 setup
  • In-game FFB settings All default

Share this post


Link to post
Share on other sites
I think I have found a temporary fix that might help with a permanent one. What I did was turn the saturation up in game until it recognised full lock at 180° (so a 360° full rotation). Then when I went in game, I turned the saturation back down to 0 and it worked as intended with full lock on my wheel being full lock in game. I am on the PS4 btw, might be different for PC

Share this post


Link to post
Share on other sites
I think I have found a temporary fix that might help with a permanent one. What I did was turn the saturation up in game until it recognised full lock at 180° (so a 360° full rotation). Then when I went in game, I turned the saturation back down to 0 and it worked as intended with full lock on my wheel being full lock in game. I am on the PS4 btw, might be different for PC
So just turning saturation up and down again, both times in game?

Share this post


Link to post
Share on other sites
I think I have found a temporary fix that might help with a permanent one. What I did was turn the saturation up in game until it recognised full lock at 180° (so a 360° full rotation). Then when I went in game, I turned the saturation back down to 0 and it worked as intended with full lock on my wheel being full lock in game. I am on the PS4 btw, might be different for PC
So just turning saturation up and down again, both times in game?
Yeah, it does work but basically every time you go back to the garage, just do it again when you head out again and so far has fixed the issue for me

Share this post


Link to post
Share on other sites
I think I have found a temporary fix that might help with a permanent one. What I did was turn the saturation up in game until it recognised full lock at 180° (so a 360° full rotation). Then when I went in game, I turned the saturation back down to 0 and it worked as intended with full lock on my wheel being full lock in game. I am on the PS4 btw, might be different for PC
So just turning saturation up and down again, both times in game?
Yeah, it does work but basically every time you go back to the garage, just do it again when you head out again and so far has fixed the issue for me
Didn't work for me, especially as the game does recognise me being in full lock at 180 degrees (or 360, whatever) but it treats my wheel like a pad where it doesn't go on full lock depending on how quickly you go, just like when you put full input in a pad and it doesn't go full lock in game

Share this post


Link to post
Share on other sites
I think I have found a temporary fix that might help with a permanent one. What I did was turn the saturation up in game until it recognised full lock at 180° (so a 360° full rotation). Then when I went in game, I turned the saturation back down to 0 and it worked as intended with full lock on my wheel being full lock in game. I am on the PS4 btw, might be different for PC
So just turning saturation up and down again, both times in game?
Yeah, it does work but basically every time you go back to the garage, just do it again when you head out again and so far has fixed the issue for me
Didn't work for me, especially as the game does recognise me being in full lock at 180 degrees (or 360, whatever) but it treats my wheel like a pad where it doesn't go on full lock depending on how quickly you go, just like when you put full input in a pad and it doesn't go full lock in game
Didn't work, still feels like a pad for me aswell.

Share this post


Link to post
Share on other sites
Why not just refund until the appropriate patch is released, isn't the wheel on supported list? If they've known since the beta they've already had 6 or 8 weeks minimum. 

Share this post


Link to post
Share on other sites
FRACTURED said:
Why not just refund until the appropriate patch is released, isn't the wheel on supported list? If they've known since the beta they've already had 6 or 8 weeks minimum. 
I can't as I didn't buy the game on steam  :/

Share this post


Link to post
Share on other sites

×