Jump to content Jump to content

[BUG] F1 2018 - Fuel rate of consumption!


mcs2006

Recommended Posts

Hi all,

We're still drilling down to try and get the best information for the development team, could I request some more information on their behalf?

Can I ask for a short video of the issue happening? Ideally just a short video showing the MFD fuel screen as well as a lap or two of the changing values. Equally, a screenshot of your R&D progress wold be useful (particularly fuel related) so we can rule out any issues there.

Thanks for your patience.
DriverNumber22
No problem. This evening I will share all you need. 
Link to post
Share on other sites
I have the same problem with the fuel,I’m doing 25% race (15 laps) 
stsrt with full tank enough for 24 laps,by the time I’m on my 2nd lap it already says I don’t have enough fuel for the all 15 laps.
Link to post
Share on other sites
I have an issue with the fuel consumption during qualy in career mode with Sauber in Australia. The fuel doesn't decrease during the laps. So if I start the run with 5 laps fuel, I finish the qualy lap with the same amount. There are other several bugs in this mode. During free practice Alo set a time 23sec faster than anyone else. Always in free practice 6 drivers were DQ because they crashed each other at the end of the pit lane. You have to resolve a lot of issues

Link to post
Share on other sites
Hi all,

We're still drilling down to try and get the best information for the development team, could I request some more information on their behalf?

Can I ask for a short video of the issue happening? Ideally just a short video showing the MFD fuel screen as well as a lap or two of the changing values. Equally, a screenshot of your R&D progress wold be useful (particularly fuel related) so we can rule out any issues there.

Thanks for your patience.
DriverNumber22
Okay.
I just made a 20min video to explain precisely how the bug occure in FP.

https://www.youtube.com/watch?v=KoBHI-C-TA4

Here a timecode of differents actions

00:00 – 01:00 Creating a new career
02:10 : R&D progress
02:28 : Starting FP1
02:43 : Set 27 kg of fuel
02:55 - 06:23 : 2 Laps without the bug fuel. Using various fuel settings
06:23 : Back to the pit menu
06:35 : Starting fuel consumption practice  (without bug)
06:42 - 10:08 - End of fuel consumption practice (without bug)
10:16 :  Fuel consumption practice results (without bug)
!! 10:28 : RESTART SESSION !!
10:41 : Starting fuel consumption practice (WITH BUG)
12:40 : First lap WITH BUG of fuel consumption practice
14:12 : End of fuel consumption practice (WITH BUG)
14:22 : Fuel consumption practice results (WITH BUG)
15:15 : Starting FP3
15:24 - 17:40 : 1 Lap without the bug fuel. Using various fuel settings
!! 17:48 : RESTART SESSION !!
18:00 - 20:00 : 1 Lap WITH the bug fuel. Using various fuel settings


And here another video of the bug during a RACE (not mine)

https://www.youtube.com/watch?v=7ZNBXAGquWo

As you can see, even in the "lean" mode, he can save fuel.

Hope it help. Let me know if you need something else !





Link to post
Share on other sites
I tested around a bit and what I've found looks like the source of the fuel problem in races.
As Maxime10 shows us, there is no fuel consumption after a session restart in FP (and also not in Q).
If you do a race strategy program without the bug and one with the bug, the game just take the average fuel consumption of both programs.
Example (Bahrain 25% distance):
FP1 (without bug): S-compound - 1.8 kg per lap
FP2 (with bug): SS-compound - 0 kg per lap
Average fuel consumption per lap = (1.8 + 0) / 2 = 0.9 kg
So the game thinks you can finish the 14 lap race with just 12.6 kg fuel and every 0.9 kg fuel you put extra will count as a lap of extra fuel. But even on lean and with lift & coast you will need much more.
If you do the race strategy program three times (one without and two with bug) it will be impossible to finish the race even with maximum fuel load.

Until fixed I recommend to NOT USE Restart session in free practises. Use Back to Main Menu instead. That will prevent you from the no fuel consumption bug. You can of course restart Session (i.e. if you crashed). But then you should go back to Main Menu before you do any programs.
If you're sticking in a unfinishable race... well... maybe it will be fixed for existing savegames. If not, retire the car in the race. That will at least save the engine parts.
Link to post
Share on other sites
An alternate to quiting to main menu you could use flashback. I’ve used flashback for past 4 races and run into no issues as of yet.

i hate it but until the bugs fixed this is what I’m left with. Don’t want to be spending time with all the load screens going to menu n back in.

civ
Link to post
Share on other sites
VUnit469 said:
An alternate to quiting to main menu you could use flashback. I’ve used flashback for past 4 races and run into no issues as of yet.

i hate it but until the bugs fixed this is what I’m left with. Don’t want to be spending time with all the load screens going to menu n back in.

civ

That's what ive been doing too. Hate doing it but at least it is a work around for now
Link to post
Share on other sites
Aropretim said:
I tested around a bit and what I've found looks like the source of the fuel problem in races.
As Maxime10 shows us, there is no fuel consumption after a session restart in FP (and also not in Q).
If you do a race strategy program without the bug and one with the bug, the game just take the average fuel consumption of both programs.
Example (Bahrain 25% distance):
FP1 (without bug): S-compound - 1.8 kg per lap
FP2 (with bug): SS-compound - 0 kg per lap
Average fuel consumption per lap = (1.8 + 0) / 2 = 0.9 kg
So the game thinks you can finish the 14 lap race with just 12.6 kg fuel and every 0.9 kg fuel you put extra will count as a lap of extra fuel. But even on lean and with lift & coast you will need much more.
If you do the race strategy program three times (one without and two with bug) it will be impossible to finish the race even with maximum fuel load.

Until fixed I recommend to NOT USE Restart session in free practises. Use Back to Main Menu instead. That will prevent you from the no fuel consumption bug. You can of course restart Session (i.e. if you crashed). But then you should go back to Main Menu before you do any programs.
If you're sticking in a unfinishable race... well... maybe it will be fixed for existing savegames. If not, retire the car in the race. That will at least save the engine parts.
Nice test ! I think this evening i will upload another video with the race strategy program and then the race.

Link to post
Share on other sites
I have the same bug in Bahrain. I think you guys covered most of it, but I figured I upload another video as extra evidence/information.
I didn't know it would come out in potato quality but if you squint you can distinguish the steady decrease of the fuel mix counter, even in lean mix.
I tried quiting to main menu, and then going back into the career, and that didn't really work. I hope an upcoming patch will fix any upcoming save game, else I might indeed retire the race. Shame, because I was having a good weekend, haha.

Here's the video, please ignore both my driving skills and the potato quality:
https://youtu.be/xccBAtYCs6A
Link to post
Share on other sites
First sorry for my english because i‘m from Germany, i hope you will understand me.
This Fuel glitch happens two time in a row for me.
it happens only when it started to rain during a race in career mode.
the first time it started to rain in a race for me was in France i got fuel +0,78 and then when jeff told me  for a different strategy to go on intermediates in this second my fuel goes from +0,78 to -2.45 that changes in one second. I was angry a little bit but i though ok this happend one time and i saved this -2.45 fuel easily on the wet conditions. But the second time this happens was a lot oft worst.
After the france race the next race in austria this happend again. Same type of race start on dry wheahter them after around 15 laps it started to rain and on an few laps later when the track becomes wet and at the point where jeff told you to change the strategy to go on intermediates in this second my fuel goes from i think +.1,15 to -16,65 !!!!!!!!!!! Within a second i was very angry please codemasters fixed this issue this game is so good but there are tooooo many problems please fixed it.
This glitches happend on my career mode. 100% race!
Link to post
Share on other sites
I am having a similar but opposite issue as this. The fix for me is to quit to main menu and reload the race entirely. Super inconvenient. 

If I flashback anytime during career, the fuel consumption of my car is 0. So if I make a mistake on lap 1, I have 100kg of fuel in the car, and it doesn't go down. Same in the qualifying/practice sessions. There is no fuel consumption, so the car is heavy and tires degrade like normal. 

It's great to overheat and run in max fuel at all times, but makes the car already that much far slower. Williams 100% race career on 101 ai for reference.
Link to post
Share on other sites
Maxime10 said:
Aropretim said:
I tested around a bit and what I've found looks like the source of the fuel problem in races.
As Maxime10 shows us, there is no fuel consumption after a session restart in FP (and also not in Q).
If you do a race strategy program without the bug and one with the bug, the game just take the average fuel consumption of both programs.
Example (Bahrain 25% distance):
FP1 (without bug): S-compound - 1.8 kg per lap
FP2 (with bug): SS-compound - 0 kg per lap
Average fuel consumption per lap = (1.8 + 0) / 2 = 0.9 kg
So the game thinks you can finish the 14 lap race with just 12.6 kg fuel and every 0.9 kg fuel you put extra will count as a lap of extra fuel. But even on lean and with lift & coast you will need much more.
If you do the race strategy program three times (one without and two with bug) it will be impossible to finish the race even with maximum fuel load.

Until fixed I recommend to NOT USE Restart session in free practises. Use Back to Main Menu instead. That will prevent you from the no fuel consumption bug. You can of course restart Session (i.e. if you crashed). But then you should go back to Main Menu before you do any programs.
If you're sticking in a unfinishable race... well... maybe it will be fixed for existing savegames. If not, retire the car in the race. That will at least save the engine parts.
Nice test ! I think this evening i will upload another video with the race strategy program and then the race.

Hey @DriverNumber22 ! I'm back with Round 2 of Maxime10 the bug hunter !

Today a video too explain how to reproduce the Heavy consumption bug fuel during races :

https://www.youtube.com/watch?v=cSKe9euufnI

Timecode :
00:00 Starting FP1
00:26 Load car settings
00:31 First strange thing : 11kg = 11.2 laps. Then i add 1kg and now 12kg = 6.7 laps
00:52  Starting Race strategy practice with soft tyres
01:01 - 08:53 5 laps of race strategy practice without the fuel bug
09:01 Result of the race strategy practice without the fuel bug
09:14 Go to FP3
10:09 Go out to see if the fuel bug occure or not.
10:16 - 10:29 No bug fuel
10:30 RESTART SESSION
10:34 Go out to see if the fuel bug occure or not.
10:39 - 10:56 FUEL BUG (no consumption)
11:11 Starting Race strategy practice with Super Soft tyres
11:19 - 19:05 5 laps of race strategy practice WITH the fuel bug (no consumption)
19:14 Result of the race strategy practice WITH the fuel bug (no consumption)
20:00 Race Strategy
20:02 Adding some extra fuel for the race
21:04 Race start
21:07 (best start ever x)
21:07 - 25:45 I stay in mix 3 until i got +1 lap of extra fuel. Then i go to mix 2
25:49 - 27:27 Mix 2. Heavy consumption bug fuel. When i'm at +0.01 laps, i go to mix 1 to try to save fuel...
27:30 - 28:30 Mix 1. Unable to save fuel. Heavy consumption bug fuel.


Let me know if you need something else





Link to post
Share on other sites
At first I thought it was a bug. It happened to me for the first time in Baku. He only let me load 63kg of fuel and with that it was impossible to finish the race (100% long race). I searched the internet and found this thread about the problem and I found the solution.

It is not a BUG it really depends on how the race simulation program is implemented (5 laps). During this program you have to get the time requested without using DRS and without using ERS (I mean ERS in default-Medium) and this gives a real consumption in the race when you have neither DRS or slipstream and with the ERS in medium. Doing this program in this way the consumption for the race is perfect and when you use DRS or ERS in the race the estimated remaining fuel increases and does not decrease as it happens if you do not do this training program correctly.

I hope you find it useful, try it and see how everything is adjusted to perfection.

It is not a BUG.

Greetings.

Link to post
Share on other sites
Gabimad said:
At first I thought it was a bug. It happened to me for the first time in Baku. He only let me load 63kg of fuel and with that it was impossible to finish the race (100% long race). I searched the internet and found this thread about the problem and I found the solution.

It is not a BUG it really depends on how the race simulation program is implemented (5 laps). During this program you have to get the time requested without using DRS and without using ERS (I mean ERS in default-Medium) and this gives a real consumption in the race when you have neither DRS or slipstream and with the ERS in medium. Doing this program in this way the consumption for the race is perfect and when you use DRS or ERS in the race the estimated remaining fuel increases and does not decrease as it happens if you do not do this training program correctly.

I hope you find it useful, try it and see how everything is adjusted to perfection.

It is not a BUG.

Greetings.

Hello,

I'm sorry but i totally disagree with you. It's a BUG.

Take a moment to see those 2 videos :
https://forums.codemasters.com/discussion/comment/347160/#Comment_347160
https://forums.codemasters.com/discussion/comment/347959/#Comment_347959

and come back here tell us that's not a bug.

Greetings


Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...