Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2018 [PC] [Audio] "Audio Update Rate" setting reverts to "Low" after game restart

Recommended Posts

Looks like this could be a bug.
Is anyone else seeing this behaviour, or can anyone manage to get the Audio Update Rate to "stick" after restarting the game at any setting higher than "Low"?

1) Go into Audio options -> Advanced Audio Settings
2) Increase "Audio Update Rate" from "Low" to either "Medium" or "High"
3) The game warns you that the change may not take effect till the game restarts
4) Exit out of the game, then relaunch it
5) Check the setting in Advanced Audio Settings again & it has reverted to "Low"

I monitored the file:-
"Documents\My Games\F1 2018\hardwaresettings\hardware_settings_config.xml"

There is a line near the end:-
"<audio radioDeviceId="" audioUpdateRate="0" />"

On that line, "audioUpdateRate" is changed to 1 (for medium) or 2 (for high) as soon as you back out of the options menu after making a change, and it stays that way after exiting the game.
But after relaunching the game, if I ALT+TAB out & check the file again, it has reset to 0 (low).

Further/Related Info...
- I am on Windows 10 Pro 64-bit
- I only use integrated audio (Realtek) on my motherboard (ASRock B85M Pro4) with up-to-date driver, connected to 2.1 desktop speakers & subwoofer
- My display is 144Hz, but currently set to 120Hz (as is F1 2018, in fullscreen)
- The in-game advice/tip on the "Audio Update Rate" seems to indicate I should set it to "High" for >100Hz, assuming it is talking about display frame rates
- I haven't noticed any audio glitches/issues in F1 2018, nor any other games

I appreciate there may be higher-priority bugs/issues than this so soon after launch, but it would be nice to benefit from the higher audio update rates if possible.
Thanks for any assistance/investigation!

Share this post


Link to post
Share on other sites
Same here. No matter where I set it it reverts to low. I have about 100 fps so I would really like to use a better setting. 

Let's hope Codies fix it.

Share this post


Link to post
Share on other sites
Thanks for confirming. So it looks most likely to be an issue with the game rather than something wrong my end.

Yeah, expanding on what I mentioned above, I'm hitting about 90-120fps @ 120Hz with my current settings, depending on track/grid/weather, so I wanted to set Audio Update Rate to "High".

I've been racking my brains for other ideas / possible causes of the issue... perhaps something the game is detecting that it doesn't like at start-up, making it think it's safest to default back to "Low".

The only ideas I've come up with so far are:-

- I have a 2nd monitor, which only runs at 60Hz (which is the main reason I run my primary at 120Hz, due to Nvidia driver / power saving issues when my GPU is idle if my primary is at 144Hz). However, I only run the game on the primary monitor in fullscreen, not borderless, and not streched across both displays. So I don't think that should affect anything, but I dunno... maybe the game is seeing that 60Hz monitor & auto-reverting Audio Update Rate to "Low"? I could try turning it off or unplugging it.

- I have a couple of Ubisoft's Rocksmith Realtone cables connected (they act as microphones, for connecting guitars). I guess since they are audio hardware, there could be something weird going on there, but it seems unlikely. I could try disabling / disconnecting them.


@drKotasz ... I don't suppose you have a 2nd monitor, or any other sound hardware connected to your PC, or anything else in common with anything I've listed above?


I'll report back if I manage to find anything that works around the issue, or come up with any other ideas for things to try.

Cheers!

Share this post


Link to post
Share on other sites
Can a CM employee, check this out, i have the same problem. Wouldn't stick after setting file to read only either.

Share this post


Link to post
Share on other sites
Same problem here, 1 monitor only, 60 hz monitor but have no problem going past 60 fps. I tried changing the rate to medium to see if it would fix the game's stuttering but it would always go to low, even just going back into the menu after telling you to restart the game. You could change anything in advanced audio settings and it would save without restarting, except Audio Update Rate.

I also have all of my usb ports used up, but I hope it does not affect the issue we have.

Share this post


Link to post
Share on other sites
Hi all,

I've passed this thread onto one our our Audio peeps to have a closer look at. Thanks for all the information that you've posted so far! 

Edit: Hi again! Could you let me know what CPU you are all using? If you're not sure, you can send us a DXDiag instead. Info on how to do that is below!

How to save a DXDiag

In Windows 7:

  1. Click on the "Start" Button.
  2. In the Search Box type dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on “Save all Information.”
  4. Save the information to your Desktop, keep the file name as is.
  5. Send the file to us at community(AT)codemasters.com (replacing the (AT) with an @ )

In Windows 8, Windows 10:

  1. Press the [Windows]+[R] keys on your keyboard to bring up the Run command.
  2. In the "Run" command box, type in dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on "Save all Information."
  4. Save the information to your Desktop, keep the file name as is.
  5. Send that file to us at community(AT)codemasters.com (replacing the (AT) with an @ )

Share this post


Link to post
Share on other sites
Faya said:
Hi all,

I've passed this thread onto one our our Audio peeps to have a closer look at. Thanks for all the information that you've posted so far! 

Edit: Hi again! Could you let me know what CPU you are all using? If you're not sure, you can send us a DXDiag instead. Info on how to do that is below!

How to save a DXDiag

In Windows 7:

  1. Click on the "Start" Button.
  2. In the Search Box type dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on “Save all Information.”
  4. Save the information to your Desktop, keep the file name as is.
  5. Send the file to us at community(AT)codemasters.com (replacing the (AT) with an @ )

In Windows 8, Windows 10:

  1. Press the [Windows]+[R] keys on your keyboard to bring up the Run command.
  2. In the "Run" command box, type in dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on "Save all Information."
  4. Save the information to your Desktop, keep the file name as is.
  5. Send that file to us at community(AT)codemasters.com (replacing the (AT) with an @ )
Thanks for the support, I'm using a 3570k clocked at 4.4GHz. I'm pretty sure monitor refresh rate is irrelavant but i've got a 144 monitor and a 60hz montior too.

Share this post


Link to post
Share on other sites
Thanks @Faya for passing the issue on for investigation.

I'm running an i5-4460.

Also, FWIW I tried the game without the 2nd 60Hz monitor (so just my primary @ 120Hz), and without the Rocksmith cables I mentioned previously, and the issue still exists.

Share this post


Link to post
Share on other sites
Guys can you fix it shortly? We need a patch, fixing the bug, and audio issue.
I have the same problem like YorkyPudsy, and i have audio stuttering sometimes.
My CPU i7 8700k, with focusrite scarlett 2i2 audio interface.

Share this post


Link to post
Share on other sites
Faya said:
Hi all,

I've passed this thread onto one our our Audio peeps to have a closer look at. Thanks for all the information that you've posted so far! 

Edit: Hi again! Could you let me know what CPU you are all using? If you're not sure, you can send us a DXDiag instead. Info on how to do that is below!

How to save a DXDiag

In Windows 7:

  1. Click on the "Start" Button.
  2. In the Search Box type dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on “Save all Information.”
  4. Save the information to your Desktop, keep the file name as is.
  5. Send the file to us at community(AT)codemasters.com (replacing the (AT) with an @ )

In Windows 8, Windows 10:

  1. Press the [Windows]+[R] keys on your keyboard to bring up the Run command.
  2. In the "Run" command box, type in dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on "Save all Information."
  4. Save the information to your Desktop, keep the file name as is.
  5. Send that file to us at community(AT)codemasters.com (replacing the (AT) with an @ )
I am using an i5-6600k oc'd to 4.4 GHz
If it helps, I have two monitors, a G-SYNC 144 Hz gaming monitor and a secondary standard 60 Hz.
Thanks for looking into this.

Share this post


Link to post
Share on other sites
I've now received the recent v1.05 update, and just wanted to confirm that this issue still exists for me.
I thought it might be worth mentioning, since the patch notes mention a very vague "various other fixes", so I had no idea if there was any attempt to fix this Audio Update Rate issue yet.

Share this post


Link to post
Share on other sites
I have a similar (maybe same) issue - it NEVER saves for me, I change it to High, and then even going back one menu and going back, it's back to Low again. All other settings remain changed, except Audio Update Rate.

I've tried exiting the game directly (as it suggests), and returning, but the setting remains at Low.

Specs:
- Intel i7 7600K
- Galax Geforce 1080
- GSkill RipJaws 2X8GB 2600Mhz
- Asus Xonar DG sound card
- Thrustmaster T500 with F1 add-on rim

Hope this helps somehow.

Share this post


Link to post
Share on other sites
I just re-tested & this issue still exists on the recent v1.06 update, so I assume it's not part of the "various other fixes" on the patch notes...
https://steamcommunity.com/games/737800/announcements/detail/2582141086343579921

Share this post


Link to post
Share on other sites
Still not working on new patch, now when you change it to high it stays but when you restart it goes back to low again.

Share this post


Link to post
Share on other sites

Hi @Speedy862, thanks for letting us know. Could everyone else that has experienced this issue let me know if it's fixed for you in the 1.07 update or if you're still experiencing the issue? 


Share this post


Link to post
Share on other sites
I am still experiencing it. I tried setting it to medium and high and it still reverts to low after restarting the game.

Share this post


Link to post
Share on other sites
I am happy to report that patch 1.8 has fixed it for me :) The issue is gone, my audio refresh rate is finally set to high!

An undocumented fix it seems.

Thanks Codies!

Share this post


Link to post
Share on other sites
drKotasz said:
I am happy to report that patch 1.8 has fixed it for me :) The issue is gone, my audio refresh rate is finally set to high!

An undocumented fix it seems.

Thanks Codies!
Even after a game restart? How?

Share this post


Link to post
Share on other sites
Hello I just started the game hoping I wouldn't have this problem, but unfortunately I do and it's really really bad. I have the audio update rate set to low. Unfortunately I've had this problem with every F1 game I've tried, just hoping to get this fixed in 2018 since I really want to get into these games and it's so bad the game is pretty much unplayable. 

Device info: 
- i7-4790k @4.00GHz
-16GB RAM
- GTX 1070 (Driver is up to date) 
- Display currently wrapped around three monitors.However have the same issue on one monitor.
- using mobo onboard realtek audio drivers 

Can Send dxdiag if you need it

Share this post


Link to post
Share on other sites
Faya said:

Hi @Speedy862, thanks for letting us know. Could everyone else that has experienced this issue let me know if it's fixed for you in the 1.07 update or if you're still experiencing the issue? 


@Faya, I just wanted to report that I'm now on update v1.09 and the Audio Update Rate still keeps reverting back to Low after restarting the game, exactly the same as originally reported & confirmed by others above.

Is this still being looked at?
Was there any attempt to fix it in recent updates (I don't think I saw any mention in any patch notes, but could have overlooked something).
Is there any other info we can provide to assist in resolving this?

I wonder, has anyone out there (devs or others from CM, or any players) actually managed to get this setting to stay at anything other than "Low" after restarting the game?

Thanks!

Share this post


Link to post
Share on other sites
Hi, just reporting in again that this bug still exists after patch 1.12.

@Faya, is it possible we could have a status update on this issue please? :smile:

It's been almost 2 months since first reporting the problem & it was passed on for investigation, and there are obviously others here who have reported the same.
Although this clearly isn't a game-breaking bug, I'm well aware that at some point in the near future focus will inevitably shift to F1 2019, at which point all these "lesser" bugs are swept under the rug, only to rear their heads again & again in multiple future titles. (For reference, see: yellow flag/safety car issues, AI logging times with sectors missing when you skip the remainder of a session, and various other recurring issues on these forums)
Please let me know if you require any further information beyond what myself & others have already provided above.

Thanks!

Share this post


Link to post
Share on other sites
Hi, just reporting in again that this bug still exists after patch 1.12.

@Faya, is it possible we could have a status update on this issue please? :smile:

It's been almost 2 months since first reporting the problem & it was passed on for investigation, and there are obviously others here who have reported the same.
Although this clearly isn't a game-breaking bug, I'm well aware that at some point in the near future focus will inevitably shift to F1 2019, at which point all these "lesser" bugs are swept under the rug, only to rear their heads again & again in multiple future titles. (For reference, see: yellow flag/safety car issues, AI logging times with sectors missing when you skip the remainder of a session, and various other recurring issues on these forums)
Please let me know if you require any further information beyond what myself & others have already provided above.

Thanks!

By any chance: did you check your F1 2018 settings file on your computer, to see what the audio update rate is set to inside?

You could try to change it there to whatever you want, save the file and put it in Read-only, it could, maybe, fix it.

Share this post


Link to post
Share on other sites
Tarou11 said:

By any chance: did you check your F1 2018 settings file on your computer, to see what the audio update rate is set to inside?

You could try to change it there to whatever you want, save the file and put it in Read-only, it could, maybe, fix it.
Thanks, but yeah, I tried that.
I listed in my original post where the setting is stored, and how it changes in the file from 0(low) to 1(medium) or 2(high) when I change it in the audio options menu. But when you close the game & then re-launch it, it reverts to 0(low) in the file.
Additionally, if I set the file to read-only as you suggest, the game obviously can't write any hardware settings changes to that file (including the audio update rate), but the game still shows the setting in the audio options menu as "Low" after each launch of the game (which I presume is what the game is using), even though the file itself would still specify 1(medium) or 2(high), depending on what I set it to before making it read-only.
EDIT: Interestingly, I think this is the only setting I've noticed so far which specifically informs me that I'll need to restart the game for it to take effect!!!

@Tarou11 - have you managed to get the setting to "stick" at anything besides "Low" yourself? If so, is there perhaps anything different that stands out about your setup/PC compared with that others have reported on this thread?

Share this post


Link to post
Share on other sites

×