Jump to content Jump to content
F1 2021 | Online Services Down For Maintenance | 26/07/2021 ×

F1 2018 [PC] [Audio] "Audio Update Rate" setting reverts to "Low" after game restart


Recommended Posts

Tarou11 said:

By any chance: did you check your F1 2018 settings file on your computer, to see what the audio update rate is set to inside?

You could try to change it there to whatever you want, save the file and put it in Read-only, it could, maybe, fix it.
Thanks, but yeah, I tried that.
I listed in my original post where the setting is stored, and how it changes in the file from 0(low) to 1(medium) or 2(high) when I change it in the audio options menu. But when you close the game & then re-launch it, it reverts to 0(low) in the file.
Additionally, if I set the file to read-only as you suggest, the game obviously can't write any hardware settings changes to that file (including the audio update rate), but the game still shows the setting in the audio options menu as "Low" after each launch of the game (which I presume is what the game is using), even though the file itself would still specify 1(medium) or 2(high), depending on what I set it to before making it read-only.
EDIT: Interestingly, I think this is the only setting I've noticed so far which specifically informs me that I'll need to restart the game for it to take effect!!!

@Tarou11 - have you managed to get the setting to "stick" at anything besides "Low" yourself? If so, is there perhaps anything different that stands out about your setup/PC compared with that others have reported on this thread?

Sorry I did not read your original post fully...

my setting is set to Medium and stays on Medium.

Did you check this line in the same config file:
<refreshRate numerator="60000" denominator="1000" />

Does it correctly see your refresh rate?

Link to post
Share on other sites
No probs, I may not have mentioned before about trying to set the file as read-only anyway, so that could be more useful info in tracking down what's causing it.

Anyway, it's good to hear from at least one person who's got the setting working... assuming you've been back into that audio options menu since closing the game? If I go straight back into the audio menu after changing the setting, it does temporarily retain the new setting. Just to clarify 100%, it only reverts to Low for me once I exit the game completely & then re-launch it. It's like the game is detecting something it doesn't like, and deciding to revert just that one setting (since no other settings get reverted to defaults, that I've noticed at least, audio or otherwise).

It's not the sort of thing I expect most people would have noticed, as I guess typically they will either not bother changing this kind of setting, or set it once & then not go back in there.... why would you expect it to revert itself after all?!

So I suppose it could be useful to CM and/or others in the thread if there's anything different about your setup compared with ours...?

Some people listed their CPUs as requested by @Faya earlier. And a few of us listed details regarding monitors & audio hardware, since they seem most related.

Here are some more details from me... anything here that's the same/different for you, @Tarou11, since I think you're the 1st person I've seen confirm it's remembering the setting for them...?

CPU: i5-4460
GPU: GTX 970
Drives: SSD (system drive + Steam installation) + HDD (F1 2018 installed here)
O/S: Windows 10 Pro 64-bit, v1803
Motherboard: ASRock B85M Pro4
Audio: Integrated (Realtek) with up-to-date driver
Speakers: External desktop 2.1 speakers + subwoofer
Displays: Primary=1920x1080@144Hz[but currently set to 120Hz] + Secondary(1600x900@60Hz) [already tried without 2nd monitor]
Other: 2 x Ubisoft Rocksmith Realtone cables [though at least 1 is often disabled, and I've tried disabling both, still get the issue]

Link to post
Share on other sites
Hi @YorkyPudsy,

My setting is on Medium since I have the game, I started it 10 minutes ago to check and it was on Medium still.

CPU: i7-6700k
GPU: GTX 980ti
Drives. SSD (System + Games), HDD (purely storage)
O/S: Windows 10 Pro 64-bit, v1803
Motherboard: Asus Z170-A
Audio: Integrated (Realtek High Definition Audio)
Headset: Corsair Vengeance 1500 / Sony MH1000X M2 / V-Moda Crossfade 2
Display: Asus 1920x1080 @60Hz
Other: Xbox One controller, used in wired mode via USB
Link to post
Share on other sites
Thanks @Tarou11 for taking the time to list that stuff. That's a bit more for CM to go on if they're still investigating :)

I forgot to mention controllers, although I've tested with both wireless XBox One controller & with Logitech G29 wheel, and the issue exists for me regardless.

So, things that stand out to me...
- We have different CPUs, and you're on a newer chipset, although I've seen people in this thread say they have the issue with newer Intels than that even, and also with at least one AMD I think
- Looks like you have the game installed on your system drive (SSD), whereas I have mine on a secondary HDD... guess that could be worth checking out, although the settings file is in "My Documents" in the usual place on my SSD anyway.
- Different motherboard, but potentially very similar onboard audio hardware
- Your don't have a display with >60Hz refresh rate... this looks like another possible thing to investigate, since I've seen at least one other person with the issue here report having a 144Hz display (+ a secondary display like me). I've tried disabling my 2nd 60Hz display, but haven't tried dropping to 60Hz on my primary.

More details on my audio hardware, since this could be relevant to it not remembering the audio update rate setting for me...
- Device Manager > High Definition Audio driver is v10.0.17134.319 dated 2018-09-07
- Sounds > Playback device is set to 16-bit 48kHz, with no 'enhancements' enabled, and Spatial Sound=off

Link to post
Share on other sites
Hi @YorkyPudsy ,

I see a difference in the latest details you gives, but I still doubt it would cause the issue you have:
- High Definition Audio driver: v6.0.1.7910 dated 2016-08-16 (since I have no audio issue with anything, I did not update them)
- Sound playback setting, here there is a difference, I have 24-bit 48kHz, no enhancements enabled and spatial sound off.

Did you check what I mentioned above, the line <refreshRate numerator="60000" denominator="1000" /> ?

Link to post
Share on other sites
Thanks @Tarou11, that's a couple of other things I can look into. Really appreciate your help!

It would certainly be strange if it works ok on an audio driver from a couple of years ago, but not for me on a current version.
The bitrate thing could be worth a try messing with.

I'll report back if I get anywhere, or think of anything else to investigate.

Meanwhile, @Faya, any official updates from CM on progress with this audio update rate setting issue would be welcome.

Thanks again!
Link to post
Share on other sites
Hey @YorkyPudsy, thanks for the update. Let me go and poke the team as I think that a fix was put in, but if you’re still having issues then it might be something else. Either way I’ll get the team to take another look.
Link to post
Share on other sites
Thanks @Faya. Let me know if there's any other info you/the team need (most of the details of my PC are already listed above in previous posts).

Since my last post I did try temporarily setting my onboard sound playback device to 24-bit 48kHz (to match the settings which are working for @Tarou11 above), but it didn't make any difference.

And @Tarou11, I also checked the line in the game's settings file that you mentioned, and mine seems to match my current 120Hz (actually says 119Hz in the settings menu)...
            <refreshRate numerator="119982" denominator="1000" />
As I mentioned before, I've also tried setting the game & display to 60Hz (since @Tarou11 is running @ 60Hz).

Link to post
Share on other sites
  • 2 weeks later...
Fantastic, that does indeed seem to have fixed it here.
I entered & exited the game a couple of times to be certain, and the setting now stays as I set it (both in the file & the in-game options).
It's not resetting to Low any more when launching the game.
Hopefully that's fixed it for the other people who reported the issue above too.

Thanks @Faya! And please pass on my thanks to the team for getting that sorted! :)

Off topic, while I was checking my settings & that config file, I noticed a new framerate limiter setting in there now, which I don't think was mentioned in the patch notes. That's really handy for some people/situations, so cheers for that too. Hopefully it makes it's way into other CM titles in the future.
Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...