Jump to content Jump to content

[PC] Game stuck on black screen after loading to track


CodiesBlogBot

Recommended Posts

  • Codemasters Staff
@JohnArkoumanis - we've passed on the information to our test lab who are investigating these issues. We'll let you know as soon as we receive any update on this.
Link to post
Share on other sites
@Hoo nothing yet, it has been one week and I still can’t play the game I bought!!!!

I am kinda disappointed, I have waited so long for the game and, I almost bought all the games from you. 
Come on guys! Give them a little time of fixing it! It´s a complex code and if they change something, it´s important to check that it will not create any new bugs!

So stay calm and wait for 1.05. ;)

Link to post
Share on other sites
  • Codemasters Staff
@JohnArkoumanis - the specs of your PC look fine for running the game. Also, we can't locate a crash dump for you, so we suspect the game is locking up or hanging on the loading screen rather than crashing. Your dxdiag suggests that your PC is running a 4k monitor @30Hz, so there might be some conflict between what the game is trying to output compared to what your system can support. Here are a few things to try before loading to track:
  • Update your gfx driver as your current one is 6 months old. 
  • Try enabling (or disabling) the vsync option in the Video Mode options.
  • Try adjusting / reducing the screen output resolution, e.g. to 1920x1080.
  • Try running the game in windowed mode at a low resolution
  • Try lowering the graphics settings to the lowest settings
  • If you have one available, try connecting a smaller 60Hz monitor and see if that makes a difference.
If nothing works, then send through your hardware settings file and we'll see if there is anything else that looks out of place. Instructions for sending this to us are here: http://forums.codemasters.com/discussion/132514/f1-games-technical-assistance-bug-reports-please-read-before-posting.

(EDIT: given that this is a different issue, it would be useful to start a new support thread so that we can assist you without getting side-tracked by the issues that others are facing).
Link to post
Share on other sites
Hi,
I also cannot play. The game stucks at the loading screen, when I start first after the last update. The next start I get a black screen but I can hear the ui music. I do not find crash dumps.
I sent dxdiag and hardwear files to you per mail. Will I get an answer back? Steam ID 76561197989845468.
I run triple screen at 5670/1080.  My gfx card sometimes has problems with more than 85 Hz. Can I set this manually in some ini files, 'cause I can't get to options?

Link to post
Share on other sites
  • Codemasters Staff
Hi,
I also cannot play. The game stucks at the loading screen, when I start first after the last update. The next start I get a black screen but I can hear the ui music. I do not find crash dumps.
I sent dxdiag and hardwear files to you per mail. Will I get an answer back? Steam ID 76561197989845468.
I run triple screen at 5670/1080.  My gfx card sometimes has problems with more than 85 Hz. Can I set this manually in some ini files, 'cause I can't get to options?

Hi. Looking at your hardware settings and dxdiag, there seems to be a conflict in how the refresh rate is being handled. Your primary monitor is reporting 60Hz, with Windows setting this to 85Hz triple screen and then the game is detecting just under 144Hz. It might be worth double-checking how these are connected and configured in Windows. If you are happy with how this is set up then here are a couple of in-game things you may want to try:
  • Delete the hardware settings file and then launch the game (backup the file first just in case!). This should restore the settings to default which should come from what you are using in Windows. 
  • If the above doesn't work, or you don't want to delete the file, then try manually adjusting refresh rate line in your hardware settings file so that it reads:
<refreshRate denominator="1" numerator="85"/>
Link to post
Share on other sites
Hoo said:
Hi,
I also cannot play. The game stucks at the loading screen, when I start first after the last update. The next start I get a black screen but I can hear the ui music. I do not find crash dumps.
I sent dxdiag and hardwear files to you per mail. Will I get an answer back? Steam ID 76561197989845468.
I run triple screen at 5670/1080.  My gfx card sometimes has problems with more than 85 Hz. Can I set this manually in some ini files, 'cause I can't get to options?

Hi. Looking at your hardware settings and dxdiag, there seems to be a conflict in how the refresh rate is being handled. Your primary monitor is reporting 60Hz, with Windows setting this to 85Hz triple screen and then the game is detecting just under 144Hz. It might be worth double-checking how these are connected and configured in Windows. If you are happy with how this is set up then here are a couple of in-game things you may want to try:
  • Delete the hardware settings file and then launch the game (backup the file first just in case!). This should restore the settings to default which should come from what you are using in Windows. 
  • If the above doesn't work, or you don't want to delete the file, then try manually adjusting refresh rate line in your hardware settings file so that it reads:
<refreshRate denominator="1" numerator="85"/>
Hi Hoo,
thanks a lot for your help. Changing the hardware settings was succsesfull. Game runs now perfectly! :)
Link to post
Share on other sites
  • Codemasters Staff
This discussion was created from comments split from: F1 2018 crashes on loading screen with CPUs which has SSSE3 compatibility [PC, version 1.04]. [Edit by Hoo] Hi All. I've separated out this thread to cover the issue when the PC version of the game goes to a black screen after loading to track (rather than hanging or crashing, which is covered in other threads.
Link to post
Share on other sites
  • Codemasters Staff
Hi @JohnArkoumanis. Looking at your hardware settings, your refresh rate settings are both reporting as 0 and 0. This doesn't seem correct. If you follow the instruction from my above post, you can either delete your hardware settings file and let it regenerate when it boots up (which will hopefully get updated settings from Windows), or you can edit the file and manually configure your refresh rates . If you are still using your original 4K@30Hz monitor, then adjust the refresh rate line to read:
<refreshRate denominator="1" numerator="30"/>
Link to post
Share on other sites
  • Codemasters Staff
Hello @JohnArkoumanis. Please try the following:
  1. Update your NVidia drivers to the latest ones
  2. Disconnect one of your monitors, then delete the hardware settings file and launch the game.
  3. If this does not work, disconnect your current monitor and connect your other monitor, delete the hardware setting file again and then launch the game
Please let us know if any of this manages to get you loading to the track. If not, please send through your updated dxdiag file and hardware settings files which each of your monitors connected.

Link to post
Share on other sites
Hello, I just purchased F1 2018 game and i have problem when game is loading to  track. I see never ending  black loading screen with "please wait" . I tried to change all settings, also resolutions, vsync and nothing helped. Game is not crashing, but i ve got never ending loading screen :/ I sent u email with everything what u need

Edit: Ok,  my game crashed. I sent u crash report via email too ::smile:
Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
If you are on Steam and get a black screen when launching F1 2018, you can try to launch the game from steam in safe mode with the command "-safemode".

To do so, right click on F1 2018 in your Steam library, click Properties, and Set Launch Options... Then insert the "-safemode" (without the "").

Link to post
Share on other sites
Certainly something is wrong with steam....
I tried to go multiplayer and the systems kicks me out for cheating....!!!!!??????
What is that ...?????
Come on I bought the game so many many days ago and cannot play anything...
Codemasters plz HELP here!!!!
@Hoo are you still receiving all that?
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...