Jump to content
  • 0
Sign in to follow this  

When will the famous "D3D has been removed" error finally be resolved?

Question

  • 0
After playing for 3-4 laps and entering the pit, the game continuosly crashes and a message "D3D Device has been removed" shows. I'm running the game using my graphics card in Windows 10, my specifications should safely satisfy the game requirements and no problems should occur related to the graphic card.

Here are the specifications of my laptop:
HP Omen 15
Intel Core i7 7700HQ @2.80GHz
8Gb RAM
NVIDIA GeForce GTX 1050
All drivers up to date
The GPU usage is configured so that it can only be used by games so that no other program/process utilices the GPU when playing.

I've tried uninstalling and reinstalling the game without success, double checking the state of my drivers also without success.

At this point, the game is simply unplayable, as I cannot even finish a single 5-lap race, the game just crashes before that.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Guest
Hoo said:
@wchsam92 - is it the same "D3D Device Has Been Removed" crash every time, or are you getting different crashes? If you can send through your Steam ID then we can check if you have reported any other crashes (see here for instructions oOfn getting your Steam ID).
Of course it is the dreaded "D3D device removed" error. Also I had sent my crash dump to your community email address.

Share this post


Link to post
Share on other sites
  • 0
Hi @wchsam92 - we can't get any more info out of the crash dump as it simply reports the same issue that you have mentioned already. As such, the suggestion is still that the system is struggling to run the game. A few things to try are:
  • Check your gfx driver is up-to-date
  • Run your laptop with it plugged in to ensure maximum power goes through to the gfx card (assuming your energy plan in Windows supports this).
  • Lower the gfx settings
  • Cap the framerate - a new in-game option in the video mode settings should let you do this.
If this doesn't work, then send through your dxdiag and hardware settings and we can take a further look.

Share this post


Link to post
Share on other sites
  • 0
Guest
Hoo said:
Hi @wchsam92 - we can't get any more info out of the crash dump as it simply reports the same issue that you have mentioned already. As such, the suggestion is still that the system is struggling to run the game. A few things to try are:
  • Check your gfx driver is up-to-date
  • Run your laptop with it plugged in to ensure maximum power goes through to the gfx card (assuming your energy plan in Windows supports this).
  • Lower the gfx settings
  • Cap the framerate - a new in-game option in the video mode settings should let you do this.
If this doesn't work, then send through your dxdiag and hardware settings and we can take a further look.
Graphics driver is latest Nvidia 416.34. I always game plugged in and energy plan is at high performance. GFX settings is already lowered to almost bare minimum, and it can maintain smooth 60fps with MSI Afterburner indicating around 85% GPU Usage. Framerate was already capped at 60fps due to Vsync on, and I had experimented with 50fps cap, this lowers my GPU usage to averaging 75% and it still crash.

I'll send my dxdiag and hardware settings to your community email.

Share this post


Link to post
Share on other sites
  • 0
Hi @wchsam92 - I've forwarded the info onto the dev team to see if they can see anything that might be causing this.

Share this post


Link to post
Share on other sites
  • 0
Guest
Hoo said:
Hi @wchsam92 - I've forwarded the info onto the dev team to see if they can see anything that might be causing this.
Alright this is strange but my crash had stopped due to this 2 setting/tweak. Set pagefile size manually to 16384mb fixed for min and max, use -safemode launch command in steam. It must be both. I tried using either one and crashes still occur.

I've managed to finish Qualifying (one shot) and a 25% (15 laps) race at round 1 Melbourne. Then proceeded to an invitational event, overtake challenge using F2004 at Paul Ricard. Then finished several R&D objectives in P1 of round 2 Bahrain. However the main disadvantage is that i had to reset my graphics setting everytime I launch the game as the -safemode command resets settings to 1024x768 windowed and ultra low preset. Still, the crashes had stopped. Forward this info to the dev.

Share this post


Link to post
Share on other sites
  • 0
@wchsam92 - I've passed the info on. Launching in safe mode should make the game boot up using minimum graphics settings, so this would suggest that either there are some graphics settings that your PC doesn't like, or that the hardware settings file has some incorrect data in it. You could try deleting / renaming your current hardware settings file and relaunch the game without using safe mode - this will cause the game to create a new default hardware settings file. You can then set the gfx settings to whatever you changed them to when running safe mode and see if the game runs normally after that point.

Share this post


Link to post
Share on other sites
  • 0
Guest
Hoo said:
@wchsam92 - I've passed the info on. Launching in safe mode should make the game boot up using minimum graphics settings, so this would suggest that either there are some graphics settings that your PC doesn't like, or that the hardware settings file has some incorrect data in it. You could try deleting / renaming your current hardware settings file and relaunch the game without using safe mode - this will cause the game to create a new default hardware settings file. You can then set the gfx settings to whatever you changed them to when running safe mode and see if the game runs normally after that point.
I've tested your suggestion but sadly it still crashes. I started by deleting the whole F1 2018 folder in Documents/My Games, then launched the game without -safemode command. Reset graphics settings to what worked previously, and went on to finish the whole Bahrain GP weekend in career without problems, so I thought it (deleting and creating new hardware settings file) should be working but I need more testing to confirm. I quit back to windows and relaunch the game (with the newly created hardware settings file), loaded to the next race, China, did the first R&D objective and it crashes on lap 1 around the 3rd corner. I'll stick to -safemode launch command for now.

Share this post


Link to post
Share on other sites
  • 0
Guest
First of all, appreciate codemasters for responding to my tweet. I'm loving F1 2018 on pc but recently the game has been unplayable with the D3D message. Seems patch 1.13 or 1.14 has made it worse for me as I had experienced it before but it was rare. Now i struggle to get through more than 5 minutes of gameplay.

I have tried all the suggested tricks to fix it (vsync windowed mode etc.), reinstalled graphics drivers and the game itself, turned down graphics settings but nothing helped. Would love to continue my career mode but I'm afraid I'm going to have to wait until the issue is fixed before I can play the game again. Regretting not getting it on ps4 at this stage. Must be mentioned that I don't have any issues in other games like assassin's creed just in F1 2018.

Key pc specs:
- i7 8700k
- RTX 2080
- 3200mhz ram

Hopefully this issue is fixed soon!

Share this post


Link to post
Share on other sites
  • 0
Anyone watching Gamers Nexus investigations into RTX issues? Apparently multi monitor causing issues too, might be something to try for anyone with such a setup. 

Share this post


Link to post
Share on other sites
  • 0
@wchsam92 - the devs have had a look and think that your gfx card may fall below minimum specs. It's technically higher than the GT 640 listed as minimum spec, but the 650M variant packs a bit less punch. As such, it looks like the game would need to be run on pretty much minimum settings to run properly.

The settings for safe mode are the same as the ultra low defaults except:

  • The game runs in Windowed Mode at 1024 x 767 resolution
  • TAA is Off
  • Weather Effects are set to low
So, you should be able to run without using safe mode by using the ultra low graphics preset with the above additional changes.

Here is a comparison of your original gfx settings compared to what the safe mode sets these to:
  • Full screen 1366 x 768, vsync on (Safe mode: 1024 x 768 vsync off)
  • AA – TAA + Checkerboard (Safe mode: Off)
  • Anisotropic filter 16x (Safe mode: Off)
  • Lighting Quality – Medium (Safe mode: Low)
  • Post process – Medium (Safe mode: Low)
  • Vehicle reflections – Low (Safe mode: Ultra Low)
  • Weather effects – Medium (Safe mode: Low)
  • Skidmarks – High (Safe mode: Off) 

Share this post


Link to post
Share on other sites
  • 0
Hi @mattvav - The easiest way to improve stability is to cap the frame rate. You can do this now in the video mode settings in the game's graphics options. If you cap it at a frame rate under what you'd usually expect to hit with your current graphics settings then this will give your system a little extra headroom which can alleviate any potential issues due to overloading the hardware or drivers. Please can you try this and let us know if this helps at all?

Share this post


Link to post
Share on other sites
  • 0
Guest
my pc system is old. Why do not I have any problems? everything is going very well. 1920x1080p, high and ultra high. never crash, stutter or something.

=gesamt 8 GB DDR3
ASRock FM2A85X Extreme4-M
AMD A85X (Hudson-D4)
AMD Athlon X4 760K
3800.0 MHz/4100.0 MHz
NVIDIA GeForce GTX 750 Ti 2 GB

Share this post


Link to post
Share on other sites
  • 0
Guest
Hoo said:
@wchsam92 - the devs have had a look and think that your gfx card may fall below minimum specs. It's technically higher than the GT 640 listed as minimum spec, but the 650M variant packs a bit less punch. As such, it looks like the game would need to be run on pretty much minimum settings to run properly.

The settings for safe mode are the same as the ultra low defaults except:

  • The game runs in Windowed Mode at 1024 x 767 resolution
  • TAA is Off
  • Weather Effects are set to low
So, you should be able to run without using safe mode by using the ultra low graphics preset with the above additional changes.

Here is a comparison of your original gfx settings compared to what the safe mode sets these to:
  • Full screen 1366 x 768, vsync on (Safe mode: 1024 x 768 vsync off)
  • AA – TAA + Checkerboard (Safe mode: Off)
  • Anisotropic filter 16x (Safe mode: Off)
  • Lighting Quality – Medium (Safe mode: Low)
  • Post process – Medium (Safe mode: Low)
  • Vehicle reflections – Low (Safe mode: Ultra Low)
  • Weather effects – Medium (Safe mode: Low)
  • Skidmarks – High (Safe mode: Off) 
Well the thing is its actually 2x GT650M in SLI mode which technically should be better than GT640, and for some reason AA i need to set TAA Checkerbox, anything else be it off, TAA the scaling is not as good, lower gpu usage. This is also happening in F1 2017 which I manage to get SLI working too using F1 2018's NVIDIA profile. Did more testing today and although it still crashes but much less often as before, like once every 3 race. To be safe, besides keeping my existing tweak (custom pagefile and -safemode) im using the mid session save every 5 laps, so that i do not need to restart a race if it crashes midway.

EDIT: I would like to add, what i did everytime when i start the game now (with -safemode) is go into settings and re-set settings back to what had worked for me, the ones you indicated above.

And I would like to bring your attention to the F1 2018 steam discussion forums, there are plenty who reported the same problem (D3D removed), some with way better hardware that I had. Some mentioned it only started since 1.13, well I cannot verify this as i only purchased this game about a fortnight ago, and its already patched to 1.13.

Share this post


Link to post
Share on other sites
  • 0
Guest
Hoo said:
Hi @mattvav - The easiest way to improve stability is to cap the frame rate. You can do this now in the video mode settings in the game's graphics options. If you cap it at a frame rate under what you'd usually expect to hit with your current graphics settings then this will give your system a little extra headroom which can alleviate any potential issues due to overloading the hardware or drivers. Please can you try this and let us know if this helps at all?
Hi Hoo,

I tried capping the frame rate at 40 fps but this didn't help much at all. However, I realised that both the race and practice session I was having the D3D issue in were wet sessions (only light rain). I tried a 25% race at the same track in the dry and had no issues the whole race so I went back to career mode and skipped to the next session which was dry and again had no issues. What's more, I removed the frame rate cap and still didn't have any issues. So it seems that wet weather is causing my D3D issues.

However, earlier in the career mode there was a wet race and I didn't have any issues in that so I still think it has become worse since the recent patches.

So hopefully not many wet sessions upcoming in my career mode until this issue is resolved somehow.

Share this post


Link to post
Share on other sites
  • 0
@mattvav - would you be able to try the turning down the weather effects setting in the advanced graphics options menu to see if that allows you to play wet weather races successfully?

Share this post


Link to post
Share on other sites
  • 0

I upgraded my pc from a 5 year old spec to a RTX 2070 + Ryzen 2700x. Havent had the problem on the old pc. 

Was first in our league with 4 points on p2. Now after this problem in lap 20 in brazil (penultimate race #20) ive lost the whole championship. WP.

Can play division 2 on ultra settings, without any problem... 

Share this post


Link to post
Share on other sites
  • 0

Had a real bad time with this myself.  Not 100% sure but i think turning off fast startup in control panel power options may have fixed this for me.

have run 3 test races since and no D3D error crash.

Share this post


Link to post
Share on other sites
  • 0
On 11/8/2018 at 3:27 AM, Hoo said:

You could try deleting / renaming your current hardware settings file

How do I do this, where is the file located?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×