Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

[PC] Tips for Diagnosing Frame Stalls During Races

Recommended Posts

@supersnel - I'm sorry that the issue has returned. I believe you were running the game using a frame cap from Insights (or similar software). Have you tried disabling that frame rate cap and using the in-game one as there is a chance that these are conflicting?

Share this post


Link to post
Share on other sites
I haven't seen it mentioned, but for me the worst stuttering/lag is in career mode. At Baku and P1 I get severe lags like three or four times a lap (0.5s), whitch makes it almost imossible to complete a lap without hitting a wall.

However, in Time Trial and a single Grand Prix I only get the "microstuttering" that is a little annoying but not crucial.

Can it be something about my career file that had been the same since release date? Should I reset it?

(My GPU is a GTX 1060 6MB.)

Share this post


Link to post
Share on other sites
@xdannil - there shouldn't be anything in the save file which would affect performance, so I wouldn't recommend deleting your career save. You could try and start a new career profile and see if that also suffers from the same issues? 

Time Trial is generally easier on performance as there is only one proper car on track. However, Grand Prix and Career mode should be close. It'd be good to know if others are seeing similar patterns with career mode being noticeably worse than Grand Prix mode.

Share this post


Link to post
Share on other sites
Guest
I have had enough.  Since patch 1.13 the game is almost unplayable in career and online.  Just done a career mode race in azerbijan and the stalls were so bad, the car stuttered around the whole track.

Mine ssues mainly occur on bends, bumpy track sections and if near other cars.

I've tried everything talked about here but nothing works.

My specs are:
AMD Fx 6300 3.50 Ghz 6-core
Geforce 160 GTX 6 gb
16 gb ram
Game installed on its own SSD
Win 7 home premium

DxDiag sent in.

Share this post


Link to post
Share on other sites
Ok, career mode suddenly works much better, and game seem to be playable again (the career save is the very same).

All I did was to install new Nvidia drivers (416.81) and turned off Rapid mode on my Samsung SSD drive. (I don't know which fixed it).

Share this post


Link to post
Share on other sites
Hi @xdannil - that's great news. I'd be really interested to know if Rapid Mode was a factor in causing your issue. Do you have any desire to turn it back on again and see if the stuttering comes back? 

Share this post


Link to post
Share on other sites
Guest
Since my last post I’ve run the sound through my gfx card instead of the motherboard and the game has improved dramatically. Still have some micro stutter and the odd stall(0.2s), but it is loads better. 

Share this post


Link to post
Share on other sites
Hoo said:
Hi @xdannil - that's great news. I'd be really interested to know if Rapid Mode was a factor in causing your issue. Do you have any desire to turn it back on again and see if the stuttering comes back? 
Ok, I tested to reenable Rapid Mode, and ran two laps. I had one lag for about 0.3 s, but now I'm in P2 for the same career. It seems to be somewhere in between of the best and the worst. Even before I didn't do very many laps, though, so I will try it out some more and see if I come to a pattern when I have the time. I'll tell you when I have something more about it.

Share this post


Link to post
Share on other sites
Since my last post I’ve run the sound through my gfx card instead of the motherboard and the game has improved dramatically. Still have some micro stutter and the odd stall(0.2s), but it is loads better. 
Dang, that's scientific. Fixed...sort of....perhaps.

Share this post


Link to post
Share on other sites
@Hoo
Now I have tried 10 laps with Rapid Mode on, and 10 laps with Rapid Mode off. For both I did 10 ordinary laps (no practice program) in P2 at Baku in my career.

Rapid Mode on: 4 severe lags (on the straights lyckily) and some microstuttering that I didn't count.
Rapid Mode off: 1 severe lag and a lot less microstuttering. Important though, I'm not sure that the characteristics of the lag was exactly the same. It was more like a drop in framerate than all of the previous which were more of a total freeze, so my guess is that it was actually caused by something else.

For me it seems quite clear at the moment. I will play with Rapid Mode off from now on.

My rig: i7-3820 3.6GHz, 8 Gb RAM, 64 bit Win10, Samsung SSD 850 EVO 500Gb with firmware EMT03B6Q, Logitech Driving Force GT.

Share this post


Link to post
Share on other sites
xdannil said:
@Hoo
Now I have tried 10 laps with Rapid Mode on, and 10 laps with Rapid Mode off. For both I did 10 ordinary laps (no practice program) in P2 at Baku in my career.

Rapid Mode on: 4 severe lags (on the straights lyckily) and some microstuttering that I didn't count.
Rapid Mode off: 1 severe lag and a lot less microstuttering. Important though, I'm not sure that the characteristics of the lag was exactly the same. It was more like a drop in framerate than all of the previous which were more of a total freeze, so my guess is that it was actually caused by something else.

For me it seems quite clear at the moment. I will play with Rapid Mode off from now on.

My rig: i7-3820 3.6GHz, 8 Gb RAM, 64 bit Win10, Samsung SSD 850 EVO 500Gb with firmware EMT03B6Q, Logitech Driving Force GT.
I also have the 850 EVO Magician tells me I have the latest firmware on EMT02B6Q and that is the one listed on the support page.

Rapid mode is OFF and I get 530/508 Seq. R/W and Random IOPS of 44K/43K R/W that is on a laptop on battery with Spectre patches enabled.

Share this post


Link to post
Share on other sites
Guest
Hello @all.
I have the same stuttering issue since 2 or 3 months.
I tried a lot of things. I updated all my drivers. I uninstall the game (and delete savegame).
I install the game new on another harddrive.
I updated my Samsung SSD drivers (the rapid mode btw is always off).
I uninstalled the nvidia GPU drivers and after a restart i install the new one. 
Nothing changes for me, still have the stuttering. (Austria, Bahrain, Baku, Monaco and a lot other tracks).
So i set the texture streaming to 0.
It runs a bit smoother yet but i have still stuttering during the races. I tried at least a fps cap to 70 fps and vsync on, everything runs fine. What is interesting if i set the fps cap to max, the stuttering is back.

Windows 10 64 Bit
Gtx 1080 ti aorus with Powerlimit 150%
AMD Ryzen 2700x
16 GB Ram


Sorry for my bad english, maybe one of the codemasters team is speaking german so i can better help.

Share this post


Link to post
Share on other sites
Hello guys. I upgraded my whole system except for my GPU (GTX 1060 6GB). The most notable changes regarding this game are CPU: i5 4460 -> Ryzen 5 2600 and PSU: Seasonic M12II EVO 520W -> 620W. I ran a test race on my notoriously laggy Montreal, and I didn't get any noteworthy stutter. I will keep testing for some time to see if it stays like it.

Share this post


Link to post
Share on other sites
Guest
Since my last post I've done a career race in Spain with no real issues. Not changed anything.
 Now at Monaco and the game is unplayable.  Stalls all around the circuit other than on the start/finish straight.
I know my GFX card can cope, and even though my cpu is above the minimum specs I am wondering if this is the culprit and it just can't cope.

Share this post


Link to post
Share on other sites
Ok. I still get lags in Multiplayer, so maybe Rapid Mode ON or OFF does not make a difference. Or it is a part of the problem...

What I noticed now in MP season at China was that lags ocurred in P and in R when it was raining. In Q and good wearher everything was fine.

Share this post


Link to post
Share on other sites
@xdannil - try setting the weather effects option in the advanced graphics options to Low and see if that helps with the framerate in the wet.

Share this post


Link to post
Share on other sites
Guest
@Hoo Are you still working on a solution that causes the stuttering ? Unfortunately, the problem still exists and it varies from track to track. 

Share this post


Link to post
Share on other sites
@Gamiga - we are still looking into this issue. Unfortunately, it is made difficult by different causes of the issue, many being unique to certain users' setups. We are currently trying to build a PC that will hopefully have stuttering so that we can investigate further (using similar setups to those reported in this thread). Unfortunately, we haven't yet found a setup that exhibits this problem, but we are still trying. 

From your post above, it looks like you were able to solve this by capping the frame rate. I would suggest capping frame rate without v-sync on too and see if you can get this to an acceptable frame rate that does not stutter.

If you wish to help diagnose the issue further, try running the game with uncapped frame rate (so it will stutter) with a profiler attached, such as GPU-Z, and see if the output it gives helps point to a cause of the problem. There should be info about all of this on the first page of this thread to help you work through the different techniques for providing further information.

Share this post


Link to post
Share on other sites
Guest
I am at a loss. I have now lifted all the limits and drove a complete race in China with changeable weather conditions and nothing went wrong. I will continue to test and report the log from GPU-Z as soon as there are abnormalities.

Share this post


Link to post
Share on other sites
https://forums.codemasters.com/discussion/141635/game-randomly-freezing#latest

I'm hopeless. HELP!

Share this post


Link to post
Share on other sites
Hoo said:
@Gamiga - we are still looking into this issue. Unfortunately, it is made difficult by different causes of the issue, many being unique to certain users' setups. We are currently trying to build a PC that will hopefully have stuttering so that we can investigate further (using similar setups to those reported in this thread). Unfortunately, we haven't yet found a setup that exhibits this problem, but we are still trying. 

From your post above, it looks like you were able to solve this by capping the frame rate. I would suggest capping frame rate without v-sync on too and see if you can get this to an acceptable frame rate that does not stutter.

If you wish to help diagnose the issue further, try running the game with uncapped frame rate (so it will stutter) with a profiler attached, such as GPU-Z, and see if the output it gives helps point to a cause of the problem. There should be info about all of this on the first page of this thread to help you work through the different techniques for providing further information.
You should put an Nvidia card in it perhaps. A 1060 or a 1080, perhaps both (not at the same time).

I'll be rebuilding with 17763.134 & AMD 18.11.1 today, so we'll see. 

Share this post


Link to post
Share on other sites
Hoo said:
@Gamiga - we are still looking into this issue. Unfortunately, it is made difficult by different causes of the issue, many being unique to certain users' setups. We are currently trying to build a PC that will hopefully have stuttering so that we can investigate further (using similar setups to those reported in this thread). Unfortunately, we haven't yet found a setup that exhibits this problem, but we are still trying. 

From your post above, it looks like you were able to solve this by capping the frame rate. I would suggest capping frame rate without v-sync on too and see if you can get this to an acceptable frame rate that does not stutter.

If you wish to help diagnose the issue further, try running the game with uncapped frame rate (so it will stutter) with a profiler attached, such as GPU-Z, and see if the output it gives helps point to a cause of the problem. There should be info about all of this on the first page of this thread to help you work through the different techniques for providing further information.
You should put an Nvidia card in it perhaps. A 1060 or a 1080, perhaps both (not at the same time).

I'll be rebuilding with 17763.134 & AMD 18.11.1 today, so we'll see. 
So, the 'lost focus' bug remains. I even disabled Steam cloud sync before installing. 

I also got the locked to 60FPS bug first run but I didn't use the Steam FPS counter.

Pretty much the basic benchmark test I do at Australia shows absolutely no difference to patch 1.12, driver 18.10.1 and W10 1803. (1080 High preset, Dry conditions and Cycle cam)

The framerates were better on average during builds 1.08 thru 1.10 (120-122FPS) but there's been no more than +5% average difference since release and it's on a median figure right now (118). The low (96) has barely changed save an oddity on 1.08 (90) which seems to conflict with the higher averages. The high is pretty much hitting the monitor refresh at 144 (with Freesync and V-Sync off it's in the 150s)

So, nothing to see here. I could do the GPU-Z logging at different frame caps but do I use the Adrenaline FPS Limiter, the in-game one or just lower the monitor sync and leave V-SYNC on? 

Share this post


Link to post
Share on other sites
I would suggest starting out by just capping the frame rate with the in-game option, turning v-sync off and freesync on. Start by capping this low (below the 90fps low that you were getting) and then notch it up if it looks stable. 

Share this post


Link to post
Share on other sites
Hoo said:
I would suggest starting out by just capping the frame rate with the in-game option, turning v-sync off and freesync on. Start by capping this low (below the 90fps low that you were getting) and then notch it up if it looks stable. 
OK let me play with the DX12 Beta for a bit first.  :p

Share this post


Link to post
Share on other sites
A bit of a long shot, but might be worth anyone having this issue trying out the DX12 beta if they have suitable systems: http://forums.codemasters.com/discussion/141667/the-f1-2018-dx12-beta. 

As this uses a different rendering path and drivers, this may have an impact on this issue. If you do try out the DX12 beta, please update this thread and let us know if the frame stalls still occurred.

Share this post


Link to post
Share on other sites

×