Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

[PC] Tips for Diagnosing Frame Stalls During Races

Recommended Posts

Hoo said:
A bit of a long shot, but might be worth anyone having this issue trying out the DX12 beta if they have suitable systems: http://forums.codemasters.com/discussion/141667/the-f1-2018-dx12-beta. 

As this uses a different rendering path and drivers, this may have an impact on this issue. If you do try out the DX12 beta, please update this thread and let us know if the frame stalls still occurred.
Can you fix the Fullscreen bug please? DX12 won't show any benefit if the output is scaled to a non-standard resolution, it's comparing apples to oranges. 

All the game faults are still there to cause the issue to be a major problem, the lost focus bug and the 2017/18 60FPS lock (workaround is ALT-TAB in DX11), which triggers the one bug that you've stated with this DX12 build.

I don't believe the 60FPS lock issue was there in F1 2016 but the lost focus bug has been around seemingly since the dawn of time. It's quite astounding that jumping the game in and out focus seems to randomly cause and / or fix so many issues.

Share this post


Link to post
Share on other sites
Looks like i don't get that freqeunt screen freezes in DX12. Just once or twice in a while. Now the game is "playable".

Share this post


Link to post
Share on other sites
Fking finally!! As Kimi said it after winnning the USGP!!
I no longer get the annoying screen freezes anymore.
Here is how i fixed it after weeks of suffering: :s 

1, Windows power plan set to: Prefer maximum performance.
2, Download and install the Intelligent standby list cleaner (Made by the group who makes the DDU software. )
(Download link: https://www.wagnardsoft.com/forums/viewtopic.php?f=18&t=1256&sid=8f18567914bea3193d4d339b81b2a775)
3, Make sure to start the memory cleaner before starting up the game! Also do a memory cleaning before it.
4, Download MSI Afterburner, install it, then go to the rivatuner settings and lock your fps to your screen. For example if you have a 60hz monitor 60fps, 144hz - 144fps and so on..
5, Enable vsync in your game.
That's it.. Im happy.  Game plays smooth as it should be from the start.

Share this post


Link to post
Share on other sites
ATSSHD said:
Fking finally!! As Kimi said it after winnning the USGP!!
I no longer get the annoying screen freezes anymore.
Here is how i fixed it after weeks of suffering: :s 

1, Windows power plan set to: Prefer maximum performance.
2, Download and install the Intelligent standby list cleaner (Made by the group who makes the DDU software. )
(Download link: https://www.wagnardsoft.com/forums/viewtopic.php?f=18&t=1256&sid=8f18567914bea3193d4d339b81b2a775)
3, Make sure to start the memory cleaner before starting up the game! Also do a memory cleaning before it.
4, Download MSI Afterburner, install it, then go to the rivatuner settings and lock your fps to your screen. For example if you have a 60hz monitor 60fps, 144hz - 144fps and so on..
5, Enable vsync in your game.
That's it.. Im happy.  Game plays smooth as it should be from the start.

Points 4 and 5 make no sense? If you enable V-Sync, you are automatically limited to your monitor's refresh rate. Also setting a frame limit at the refresh rate without V-Sync will create terrible tearing. I use 65 FPS for 60 Hz and the tearing is not that visible. Also V-Sync with a wheel is a big no-no. So much input lag.

Happy it works for you just wanted to clarify the last 2 steps.

Share this post


Link to post
Share on other sites
@ATSSHD - I'd be interested to know what happens if instead of doing steps 4 and 5 whether you just lock the frame rate using the in-game setting? Also, is the stuttering fixed after step 3, or does it require you to lock the frame rate?

Share this post


Link to post
Share on other sites
I know it's makes a bit of nonsense, but if you only use vsync your game will have frametime spikes. MSI Afterburner is much better for that and you get constant 16.6 ms frames for example if you use a 60hz monitor. If i only use the ingame vsync without the fps lock in afterburner my game is still getting the same frame freezes that i had before.
+ I use the ingame vsync beacuse i dont get the tearing.


I don't use the ingame fps lock, it doesn't work for me. Also if i enable it at 60 i get 57 fps if i lock ingame at 80 i get 77 and so on. = Frame freezing and tearing.
Thats why i used afterburner and did the trick!

I write down my specs again maybe someone with a similar pc or similar issue find the solution useful:
Ryzen 5 1600
GTX 1060 
2x4 GB 3000 MHz HpyerX  RAM

Share this post


Link to post
Share on other sites
ATSSHD said:
**** finally!! As Kimi said it after winnning the USGP!!
I no longer get the annoying screen freezes anymore.
Here is how i fixed it after weeks of suffering: :s 

1, Windows power plan set to: Prefer maximum performance.
2, Download and install the Intelligent standby list cleaner (Made by the group who makes the DDU software. )
(Download link: https://www.wagnardsoft.com/forums/viewtopic.php?f=18&t=1256&sid=8f18567914bea3193d4d339b81b2a775)
3, Make sure to start the memory cleaner before starting up the game! Also do a memory cleaning before it.
4, Download MSI Afterburner, install it, then go to the rivatuner settings and lock your fps to your screen. For example if you have a 60hz monitor 60fps, 144hz - 144fps and so on..
5, Enable vsync in your game.
That's it.. Im happy.  Game plays smooth as it should be from the start.

I'm also not going to be implementing this 'fix'.There's no way you should have to set your power plan to not having a power plan.

As for RAM cleaners, my word are we really back in the days of 640KB DOS? I think not. I have respect for Wagnardsoft's DDU but this utility should not be necessary.

Also think that the input lag attached to V-SYNC is the issue why we can't run low (i.e. 60FPS) refresh rates. It's a definite thing if I play at 100FPS average as opposed to 60FPS. 


Share this post


Link to post
Share on other sites
The problem is windows. Other games have this issue too..

Windows is not releasing the ram properly and holding it in.
Search it up in reddit or watch youtube videos about it, and you will see those game freezes when people playing bf1,bf5,pubg etc. Even in the latest 1809 build, the bug is still not fixed by Microsoft.

Some people have this issue and going crazy like me, and others have no issues. No idea why..

Share this post


Link to post
Share on other sites
ATSSHD said:
I know it's makes a bit of nonsense, but if you only use vsync your game will have frametime spikes. MSI Afterburner is much better for that and you get constant 16.6 ms frames for example if you use a 60hz monitor. If i only use the ingame vsync without the fps lock in afterburner my game is still getting the same frame freezes that i had before.
+ I use the ingame vsync beacuse i dont get the tearing.


I don't use the ingame fps lock, it doesn't work for me. Also if i enable it at 60 i get 57 fps if i lock ingame at 80 i get 77 and so on. = Frame freezing and tearing.
Thats why i used afterburner and did the trick!

I write down my specs again maybe someone with a similar pc or similar issue find the solution useful:
Ryzen 5 1600
GTX 1060 
2x4 GB 3000 MHz HpyerX  RAM
I agree that that the in-game FPS lock is not really accurate. I use RTSS as well. May I ask you what kind of a PSU do you have?

Share this post


Link to post
Share on other sites
@ATSSHD / @SoloWingX - we've spotted the problem with the in-game FPS cap and will be rolling out a fix in the next update.

Share this post


Link to post
Share on other sites
Guest
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.

Share this post


Link to post
Share on other sites
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.

Share this post


Link to post
Share on other sites
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
AMD ReLive!, Nvidia Shadowplay, OBS - if you could fix those, that gives both the red and green teams a couple of options each.

People use Twitch and YouTube to stream - again, it's a couple of options that cover mostly everyone.

Share this post


Link to post
Share on other sites
Guest
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
FBX Game Recorder I find gives me best performance of all game recording software.

Share this post


Link to post
Share on other sites
Savajay said:
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
FBX Game Recorder I find gives me best performance of all game recording software.
Will take a look at this, thanks.

Share this post


Link to post
Share on other sites
Guest

Savajay said:
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
FBX Game Recorder I find gives me best performance of all game recording software.
Will take a look at this, thanks.
I can produce some gameplay for you if you require it.

Share this post


Link to post
Share on other sites
SoloWingX said:
ATSSHD said:
I know it's makes a bit of nonsense, but if you only use vsync your game will have frametime spikes. MSI Afterburner is much better for that and you get constant 16.6 ms frames for example if you use a 60hz monitor. If i only use the ingame vsync without the fps lock in afterburner my game is still getting the same frame freezes that i had before.
+ I use the ingame vsync beacuse i dont get the tearing.


I don't use the ingame fps lock, it doesn't work for me. Also if i enable it at 60 i get 57 fps if i lock ingame at 80 i get 77 and so on. = Frame freezing and tearing.
Thats why i used afterburner and did the trick!

I write down my specs again maybe someone with a similar pc or similar issue find the solution useful:
Ryzen 5 1600
GTX 1060 
2x4 GB 3000 MHz HpyerX  RAM
I agree that that the in-game FPS lock is not really accurate. I use RTSS as well. May I ask you what kind of a PSU do you have?
EVGA 450 W BR, bought it like a month ago.

Share this post


Link to post
Share on other sites
ATSSHD said:
SoloWingX said:
ATSSHD said:
I know it's makes a bit of nonsense, but if you only use vsync your game will have frametime spikes. MSI Afterburner is much better for that and you get constant 16.6 ms frames for example if you use a 60hz monitor. If i only use the ingame vsync without the fps lock in afterburner my game is still getting the same frame freezes that i had before.
+ I use the ingame vsync beacuse i dont get the tearing.


I don't use the ingame fps lock, it doesn't work for me. Also if i enable it at 60 i get 57 fps if i lock ingame at 80 i get 77 and so on. = Frame freezing and tearing.
Thats why i used afterburner and did the trick!

I write down my specs again maybe someone with a similar pc or similar issue find the solution useful:
Ryzen 5 1600
GTX 1060 
2x4 GB 3000 MHz HpyerX  RAM
I agree that that the in-game FPS lock is not really accurate. I use RTSS as well. May I ask you what kind of a PSU do you have?
EVGA 450 W BR, bought it like a month ago.
Before I upgraded I had a lot of lag spikes. I had a Seasonic 520W PSU paired with an older PC (i5 4460, 1060 6GB, 8GB RAM), but no visible bottleneck on F1 2018. Now I have a similar PC to yours (Ryzen 2600, 1060 6GB, 16GB RAM), BUT I also bought a new PSU, Seasonic 620W. I no longer get these lag spikes. Might be correlated. F1 2018 might need more overhead? I know that F1 2017 was the first game that indicated the failure of my even older PSU... So I see some trend there. To get to the bottom of this I would experiment with changing the PSU if you have some money you can "throw away" or lend a stronger PSU from a friend if you can. I have a strong feeling it's a big factor.

Share this post


Link to post
Share on other sites
@Hoo I guess you guys have a lot of hardware hanging around. Have you experimented with some lower wattage PSUs? Because as we can see, strong CPUs and GPUs are getting this problem, while sometimes weaker PCs have no such problems. So it can't be that. But what power supply it's paired with... that is something we rarely ask. Maybe your engine needs more overhead to provide smooth gameplay...

As I said after I upgraded I no longer have this problem, the game is a LOT of FUN, I tell you. I just... want to help solve it, because everyone should get the chance to enjoy this game :) And I have a hunch this could be something.

Share this post


Link to post
Share on other sites
Tomorrow i upgrade my ram to 16GB from 8 idk it's going to mean anything..

FX6300 OC'd to 4.2 GHZ, 1050Ti too by +150 core & 500 mhz memory w 16GB ddr3 memory i was able to run the game on med-high settings without issues and the psu was a cheap 400w chieftec which is 7 years old. ( This was somewhere at release.)


Now i have the listed ryzen build.

Share this post


Link to post
Share on other sites
450 watt psu is not enough.
i replaced mine with a 750 watt.
most of the stutters are gone.
now i have or network lag, or the the lag spikes when you hit a curb or something.
but those 2 a minor spikes.

Share this post


Link to post
Share on other sites
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
AMD ReLive!, Nvidia Shadowplay, OBS - if you could fix those, that gives both the red and green teams a couple of options each.

People use Twitch and YouTube to stream - again, it's a couple of options that cover mostly everyone.
Do you know if these actually cause problems with stuttering at the moment? Our broadcast team use OBS, so this should be working fine (or certainly used to be working fine), unless there are certain combinations of kit and capture settings that are problematic.

Share this post


Link to post
Share on other sites
SoloWingX said:
@Hoo I guess you guys have a lot of hardware hanging around. Have you experimented with some lower wattage PSUs? Because as we can see, strong CPUs and GPUs are getting this problem, while sometimes weaker PCs have no such problems. So it can't be that. But what power supply it's paired with... that is something we rarely ask. Maybe your engine needs more overhead to provide smooth gameplay...

As I said after I upgraded I no longer have this problem, the game is a LOT of FUN, I tell you. I just... want to help solve it, because everyone should get the chance to enjoy this game :) And I have a hunch this could be something.
I had previously suggested this, but it wasn't well received. Our Compliance team are very particular about configuring their rigs with appropriate sets of components and weren't keen on deliberately running with inadequate power supplies. 

Share this post


Link to post
Share on other sites
artworx said:
450 watt psu is not enough.
i replaced mine with a 750 watt.
most of the stutters are gone.
now i have or network lag, or the the lag spikes when you hit a curb or something.
but those 2 a minor spikes.
How is it not enough? lol
I can run fine every game on High/Ultra, i only have problems with the F1  game.

Midrange pc doesnt even use over 350 W when under full load.

Share this post


Link to post
Share on other sites
Hoo said:
Hoo said:
Savajay said:
I suffer from no lag problems at all when running the game.

As soon as a load a cgame capture software, I get random freezes in the game, always at the same corners of the track. 

It does not affect me on any other game at all Just F1 2018.
Please could you let us know which specific piece of software you are running that causes these problems? Thanks.
AMD ReLive!, Nvidia Shadowplay, OBS - if you could fix those, that gives both the red and green teams a couple of options each.

People use Twitch and YouTube to stream - again, it's a couple of options that cover mostly everyone.
Do you know if these actually cause problems with stuttering at the moment? Our broadcast team use OBS, so this should be working fine (or certainly used to be working fine), unless there are certain combinations of kit and capture settings that are problematic.

I find OBS less demanding (i.e. it sucks less performance away from the FPS). Shadowplay and ReLive! are the "lazy / easy" options as they're built into the driver (unless you go to the trouble of removing them, particularly since Nvidia introduced the black box / telematic installs).

AMD at least chain ReLive! onto the install so you can just restart and it doesn't require you to sign in to use the feature.

Share this post


Link to post
Share on other sites

×