Jump to content
  • 0
Sign in to follow this  

DR - Progressive problems with fps drops/stutters (Tried other solutions)


I bought DR as part of the midweek sale on Steam today and was disappointed that the game was having severe stutter problems, despite running a solid 120FPS (Or so it seems).

My pc setup:
Asus ROG Crosshair VI Motherboard
Ryzen 7 1800X
GTX 1080
Game currently runs on 7200RPM HDD
Windows 10 Pro 1809 OS-version 17763.55

I've looked up this problem and found to say the least, wildly different solutions for this problem. One common thing with many of them is the use of a USB peripheral like wheel, shifter etc. but I am not using any of that.
I have been trying to use a PS4 controller, but I get the same problem with it disconnected. Only mouse and keyboard connected and still problems.
The wierd thing is, this is not an instant thing. The game runs fine when I start a rally stage, but progressively gets worse during my play, up to the point where controlling the car becomes impossible. Sometimes it takes half a stage for this to happen, other times it takes a couple of stages.

I have tried to set the game to run as admin, to run in compatability mode.
I have updated chipset drivers as some suggested that could work.
I have updated Logitech software, as this was also pointed at as a problem. I have made a specific profile for DR as suggested.
I checked if UI control with mouse was off, which it is.
I have tried all different graphical settings
I have made sure I have the newest GeForce drivers.
I have tried to put V-sync on and limit to 60fps, despite a 144Hz monitor.

Friend of mine, with a bit lower specs but relatively similar setup, have absolutely no issues. He is also running Win 10. He is using a G920 Wheel and pedals as well, which I've read can cause issues, but in his case does not.

The only thing I have yet to try is the registry tweak to check if Steam is running in compatability mode, but to be frank: none of this should be needed to run the game without that sort of issue.
Reqs on game too high for the setup, no issues with that, but this is clearly not the case here.

Has this problem been invastigated any further or has it just been dropped dead due to the game being a few years old by now?

Share this post

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this