Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

The F1 2018 DX12 Beta Discussion Thread [UPDATE - 06/12]

Recommended Posts

UP100 said:
artworx said:
ok, did some testing offline and online.
seems both are steady for me.!
only thing is "the work in progress"bar on top of the screen the whole time.

https://imgur.com/BwDmRdW
https://imgur.com/b2uiSUz
Which one of those is the DX12 version? I would guess it to be the one with a bit higher framerate?
The one with “work in progres” is dx12

Share this post


Link to post
Share on other sites
Thanks @artworx. Glad to see it working ok.

Share this post


Link to post
Share on other sites
Correct me if I’m wrong but.

I get WORK IN PROGRESS in dx11 and dx12 modes of operation.

I think it’s more to do with running the beta branch than being dx11 or dx12.

opt out of the beta and it should revert to dx11 without the WORK IN PROGRESS banner

Share this post


Link to post
Share on other sites
artworx said:
UP100 said:
artworx said:
ok, did some testing offline and online.
seems both are steady for me.!
only thing is "the work in progress"bar on top of the screen the whole time.

https://imgur.com/BwDmRdW
https://imgur.com/b2uiSUz
Which one of those is the DX12 version? I would guess it to be the one with a bit higher framerate?
The one with “work in progres” is dx12
Holy shit how did I miss it...

Share this post


Link to post
Share on other sites
Correct me if I’m wrong but.

I get WORK IN PROGRESS in dx11 and dx12 modes of operation.

I think it’s more to do with running the beta branch than being dx11 or dx12.

opt out of the beta and it should revert to dx11 without the WORK IN PROGRESS banner

i know that,
but it would be nicer to change "the work in progress" to dx12beta in a corner.

Share this post


Link to post
Share on other sites
AMD Vega 64 graphic card with Freesync on.
AMD CPU Threadripper 16 threads 1950x 64GB RAM

No graphic difference found yet. I saw a slight improvement in FPS in online race in Canada recorded by AMD Relive in 1920x1080p.
DX11 : 28 000 kbits/sec
DX12 : 29 000 kbits/sec

I found the Work in Progress a little annoying because i record my races. Is it possible to replace this by a discrete DX12 inscription onscreen ?

Share this post


Link to post
Share on other sites
basically i do not have any problems with this dx 12 beta,i am playing online and game running very well
my benchmark result
https://photos.app.goo.gl/KjjMDWxbVchnJiVA8

Share this post


Link to post
Share on other sites
I have to say so far so good, did a race and not 1 frame drop. Usually have a big problem with the game dropping frames and freezing for a second mid race. Like only like once or twice a race but still annoying. 

Share this post


Link to post
Share on other sites
Faya said: 

Hi all and welcome to the F1 2018 DX12 Beta discussion thread.

You can find main The F1 2018 DX12 Beta post here, which has all the information about the beta.

Please report any issues to us in this thread below – especially if something’s happened in your game, something looks wrong, or you encounter something you hadn’t noticed in the standard (DX11) version of the game.

If we get numerous reports on the same issue then we may break these out into their own support thread to make issues easier to track.

When reporting something, please be sure to add your basic system specs in your post, so that you can help us identify issues with specific hardware configurations.

 


Finally! Thank you so much Codies.
Hopefully this will make performance a little bit better and will maybe add some more stability.

Share this post


Link to post
Share on other sites
Hi,

I tryed both dx11 and dx12 an extensive amount of tests. My results were pretty bad for dx12. I had on average about 30% less fps with the newer version. I am using 8700 and a 1060 3gb with 16 gb of ddr4 ram in 3200mhz. If you want my dxdiag contact me Codemasters

Share this post


Link to post
Share on other sites
Brawli said:
Hi,

I tryed both dx11 and dx12 an extensive amount of tests. My results were pretty bad for dx12. I had on average about 30% less fps with the newer version. I am using 8700 and a 1060 3gb with 16 gb of ddr4 ram in 3200mhz. If you want my dxdiag contact me Codemasters
Thanks for testing this out. If you could let us know your resolution and in-game gfx settings that would be helpful.

Share this post


Link to post
Share on other sites
So I've done multiple online lobbies including tracks like Baku and have not gotten a single stutter whilst recording so it's a thumbs up so far for me. FPS maintains pretty much the same (no benchmarks yet), no major increases/decreases that I've noticed. Just glad the stuttering is gone so far.

Only problem so far was whilst recording in OBS, the menu flickers in the recording such as the main menu, and garage menus for setup etc. I've tried anti-cheat compatibility, but enabling third party overlays seems to fix some menu screens like the main menu, but not the garage menu.

Share this post


Link to post
Share on other sites
Guest
Since switching to the beta branch I've run into 2 issues. My load times have gone up noticeably (I don't see why this would be related, might be something else) and I started getting screen freezes running DX12 mode. Most recently I ran it in DX11 mode (but still on the Beta) and didn't have the screen freeze issues.

Core i7 7700k
16GB RAM
6GB GeForce GTX 1060 @ 1440p

Share this post


Link to post
Share on other sites
Qres said:
Since switching to the beta branch I've run into 2 issues. My load times have gone up noticeably (I don't see why this would be related, might be something else) and I started getting screen freezes running DX12 mode. Most recently I ran it in DX11 mode (but still on the Beta) and didn't have the screen freeze issues.

Core i7 7700k
16GB RAM
6GB GeForce GTX 1060 @ 1440p
Yes, load times are highly frustrating. 

Share this post


Link to post
Share on other sites
Qres said:
Since switching to the beta branch I've run into 2 issues. My load times have gone up noticeably (I don't see why this would be related, might be something else) and I started getting screen freezes running DX12 mode. Most recently I ran it in DX11 mode (but still on the Beta) and didn't have the screen freeze issues.

Core i7 7700k
16GB RAM
6GB GeForce GTX 1060 @ 1440p
Are the screen freezes occurring when on track, or in the menus, or everywhere? Is a brief frame spike or a long freeze? How often does this occur?

Share this post


Link to post
Share on other sites
@Qres, @steviejay69 - the load times are a little longer due to the extra setup that the renderer has to do. It shouldn't be a massive difference though. What sort of load times are you getting now compared to the DX11 version? 

Share this post


Link to post
Share on other sites
Hoo said:
@Qres, @steviejay69 - the load times are a little longer due to the extra setup that the renderer has to do. It shouldn't be a massive difference though. What sort of load times are you getting now compared to the DX11 version? 

From clicking the launch DX11 it's 24 seconds until the intro sequence starts (audio/visual cues, not including appearance of WORK IN PROGRESS banner). On DX12 it's 47 seconds.

I have an NVMe drive so it must be the renderer difference. @Hoo

Share this post


Link to post
Share on other sites
@steviejay69 - thanks for the info. I'll pass this on to the dev team.

Share this post


Link to post
Share on other sites
Guest
Hoo said:
Qres said:
Since switching to the beta branch I've run into 2 issues. My load times have gone up noticeably (I don't see why this would be related, might be something else) and I started getting screen freezes running DX12 mode. Most recently I ran it in DX11 mode (but still on the Beta) and didn't have the screen freeze issues.

Core i7 7700k
16GB RAM
6GB GeForce GTX 1060 @ 1440p
Are the screen freezes occurring when on track, or in the menus, or everywhere? Is a brief frame spike or a long freeze? How often does this occur?
On track, almost exclusively when other cars are around me. Fairly brief, just long enough to cause collisions. It's fairly consistent as well, if it's me and at least 2 other cars it's basically guaranteed to happen. When it happens and causes a collision, if I rewind it won't re-occur most of the time. EDIT: Just for comparison, I basically NEVER got screen freezes before going on the Beta.

On the load time issue, I have an SSD for my main drive (Samsung 860 EVO) and a WD 7200rpm harddrive as a secondary drive. Windows is on the SSD and the game is installed on the platter drive. I'd ballpark it as being a good 50% increase in load time vs non-Beta DX11.

Share this post


Link to post
Share on other sites
Well this evening is ruiind for me, after practising my ass off last week for the leaguerace on abu dhabi my game had lag spikes all over.
I have tested it last week, and the where no problems but this afternoon i've got a 3 sec freeze, so i've decided to race the old fashioned way (DX11).
So i selected the normal F1 2018 button, but had the "work in practice" sigh above, strange??

The race felt different, like the frames weren't fluent, sometime faster. And at the end of my first stint i got is major 3 sec freeze, others where driving throug me and i've got a penaltuy for an illigal overtake (i even couldn't control my car for crying out loud). 

I recorded the complete race (atleast until i've ended it) it was undrivable.
Before I had never got such issues.
Nice job codies.... I will delete everything and reinstall the game. (not happy)

7700K @ 5Ghz.
32GB 3000mhz
GTX1080Ti @2000Mhz and 3440x1440 
All water cooled
Game settings: All on max. 

Share this post


Link to post
Share on other sites
After trying the beta, my experiences are sadly negative.
I tested France in Time Trial.

Settings: High preset, 3840x2160 resolution (4K), TAA off, AF x16, Vsync off
PC: i5 8600K, 16GB 2400MHz DDR4 RAM, GTX 1070 Ti, Samsung 500GB M.2 SSD, Windows 10 version 1709 (yes that's not a typo, I'm still on 1709)

Here's my summary:


DX12: 
  • FPS is generally worse than DX11. I am used to the framerate going lower when you go into the setup screen in the garage, but in DX12 it went down to 33 FPS. On track, the game was constantly between 55 and 65 FPS, and I constantly had small framedrops/stutters which were really annoying and hindered gameplay.

DX11:
  • FPS in the garage screen only goes down to the low 50s instead of 33 on DX12. On track, I have between 70 and 80 FPS everywhere and I get no stuttering at all.

So conclusion is that with DX12 I lost about 15-20 FPS and I get annoying stuttering, so I reverted back to DX11 which seems to be flawless for me.

Share this post


Link to post
Share on other sites
Windows 10 Driver releases are targeted at different versions of Windows, so you have to keep up to hit the moving target.

Also, as has been shown with the Intel driver update that's paused Windows 10 October Update again, performance targets and feature support have caused underlying issues.

So running new drivers on old W10 and old drivers on new W10 (harder but possible) is not good. I can't be bothered to do the legwork for two reasons.

Microsoft's update cadence is too fast. Vendor driver updates are haphazard game-focused affairs (AMD slightly better than Nvidia in that respect).

Your mileage may very well vary.

Share this post


Link to post
Share on other sites
HDR is greyed out for me in the menu and it's not working with DX12.  Is it supposed to be? 
Hi. Unfortunately HDR support is not implemented in the DX12 beta. 

Share this post


Link to post
Share on other sites

×