Jump to content

The F1 2018 DX12 Beta Discussion Thread [UPDATE - 06/12]

Recommended Posts

HDR is greyed out for me in the menu and it's not working with DX12.  Is it supposed to be? 
Hi. Unfortunately HDR support is not implemented in the DX12 beta. 

Share this post


Link to post
Share on other sites
@Lockheat - to revert to the standard DX11 version please re-enter the game properties panel and select "None" in the betas tab. The game should re-patch itself to the original game. If you still the see "Work in Progress" bar then something has gone wrong (I'd suggest trying to validate Steam cache initially).

Share this post


Link to post
Share on other sites
@Hoo I've selected "none" in the betas tab and the game runs like before & it functions like it should, thx. Don't get me wrong, I do appriciate the effort to provide us DX12 support (and as a preparation for next years game, right?) . It just was harsh to end up, the final and last online league race on a DNF and trowing away the championship over this.

Share this post


Link to post
Share on other sites
I'd be curious to see how a build without Denuvo runs, regardless of the DirectX version. I'm not saying it's the cause, but as a developer it's something I would at least test out of curiosity. These stutters have a cause, and other games have reported issues with Denuvo, so it's a worthy stab in the dark IMO.

Share this post


Link to post
Share on other sites
Lockheat said:
@Hoo I've selected "none" in the betas tab and the game runs like before & it functions like it should, thx. Don't get me wrong, I do appriciate the effort to provide us DX12 support (and as a preparation for next years game, right?) . It just was harsh to end up, the final and last online league race on a DNF and trowing away the championship over this.
It really needs fixing for the fullscreen frame lock or the ALT-TAB. If the game goes purely DX12 then W7 users can't use it. F1 2020 would be the first game where they don't need to support W7 but there were some efforts to help players on Vista this time around.

Share this post


Link to post
Share on other sites
DX12 will enable DXR and therefore RTX. With RTX just working, I guess Codies are hoping that rubs off??

Jokes aside, good to see this.

Share this post


Link to post
Share on other sites
We are investigating fixes for the Windows 1809 issues (frame locking and window focus). If these work then we'll see if we can roll these into an updated DX12 beta with. We'll let you know once we get more info.

Share this post


Link to post
Share on other sites
Guest
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.

Share this post


Link to post
Share on other sites
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.

 Hi @Savajay. Thanks for taking the time to try out the DX12 beta.

Your system specs should be fine for running the game, so something else is causing problems here. When the game terminates like that without a game error this usually suggests something has gone wrong Windows-side. Often this relates to issues with the graphics drivers, or the configuration the game is attempting to run at on your hardware. The first thing to check is whether your graphics drivers are up-to-date and that you have any associated Windows updates installed. The next thing to look at is your hardware_settings file. I'd recommend deleting this file and launching the game again as it has be known for this file to become corrupt. Deleting this file forces the game to create a new hardware_settings file using default settings taken from your current Windows settings. If this doesn't solve your problem then please send through your dxdiag and hardware_settings file and we'll take a further look. 

Info on where to find these files and where to send them are contained in this post.

Thanks.

Share this post


Link to post
Share on other sites
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.
i3-7100 is not old. It is a Kaby Lake 3.9 dual-core with HT (non-Turbo). You should perhaps check your motherboard for updates as Kaby Lake has errata that can be fixed with uCode (there may be mileage in disabling HT). Your GPU is fully DX12 capable, but you should use the latest drivers. Use DDU to remove the existing drivers and install the new ones.

Share this post


Link to post
Share on other sites
Guest
Hoo said:
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.

 Hi @Savajay. Thanks for taking the time to try out the DX12 beta.

Your system specs should be fine for running the game, so something else is causing problems here. When the game terminates like that without a game error this usually suggests something has gone wrong Windows-side. Often this relates to issues with the graphics drivers, or the configuration the game is attempting to run at on your hardware. The first thing to check is whether your graphics drivers are up-to-date and that you have any associated Windows updates installed. The next thing to look at is your hardware_settings file. I'd recommend deleting this file and launching the game again as it has be known for this file to become corrupt. Deleting this file forces the game to create a new hardware_settings file using default settings taken from your current Windows settings. If this doesn't solve your problem then please send through your dxdiag and hardware_settings file and we'll take a further look. 

Info on where to find these files and where to send them are contained in this post.

Thanks.
Thanks. I have hardware_settings_info and hardware_settings_config, what should I delete?

Share this post


Link to post
Share on other sites
Guest
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.
i3-7100 is not old. It is a Kaby Lake 3.9 dual-core with HT (non-Turbo). You should perhaps check your motherboard for updates as Kaby Lake has errata that can be fixed with uCode (there may be mileage in disabling HT). Your GPU is fully DX12 capable, but you should use the latest drivers. Use DDU to remove the existing drivers and install the new ones.

I am pretty sure I am running the latest drivers, as Geforce Experience was only updated two days ago with Game Ready Driver 417.01.

Share this post


Link to post
Share on other sites
Savajay said:
Hoo said:
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.

 Hi @Savajay. Thanks for taking the time to try out the DX12 beta.

Your system specs should be fine for running the game, so something else is causing problems here. When the game terminates like that without a game error this usually suggests something has gone wrong Windows-side. Often this relates to issues with the graphics drivers, or the configuration the game is attempting to run at on your hardware. The first thing to check is whether your graphics drivers are up-to-date and that you have any associated Windows updates installed. The next thing to look at is your hardware_settings file. I'd recommend deleting this file and launching the game again as it has be known for this file to become corrupt. Deleting this file forces the game to create a new hardware_settings file using default settings taken from your current Windows settings. If this doesn't solve your problem then please send through your dxdiag and hardware_settings file and we'll take a further look. 

Info on where to find these files and where to send them are contained in this post.

Thanks.
Thanks. I have hardware_settings_info and hardware_settings_config, what should I delete?
Config but renaming them will do.

You should look at motherboard updates also.

Share this post


Link to post
Share on other sites
Guest
Tried it this steviejay69 said:
Savajay said:
Hoo said:
Savajay said:
I have had to give up on Directx12.

I run an i3 7100 3.9ghz with a 1060 6gb GPU. I appreciate an i3 is quite old, but it does the job.

The issue I have with Directx12 is that after booting up the game, I can go through the menus fine but as soon as I want to load a road, when it goes to the intro screen the game just shuts down and disappears from the screen without notice.

If anyone can shed any light on this, great. If not, I will have to revert back to Directx11.

Thank you.

 Hi @Savajay. Thanks for taking the time to try out the DX12 beta.

Your system specs should be fine for running the game, so something else is causing problems here. When the game terminates like that without a game error this usually suggests something has gone wrong Windows-side. Often this relates to issues with the graphics drivers, or the configuration the game is attempting to run at on your hardware. The first thing to check is whether your graphics drivers are up-to-date and that you have any associated Windows updates installed. The next thing to look at is your hardware_settings file. I'd recommend deleting this file and launching the game again as it has be known for this file to become corrupt. Deleting this file forces the game to create a new hardware_settings file using default settings taken from your current Windows settings. If this doesn't solve your problem then please send through your dxdiag and hardware_settings file and we'll take a further look. 

Info on where to find these files and where to send them are contained in this post.

Thanks.
Thanks. I have hardware_settings_info and hardware_settings_config, what should I delete?
Config but renaming them will do.

You should look at motherboard updates also.


Tried it this morning. Still getting the same issue. So I have sent the crash dump file to codemasters email. Everything is upto date and game is ok on directx11.

Share this post


Link to post
Share on other sites
@Savajay - it's the hardware_settings_config.xml file that you need to delete (or rename if you want to keep it around just in case).

Share this post


Link to post
Share on other sites
When I installed the dx12 version it killed vsync on both the dx11 and dx12 versions. Had to uninstall and reinstall it so I could actually play it as the frame rate limiter still causes tearing. I8 8700k, 32gb ddr4 3ghz ram, 1080ti. Running 4k ultra over HDMI to 4k Samsung tv

Share this post


Link to post
Share on other sites
Savajay said:

Tried it this morning. Still getting the same issue. So I have sent the crash dump file to codemasters email. Everything is upto date and game is ok on directx11.
Hi @Savajay. We've received the crash dump and it looks like an issue we've not seen before. Would you be able to send us your DX Diag and hardware_settings_config file too as this will help us test the issue more effectively? Many thanks, Hoo.

Share this post


Link to post
Share on other sites
Guest
Telemetry by UDP does not work.
I obtained more fps and lower temperature but I need telemetry by UDP.

Share this post


Link to post
Share on other sites
Ho3n3r said:
I'd be curious to see how a build without Denuvo runs, regardless of the DirectX version. I'm not saying it's the cause, but as a developer it's something I would at least test out of curiosity. These stutters have a cause, and other games have reported issues with Denuvo, so it's a worthy stab in the dark IMO.
As far as I know, the perfomance difference was minimal between the two versions of F1 2017 at least.

Share this post


Link to post
Share on other sites
Telemetry by UDP does not work.
I obtained more fps and lower temperature but I need telemetry by UDP.
Telemetry by UDP does work for me on DX12 beta.

I can get it on Race Dash 3.3.3 and F1 Dash (Beta) 1.2.2 on iOS12.1 so it looks like an app issue rather than a game issue.

I use static IP for the telemetry, not broadcast and update at 20kHz in the F1 2018 mode rather than F1 2017 (legacy) mode.

Share this post


Link to post
Share on other sites
The beta loads 1.14 in DX12 not 1.15 so the update is incompatible with saves.

Thought it was just differences in the .exe and / or the wrapper?

Or is build 3329358 imminent?

Share this post


Link to post
Share on other sites
so these version of the game will receive a public stable release of dx12? or is just beta to introduce only in f1 2019?

Share this post


Link to post
Share on other sites
@steviejay69 - sorry, the DX12 version 1.15 isn't quite ready to go yet. We'll be moving onto that shortly.

Share this post


Link to post
Share on other sites
squalles said:
so these version of the game will receive a public stable release of dx12? or is just beta to introduce only in f1 2019?
They are working on fixing bugs in DX12 but I think DX11 will be supported through 2020 or they will lose the W7/8/Vista players. 

Finally looks like the drawbridge to 32-bit is being lifted too :smile:


Share this post


Link to post
Share on other sites
Stutter AMD dual GPU graphics cards. I know (Crossfire support is not yet implemented)
Tested drivers 18.12.1 Adrenalin drivers.

AMD CPU TR 1920 & Radeon Pro Duo stutters or performance is very poor.
CPU Intel 4790K & Radeon 295X2 and also (2x295X2 Quadfire) very poor performance.
CPU Intel 4790K & Radeon Nano - Seems to work just fine (Single GPU) :)

Great to see that DX12 finally start coming games. Or even beta testing for games.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×