Jump to content
  • 0
Sign in to follow this  

Thrustmaster Ferrarie F1 Add-on advanced mode drives like a pad - F1 2018 PC

Question

Guest
Hi everybody 

i posted this on the wrong category, but i dont know how to move it. So i open up a new discussion.
Sorry for that. :(

Here is my old post.
I saw the the problem which some people had with there T300 Wheel. Topic was: "T300 DRIVES LIKE A PAD F1 2018 (PC)"
https://forums.codemasters.com/discussion/136995/t300-drives-like-a-pad-f1-2018-pc/p1 

I have a similar issue and i already read about this in different forums. The problem is easy to explain. I have a thrustmaster TS-PC Base and the Ferrarie F1 Add-on wheel. 
In the Thrustmaster-Profiler on a PC you can choose between two different Profiles, "Advanced Mode" and "Normal Mode". The differents are the amount of button you can use in each mode. 13 Buttons on normal and 23 on advanced.
https://preview.ibb.co/khLpNA/1.jpg 

Unforunalety if i put my wheel in to advanced mode, the game doesn't recognized it as a known controller. I still can set all the buttons and axes but as soon as i go on track i realized the wheel drives like a controller and not like a wheel. The problem is exactliy like in the topic i mentioned above. 

And when you look in to the installationfolder under "..\F1 2018\actionmaps\" you can find the buttonmappings for some thrustmaster bases combiend with the f1 wheel in advanced mode. 
https://preview.ibb.co/j8bUNA/2.jpg 

So it should work. Can some confirm this issue?

The game offers so many buttons to map and with the only F1 Wheel from Thrustmaster you can only use 13 instead of 23

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
It does work. I have the exact same stuff that you do.

Download the lastest driver and firmware 2018_TTRS_3 

Uninstall the current drivers with Geek Uninstaller

Verify your F1 2018 game files on Steam

Install the drivers, restart and check for correct operation in Thrustmaster CP.

Delete the hardware_settings_config.xml in My Documents\My Games\F1 2018

Launch the game then set up a clean profile in the game settings.

Share this post


Link to post
Share on other sites
  • 0
Guest
It does work. I have the exact same stuff that you do.

Download the lastest driver and firmware 2018_TTRS_3 

Uninstall the current drivers with Geek Uninstaller

Verify your F1 2018 game files on Steam

Install the drivers, restart and check for correct operation in Thrustmaster CP.

Delete the hardware_settings_config.xml in My Documents\My Games\F1 2018

Launch the game then set up a clean profile in the game settings.

Hi and thank you very much for your Response but unfortunately it didn't help. 

I tried this befor and i also made fresh OS install once. It stays the same. But tried it again and I did everything you wrote. When i start the game, Uknown device information appears on the screen. And As you can see in my pictures, I had all the new drivers and the latest firmware.

Are you 100% sure your wheel is recognized as a wheel? Whats the name of the preset controller in the game option? If it is recognized than you should see a preset schemata. In my option there is only Keyboard, T8 Shifter and my Fanatec pedals. 

If you drive of the track does the virtual wheel in the game shake or move a lot?

I can not belive it is driver related. Because if i set it back to normal mode everything works great.

Share this post


Link to post
Share on other sites
  • 0
daSh84 said:
It does work. I have the exact same stuff that you do.

Download the lastest driver and firmware 2018_TTRS_3 

Uninstall the current drivers with Geek Uninstaller

Verify your F1 2018 game files on Steam

Install the drivers, restart and check for correct operation in Thrustmaster CP.

Delete the hardware_settings_config.xml in My Documents\My Games\F1 2018

Launch the game then set up a clean profile in the game settings.

Hi and thank you very much for your Response but unfortunately it didn't help. 

I tried this befor and i also made fresh OS install once. It stays the same. But tried it again and I did everything you wrote. When i start the game, Uknown device information appears on the screen. And As you can see in my pictures, I had all the new drivers and the latest firmware.

Are you 100% sure your wheel is recognized as a wheel? Whats the name of the preset controller in the game option? If it is recognized than you should see a preset schemata. In my option there is only Keyboard, T8 Shifter and my Fanatec pedals. 

If you drive of the track does the virtual wheel in the game shake or move a lot?

I can not belive it is driver related. Because if i set it back to normal mode everything works great.
Try it without the shifter.

Share this post


Link to post
Share on other sites
  • 0
Guest
Nothing changed. :(

Also nothing with just the keyboard plugged in.

Share this post


Link to post
Share on other sites
  • 0

In normal mode, the wheel is recognised as 'Thrustmaster T300RS Racing Wheel (USB)'

In advanced mode, the wheel is recognised as 'Ferrari F1 Wheel Advanced T300 (USB)'

This is both in Device Manager and Thrustmaster Control Panel.

In-game preset schema is 'Thrustmaster F1'. I have created a modified schema for the wheel as I have remapped some buttons to match the wheel label to the correct control and some for convenience.

I have Logitech pedals but they are plugged into the wheelbase, not via USB. I use a DB9 to RJ-12 passive adapter. As well as the shifter, I would remove the pedals also. Plug in your T300 pedals to test.

Final suggestion is to disable Steam Cloud sync for the game as control schemas are saved. I am currently running without Steam Cloud sync but it also worked fine with Steam Cloud sync up until I disabled it.


Share this post


Link to post
Share on other sites
  • 0
Guest

In normal mode, the wheel is recognised as 'Thrustmaster T300RS Racing Wheel (USB)'

In advanced mode, the wheel is recognised as 'Ferrari F1 Wheel Advanced T300 (USB)'

This is both in Device Manager and Thrustmaster Control Panel.

In-game preset schema is 'Thrustmaster F1'. I have created a modified schema for the wheel as I have remapped some buttons to match the wheel label to the correct control and some for convenience.

I have Logitech pedals but they are plugged into the wheelbase, not via USB. I use a DB9 to RJ-12 passive adapter. As well as the shifter, I would remove the pedals also. Plug in your T300 pedals to test.

Final suggestion is to disable Steam Cloud sync for the game as control schemas are saved. I am currently running without Steam Cloud sync but it also worked fine with Steam Cloud sync up until I disabled it.


Ok. But i have the Thrustmaster TS-PC Base. I just mentioned an older discussion about the TS300 which had the similar issue. Maybe the game still have issues with this base.

But thank you for your help. ?

Share this post


Link to post
Share on other sites
  • 0
daSh84 said:

In normal mode, the wheel is recognised as 'Thrustmaster T300RS Racing Wheel (USB)'

In advanced mode, the wheel is recognised as 'Ferrari F1 Wheel Advanced T300 (USB)'

This is both in Device Manager and Thrustmaster Control Panel.

In-game preset schema is 'Thrustmaster F1'. I have created a modified schema for the wheel as I have remapped some buttons to match the wheel label to the correct control and some for convenience.

I have Logitech pedals but they are plugged into the wheelbase, not via USB. I use a DB9 to RJ-12 passive adapter. As well as the shifter, I would remove the pedals also. Plug in your T300 pedals to test.

Final suggestion is to disable Steam Cloud sync for the game as control schemas are saved. I am currently running without Steam Cloud sync but it also worked fine with Steam Cloud sync up until I disabled it.


Ok. But i have the Thrustmaster TS-PC Base. I just mentioned an older discussion about the TS300 which had the similar issue. Maybe the game still have issues with this base.

But thank you for your help. ?
2018_TTRS_3 has new firmware for the TS-PC base (v9) make sure it is applied.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×