Jump to content
  • 0
Sign in to follow this  

F1 2018 keeps crashing with same error message on brand new top of the line gaming PC

Question

Hey everyone,

I just purchased a new gaming PC from NZXT with an GEFORCE 2080 GPU and I have F1 2018 optimized in the GEFORCE experience app.   The game has crashed multiple times with the following error message:  "The D3D device has been removed.  Try updating your drivers or change graphic texture settings."  

Needless to say all my drivers are up to date and Battlefront V and other games are running smoothly.  Any thoughts?    

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
It seems you are not alone, there might be some help in this thread.
https://forums.codemasters.com/discussion/140911/when-will-the-famous-d3d-has-been-removed-error-finally-be-resolved#latest

Share this post


Link to post
Share on other sites
  • 0
So I just went through trouble shooting with NVIDIA and they think it is an issue with the game and they told me to contact Codemasters directly.  Is anyone else with a brand new 2080 GEFORCE GPU getting this "The D3D device has been removed.  Try updating your drivers or change graphic texture settings"   error message?  

My computer is brand new from NZXT and has the following specs: 

CPU - Intel Core i7-8700K 6-Core 3.7 GHz
MOTHERBOARD - ASUS ROG Maximus XI Hero (Wi-Fi AC)
 GPU(GRAPHICS) - ZOTAC GAMING GEFORCE RTX™ 2080 AMP
POWER SUPPLY - NZXT E850 Gold Digital PSU
 RAM - G.SKILL TridentZ RGB 16GB (2 x 8GB) 3200 MHz

Is there a technical support number for Codemasters?  All of my other games are running smoothly so I believe it is game specific.

Share this post


Link to post
Share on other sites
  • 0
JoshuaKM1 said:
So I just went through trouble shooting with NVIDIA and they think it is an issue with the game and they told me to contact Codemasters directly.  Is anyone else with a brand new 2080 GEFORCE GPU getting this "The D3D device has been removed.  Try updating your drivers or change graphic texture settings"   error message?  

My computer is brand new from NZXT and has the following specs: 

CPU - Intel Core i7-8700K 6-Core 3.7 GHz
MOTHERBOARD - ASUS ROG Maximus XI Hero (Wi-Fi AC)
 GPU(GRAPHICS) - ZOTAC GAMING GEFORCE RTX™ 2080 AMP
POWER SUPPLY - NZXT E850 Gold Digital PSU
 RAM - G.SKILL TridentZ RGB 16GB (2 x 8GB) 3200 MHz

Is there a technical support number for Codemasters?  All of my other games are running smoothly so I believe it is game specific.
Try this https://support.allegorithmic.com/documentation/spdoc/gpu-drivers-crash-with-long-computations-128745489.html
Revert to normal if no improvement. 
BIB -   :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×