Jump to content

Huge rhythmic stutter on high end PC

Recommended Posts

Just started playing on Steam and immediately ran into an issue. First, PC specs:

9900k

2080 Ti 418.91 drivers

16gb RAM

Windows 10 Pro x64

The issue is a large, rhythmic frame drop/stutter every 2 seconds. Settings don't matter; I tried low everything with a VERY high frame rate, but the stutter is still there like clockwork. Tried reboot, verifying the game's cache with Steam, changing all the settings, trying Vsync on/off, windowed/fullscreen, etc. Something weird is going on here.

Share this post


Link to post
Share on other sites

tried disabling overlays?

Check to ensure theres no popups or other program thats from the task bar thats causing dialogue boxes to tooltips from popping up.

Share this post


Link to post
Share on other sites
8 minutes ago, LittleApple said:

tried disabling overlays?

Check to ensure theres no popups or other program thats from the task bar thats causing dialogue boxes to tooltips from popping up.

Yeah, no overlays running or any extraneous services at all, for that matter. Tried turned off fullscreen optimizations on the .exe as well, no change.

I have a feeling this is going to turn out to be an issue with 8 cores + hyperthreading tripping up the game process somehow (16 logical cores) but obviously I'm just guessing here. I doubt many people have played this on a 9900k yet, even among Codies themselves.

Share this post


Link to post
Share on other sites

OK, I believe I've figured out what's causing it... I tried unplugging all of my peripherals, then plugging them in one by one and testing DR2. My Logitech G27, of all things, is causing it. No idea WHY though. I've been using it for years without issue, even right now with DR1 with zero issues.

Share this post


Link to post
Share on other sites
29 minutes ago, ShodanCat said:

OK, I believe I've figured out what's causing it... I tried unplugging all of my peripherals, then plugging them in one by one and testing DR2. My Logitech G27, of all things, is causing it. No idea WHY though. I've been using it for years without issue, even right now with DR1 with zero issues.

Try to install the logitech driver again. Could be a "misreading" if that makes sense

Share this post


Link to post
Share on other sites

I'm having the same problem, this stutter / frame drop every few seconds (2-3) is immense annoying. Using Fanatec and not Logitech. It seems to be a problem how CM is reading the HID devices. This has to be solved. There is a long discussion on Steam forum to try to break this down.

I have found a lot of discussions also to Dirt 4, where this problem seems never solved.

The list of real problems is unfortunately rising, FFB, career reset, stuttering ...

Share this post


Link to post
Share on other sites

This is also happening to me.  I can tie it back to my thrustmaster t300. This doesn't happen with dirt rally 1, or F12018.  Doesnt matter what USB i use, or what else is plugged in.  The second I unplug the wheel the game is smooth.  I can even see the stutter on the menu screens. Has to be a game bug. Also tried Forza Horizon 4 and Forza 7.  This is definitely related to the game.

My rig.

2080 ti
8700k
32gb ram
win10
Samsung NVME HD

Edited by retrojonezin

Share this post


Link to post
Share on other sites
3 hours ago, Peter Mathen said:

I'm having the same problem, this stutter / frame drop every few seconds (2-3) is immense annoying. Using Fanatec and not Logitech. It seems to be a problem how CM is reading the HID devices. This has to be solved. There is a long discussion on Steam forum to try to break this down.

As mentioned in the G27 stutter thread I made some more tests and found:

Started DR 2 with all my devices plugged in -> stutter -> unplugged my F16 button box while DR 2 is running -> stutter gone
Stopped DR 2 and started it again (F16 still unplugged) -> stutter -> unplugged next device my H-shifter -> stutter gone

The same with MSI Afterburner running or not, Steam overlay activated or not.

So I think it's not connected to a special device or driver as some people are saying, also not connected to MSI afterburner, RTSS or Steam overlay. From my view it's more connected how CM is reading the HID devices.

Share this post


Link to post
Share on other sites

Regardless of anything mentioned, there should never be a scenario where a game is this picky about a USB device.  If I remember correctly Dirt Rally 1 had the same issues and it was fixed in a patch.  Hopefully the same will happen here.  The unfortunate part is not being able to play 2.0 with anything but a controller. 

Share this post


Link to post
Share on other sites

Is this going to be patched, DR1 did this with a wheel plugged in an it was eventually fixed.   Not on DR 2.0 every couple seconds I stutter and drop about 10 FPS, unplug my wheel and everything is good.  I am not going start disabling USB inputs, that seems ridiculous. 

  • Agree 2

Share this post


Link to post
Share on other sites
Posted (edited)

I'll wait till I get around to taking some video, but I think this might be happening to me too, on occasion. it only happens in a race, so if I quit to the menu and go back to the stage it's usually gone but it's relatively distracting

specs:

i7 8th gen 2.20GHz

16GB ram

1050ti 4GB

crucially, this is a laptop. I play DR 2.0 on a keyboard. so the issue cannot be caused by my peripherals because I don't have any, unless you count a wireless mouse...

so yeah, I don't know if this is the same exact problem you guys are having, but it sure looks similar.

EDIT: it's only been happening since the 1.21 or 1.3 patch

Edited by ianism

Share this post


Link to post
Share on other sites
Posted (edited)

Posted March 3

Any news on the HID problems? 

Just to remind at the rhythmic stutter bug.

To make it clear, that's a HID reading problem, here an Afterburner picture where you can see the rhythmic stutter (only sitting at the starting line) and then after a while I unplugged a device (where the larger frame drop is) and you can clearly see after that the stutter is completely gone. Even driving the stage after a while (where the graph of the GPU workload is starting to move) no frame drop at all.

DR2_framedrops_2.jpg

Edited by Peter Mathen

Share this post


Link to post
Share on other sites

Switch the frame rate counter off you won't even notice it!

Share this post


Link to post
Share on other sites
35 minutes ago, Dominic0 said:

Switch the frame rate counter off you won't even notice it!

Umm, erratic frame pacing (even just 5ms here and there) is noticeable to most people. These stutters are probably in excess of 50ms or even 100ms, it renders the game almost unplayable.

Share this post


Link to post
Share on other sites
Posted (edited)

I've got this issue big time on 1080ti and i78700k. It happens at the end of ALL STAGES 😡 The game almost crashes at the end of all stages and goes into "not responding" state for about 20 seconds!!!

Edited by lucag120

Share this post


Link to post
Share on other sites

iv given up waiting for a fix on this, i STILL cant use ALL of my USB controller devices because of the USB polling issue, iv a handbrake and gearbox that are pluggd in briefly to stop the stutter, then have to be removed to prevent the stutter returning...... EVERY F*****G TIME I START IT UP!

 

frankly, not good enough CM, iv been one of your biggest supporters on this game, buy youve p*55*d on me mr chips now

 

MM

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, lucag120 said:

I've got this issue big time on 1080ti and i78700k. It happens at the end of ALL STAGES 😡 The game almost crashes at the end of all stages and goes into "not responding" state for about 20 seconds!!!

That sounds like a completely different issue. The one people are talking about in this thread is a constant rhythmic stutter that happens at all times during the game, even sitting in the menus.

Edited by ShodanCat

Share this post


Link to post
Share on other sites
On 5/19/2019 at 12:47 AM, Dominic0 said:

Switch the frame rate counter off you won't even notice it!

Wrong, the stutter in frame pacing drops 2-5 frames and that's very annoying.

Share this post


Link to post
Share on other sites

I'm really ****** about this issue. Currently I'm facing this issue every day. I do no want to go disable USB devices, the're needed.

 

  • Agree 1

Share this post


Link to post
Share on other sites

Yeah, this has stopped me playing it. Disabling USB devices does fix the issue, but I CBF'd doing that each time.

  • Agree 1

Share this post


Link to post
Share on other sites

So what's going on?

Just tried DR2 and the same problems as before, now with V 1.4.1 nothing changed.

Stutter every few seconds, it's like the pictures freezes a short time and then jumps a few frames. This way it's no fun to play. 

DR2_framedrops_3.jpg.7c7db66701ce51937312bce81fc8e02a.jpg

 

Also the long list of other bugs even the smallest bugs as REV light on Fanatec wheels going the wrong direction are not fixed.

 

Share this post


Link to post
Share on other sites

The rhythmic stutter is best documented in the Frametime graph. This is using driver 378.92,

which is the driver that gives the least stutter. It is sometimes better after a restart, but comes

back after a while and eventually the game will hang. Unless I CTRL+ALT+DEL within 10 seconds

or so, my whole PC will hang and I have to force close it. I have tried all drivers, 3 different GFX

cards (2 EVGA 1080 FTW and GIGABYTE GTX 1080Ti), 2 different MB (ASUS x99 Deluxe and Deluxe II) 

I have bought a 3rd MB (ASUS ROG RAMPAGE V EDITION 10), but have not tried it yet, because I

want to see if the new update 1.5 improves on anything first.

 

Codemasters have been acting worse than I would expect from any dev. in relation to this problem,

and is a complete disgrace. So far I have wasted more than $1200 trying to find hardware that is

circumventing these BUGs.  Codemasters could at least have tried to communicate some statistics

and work with us to try to get to the bottom of this problem, but unfortunately, they don't care... 

Since they asked us to send DxDiag to Support back in february, I have heard NOTHING.

 

Turning OFF all USB does not change anything for me, and using other drivers than 387.92, makes

the game totally unplayable. Picture below is with driver 378.92. Frametimes spikes every 10 seconds

and there are normally more large spikes in a stage than here. The long line at the end is when the 

game is windowed in the menu, and inactive. Activating it will trigger the Frametimes seen in the

beginning, before I start the stage. The picture is from February 24., but nothing have changed...

978476120_DR2StutterBUG-HighandfluctuatingFrametime-Afterburner-GTX1080TIExtreme-Driver378.92-419.17ismuchworsecannotevendrive.thumb.PNG.09265a34afb92a18f99bc9cb0637a12a.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×