Jump to content

DiRT Rally 2.0 - V1.1 - found a bug? Post it here!

Recommended Posts

The simple fact is I won’t buy any more Codemasters games. The games are good but there are always a multitude of issues plaguing them. I’ve not touched Dirt Rally 2 in 10 days as there is no point until the FFB is fixed. Back to Assetto Corsa Competizione, which despite only in early access and a few cars has brilliant FFB and is a great drive.

  • Like 1
  • Agree 4

Share this post


Link to post
Share on other sites
15 hours ago, bbbwww said:

so @xtinamcgrath does that mean

a) the next patch - coming soon - will not include any FFB changes
OR
b) the patch will come a little later because FFB issues take a little more time

Just repeating this question @xtinamcgrath as it might have slipped under the radar

Just a quick answer a) or b) would be nice to understand CM's decision (both are fine). Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

I had a bit of a weird bug... PS4, career mode.

I had to restart a stage (Please don't judge... the missus distracted me with a pie) and upon restarting the car started driving itself.

Even more irritatingly, the self driving car was very very very slow... not that I would have kept the stage time if it had been fast, you understand.... I have morals! I digress.

I had to come out of the game to get back to driving myself.

Amazingly I have had a spate of good luck so I have only had to restart just the one time after this incident and the issue did not repeat itself, but obviously I cannot say whether this issue was just a one off or not due to the small sample size of restarts. No doubt I will chuck the car into the scenery again at some point in the near future (especially if the missus distracts me with that pie again- good Lord it was delicious) so I will keep you posted should it happen again.

Cheers,

Share this post


Link to post
Share on other sites

I don't want the Split Times displayed on screen while driving.

 

To turn those OFF, I have to turn OFF Timing in OSD Settings. 

Problem is that this also turns OFF the warning if you jump-start. 

So you'll drive the whole stage only to discover that you got a

10 second penalty. :P 

 

AND

 

The Start Lights does not stay on when jump-starting. This makes

the first problem even worse. They are also too weak. The green

color on the "Start-boxes" are a lot stronger than the light. 

 

 

When recording Replay, I use the steering wheel to adjust the start

position to just before the Start Lights go out. Often, the light will 

stay ON after I start recording, as if I jump-started. 

 

 

I would also like to have the live Split Times OFF without turning off

the Timer. Adding Split Times to Replay would be much more preferable

for me.

 

Cheers :)

Share this post


Link to post
Share on other sites

Hi, I'm having a problem where when I'm driving a car through a wet stage and go through some water there is no water droplets or mud that go on my windshield rendering the windshield wipers useless unless it's raining. It worked when I first pre-ordered the game so I'm thinking the day one patch may have caused the problem.  Thanks. @ChristinaMc

Share this post


Link to post
Share on other sites
11 hours ago, Eagleizer said:

Te Awanga Sprint Forward Dry: 

Pug 205. Times are mostly wrong. 

 

- After finish it says my Personal best time is 03:00:442 (wrong). This time is not changing.

- World record (my time) is 03:01.550, which it says on the Leaderboard is the only correct time.

- At Start it says Personal best: 3:00.441 (The time displayed at Start Gate is always wrong, not only this car and stage). 

It is usually 0.001 second wrong, but I have seen 0.005 on longer stages in NZ.

- When I drive, the 3rd Split time is 17+ seconds in Green, but I still don't beat my old time,

despite driving fast the last sector.  My WR run clocked 45.897 seconds in sector 4, but it says

my Personal best is 26.066 seconds in that sector!! That's about 26 seconds difference...

- And this is totally missing from results: Previous Best 

 

This problem was there all through driving from 20th place or so and until 1st.

792187272_DR2-BUGintimesforPug205-TeAwangaSprintForwardDry-WrongPersonalBest-MissingPreviousBest.PNG.8cdb7ffb0551bb5c04847a882159e87e.PNG

1857926195_DR2-BUGintimesforPug205-TeAwangaSprintForwardDry-LeaderboardisCorrect-NoBUGherre.PNG.acf8e71095096e2c8df2e9446334515e.PNG

1636813953_DR2-BUGintimesforPug205-TeAwangaSprintForwardDry-WrongPersonalBest4thSplittime-MissingPreviousBest.PNG.97763428a23c73cbbccf7863b1f296ee.PNG

1957073858_DR2-BUGintimesforPug205-TeAwangaSprintForwardDry-WrongPersonalBestatStartgate.PNG.12dd707352fc22354de7d2d56b9bdec3.PNG

 

 

I managed to beat that wrong time, so now things looks a bit different. 

I looked a bit more into the different times, and here is what I have discovered: 

 

The Total time, that also ends up in the Leaderboard is either measured from

Start to Finish, or it's calculated wrong. When adding Split Times, the Total Time

is always faster. Could this be because there are some hidden decimals, and in

if so,  are they always rounded Down?

 

As far as I can tell by calculating some of the earlier screenshots I have, the 

"Personal Best" displayed at Start Gate, is the Split times added together.  

 

In any case, either the time on the Leaderboard and Time Trial Results, or the

time at the Start Gate, needs to be calculated from the same source as the other.  

 

Cheers :)

828768002_DR2BUG-WrongTimesStageTotal-ResultswhenaddingSplitTimes.thumb.PNG.03b47758887da7594fbc1669487242a5.PNG

349675170_DR2BUG-WrongTimesSplitTotal-ResultswhenaddingSplitTimes.thumb.PNG.3c0be4b599ba8b1caed5567b6f832d5a.PNG

387861797_DR2BUG-WrongTimesLeaderboard-ResultswhenaddingSplitTimes.thumb.PNG.5e00c0be5e2f66535ca8e95ac22620bd.PNG

1613149962_DR2BUG-WrongTimesStartGate-ResultswhenaddingSplitTimes.PNG.8d52fab015fc97f10d8b46ca858283cd.PNG

Share this post


Link to post
Share on other sites

Somehow I got two of the same rallies in a single elite career season (PC):

RnDz0zg.jpg

 

Share this post


Link to post
Share on other sites

Dip and bad camber/camber calls are missing a lot.

Option miss a as the car as transmission setting. I mean if you are in a sequential car, I should have to go back to setting to put it in sequential instead of h pattern with clutch

Trois rivieres is in canada. There is an usa flag on top of the main building... I live actually live in trois rivieres, that's why it bothers me haha.

Online only is a real issue... It doesn't need it...

Live wheel position indicator should be in the same page as the wheel deadzone setting so we can adjust while being happier haha.

 

Share this post


Link to post
Share on other sites

When not using any ui ( for more realistic hardcore experience) it would be nice to still have a place to see the start light somewhere in rallycross

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: I only get this when having Tree settings at the lowest.

 

 

I have this BUG everywhere, even on cars in Replay. The grid pattern is moving with the

camera, so if you put your finger on the pattern on your screen, it will point at the same

dot when camera is panning. or in another way, it is static in relation to the screen. It is

incredibly distracting in some places and it is absolutely everywhere. Since it's moving

with the cam, it makes this strange animated effect around things, like shimmering or

something, in particular on distant bushes and trees. The size of the dots are 4 pixels 

on my screens which are 2560x1440. 

 

1251142809_DR2-GraphicsProblem-BUG-Blackdotspattern.jpg.a6724f382e6a50ce1e3f3014d83527cd.jpg

259545626_DR2-GraphicsProblem-BUG-Blackdotspattern-003.PNG.2770a5021127055f913ff3c4ff0011ae.PNG1391839768_DR2-GraphicsProblem-BUG-Blackdotspattern-005.thumb.PNG.47a19b8917ad3fc0bead6202ce03803a.PNG2035798265_DR2-GraphicsProblem-BUG-Blackdotspattern-004.thumb.PNG.ef26faac6b4eedee480f39f2856302af.PNG370423585_DR2-GraphicsProblem-BUG-Blackdotspattern.thumb.PNG.671eebd747f129337080c6c535d70b6f.PNG

1100719465_DR2-GraphicsProblem-BUG-Blackdotspattern-008-FromvideoPug.thumb.PNG.5afeb74b9fc7c6580e2668eb3885449f.PNG960109021_DR2-GraphicsProblem-BUG-Blackdotspattern-006.thumb.PNG.ea57a9a8984409605c2bb9a1da53ef16.PNG

 

 

Edited by Eagleizer
Update

Share this post


Link to post
Share on other sites

Hi, my DSD Type 2 Hydraulic Handbrake doesn't work. On dirt rally it's perfect but from dirt 4 it doesn't work. Please help me!! Thank you in advance, FA.

Share this post


Link to post
Share on other sites

 Sorry Will come out more patches then ?? one that will solve the ffb and maybe even before solving graphics problems or bugs:classic_huh:

Share this post


Link to post
Share on other sites

a few minutes ago while I was about to start the stage "bondi forest" "Australia" in my team and appeared the error attached. play with normal ps4.

IMG_20190308_180808.jpg

Share this post


Link to post
Share on other sites

Just did an custom New Zealand rally with R5 cars. Was awesome.

Also tried an RX online event again. At Mettet. Man that is bugged all the way.
- AI is broke as hell online. Solberg was 2 seconds faster than me, while Kristofferson was 2 seconds slower than me. Sometimes de AI decide go very fast, and the next turn be like my grandma and apperently forgot how to drive. 
- Some AI is ghost all race. Like they finished immediately. 
- Some AI finish race, but not show any lap times
- Some AI have a lap of about 4 second
- Looks like if someone jump start in an other race, my race also immediately starts green. pretty annoying. 
- Waiting 120 second is much to long. A simple event that should take more time to wait than actually racing. Make that maximum 60 seconds. Now 120 seconds wait before the event. maybe 120 second wait after the race. than load again, etc. 
- If lap a car, the lapped car might be or might not be a ghost. One time a newb crashed in the fast chicane in front of me. I was going to lap him, but he not was a ghost. I crashed and got terminal damage. That newb just could carry on.

Overall conclusion RX custom event online: Full with bugs, makes no sense, feels like it not has been tested at all. It's not join and have fun. It's join and wait and frustrate atm.

Share this post


Link to post
Share on other sites
Posted (edited)

In preferences (PC version):

Changing "Camera Shake" to completely "No Shake" doesn't seem to have an effect.
Changing "Co Driver Calls" to earliest                      doesn't seem to have an effect.

With "Camera Shake" my 100 fps(frames per seconds) seem/feel like 30 fps.

 

Edit: Changing "Co Driver Calls" to completely "Later" makes the co-driver to call calls earliest. 
This Problem/Bug kind of solved. Hehe.

Edit2: Sorry, misinterpreted co-driver calls semantic; there is no bug.


Greetz

Edited by MBastieK
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

The sound bug finally happened to me. Everything went mute except the gravel. It happened while driving the 208 R5 in NZ on a custom champ. shakedown.

Edited by Riggs

Share this post


Link to post
Share on other sites
Posted (edited)

The Elite career AI needs some serious adjustment. The AI times are quicker than the world records, Poland is the biggest culprit. On the daily’s i am top 100 every time, normally higher yet i lost the group A Poland Elite championship by about 5 minutes lol (in a fully upgraded evo).  

 

surprised that wasn't picked up in the testing/quality control.

 

i know this issue has been raised before but not sure if codies /christina have acknowledged it at all, really don’t want it getting missed. Would be useful for the first post in this thread to be adjusted to include the bugs that have been raised and more importantly, which ones have at least been noted by Codies.

Edited by Pieman99
  • Agree 2

Share this post


Link to post
Share on other sites
Posted (edited)

Xbox - Digital Deluxe Version.

 

Game dashboards me during gameplay every so often asking me if I `own this game - see in store`.

I have to wait a while to get back into the game (still running in the background). Once back in the game it's on pause, but it paused itself 5-10 secs after dashboard happened. Normally results in car in a tree, or through a fence etc.

Occurs maybe once every hour of gameplay.

 

Never had the happen with any other digital games, so I'll thought I'll post it here. 

 

Also have had the sound cutting out bug every now and then.

Edited by Dscru

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/6/2019 at 7:54 PM, ChristinaMc said:

Hi all,

Thanks for all of your feedback so far. Just to let you know, we're working on a patch to address some of the most pressing issues that have been raised here. As soon as I have notes on confirmed fixes, I'll share them with you ASAP.

We're also looking into FFB as a priority, as we're aware a lot of you have raised concerns about how this feels. However, we just want to make clear that there is no easy fix for this; anything we change will affect all vehicles, surfaces and peripherals, so we have to be very thorough to ensure any changes we make will be positive across the board.

Cheers,

Christina

 

The FFB problem is just simple.

The vibrations in this game are not working.

Edited by Buddyspike
  • Agree 2
  • Disagree 1

Share this post


Link to post
Share on other sites

Not sure if it has been mentioned here but..

Championship running order is busted. At the moment, the championship leader runs last on day 1. Rally leader runs last on days 2 and 3. 

 

If you're last in the rally, you sweep the road, which is silly.

If you could ensure championship leader runs first on day 1, and maybe flip just the top 10 or top 15 for subsequent days, I think that would make for the best, and most varied experience for users to show off degradation properly.

  • Agree 2

Share this post


Link to post
Share on other sites

PC v1.1

  1. AI times seem unaffected by very low visibility conditions (night + heavy rain).
  2. AI times in career rallycross championship are not consistent from track to track - on certain tracks, even if I win all of qualifiers, I still don't make it to the semi-finals, and on others I can win the whole event easily.
  3. Some cars have lower quality interior textures, when compared to others, on the same graphics settings.
  4. Some cars are missing driver's and co-driver's names on their back side windows, and some feature real driver names, like "Atkinson", instead of your own, in career mode:

dgcLoZH.jpg

 

 

Share this post


Link to post
Share on other sites

A few minutes ago while I was running the daily plus RX, the game got stuck. I made a video (I attach it) after I restarted the application and of course the D + was no longer accessible due to withdrawal from me (I attach the photo). I can not wait for the 12 March so along with the dlc we will have the corrections at least for the instability that we are experiencing a bit all.😅. (Normal playstation4)

 

IMG_20190309_164630.jpg

Share this post


Link to post
Share on other sites

On PS4 you don't see your results when comparing your time with friends on leaderboards during dailies/weeklies. Other people can see your time, but you can't, even your PSN id doesn't show up on the list. It doesn't affect global leaderboards, those seem fine, just the friends' leaderboards. Checked with 2 people, same thing. 

Share this post


Link to post
Share on other sites
45 minutes ago, MCasu said:

A few minutes ago while I was running the daily plus RX, the game got stuck. I made a video (I attach it) after I restarted the application and of course the D + was no longer accessible due to withdrawal from me (I attach the photo). I can not wait for the 12 March so along with the dlc we will have the corrections at least for the instability that we are experiencing a bit all.😅. (Normal playstation4)

 

IMG_20190309_164630.jpg

are you on pc, overclocked gpu maybe?   i was having a pretty stable overclock and played games like metro exodus,but then i discovered gpu ram clock was too high for dr 2.0.   turned it 100mhz down,

no crashes so far 🙂

Share this post


Link to post
Share on other sites
Posted (edited)

So I guess if the AI wins the first event it gives them 60pts for a win  DOUBLE POINTS for every AI driver now? Is there like a hidden powestage in there or something we don't know about?

 

7F47C907D9B7EF8D9B32BF18AE24049BCF4D0603

Edited by CatBadders

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×