Jump to content
  • 1

Dirt Rally 2.0 RGB range (PC)

Question

I experience problems with full RGB range enabled. Dark areas are way too dark, and some of the bright areas are way too bright. The brightness control inside the game doesn't look right either, as the leftmost Dirt-logo is invisible.

When setting either the graphics card or screen (or both) to limited RGB range, everything looks correct, although with less contrast.

Anyone else experiencing this?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1

Go to your my documents folder
Go into saved games/my games folder
Find dirt rally 2.0 folder
go into hardwaresettings

with notepad or other text editor, open up hardware_settings_config.xml

Find and then replace this value:
<hdr level="1.0" />
with 
<hdr level="0.1" />

Share this post


Link to post
Share on other sites
  • 0

Not having the same issue at all, my pc is always set to 10 bit full range rgb even for SDR content(I assume you are using an HDR monitor). If you are using an HDR monitor, you should note that the game does not support HDR on the PC. It is possible if you have switched windows to HDR mode that it may be causing problems with your particular monitor.

Share this post


Link to post
Share on other sites
  • 0

 

On 2/25/2019 at 9:51 PM, Hexcaliber said:

Not having the same issue at all, my pc is always set to 10 bit full range rgb even for SDR content(I assume you are using an HDR monitor). If you are using an HDR monitor, you should note that the game does not support HDR on the PC. It is possible if you have switched windows to HDR mode that it may be causing problems with your particular monitor.

I've noticed some areas are dark and some of the tracks are so bright the ground looks white.  I also have my nvidia setting to full rgb. I'll have to try it at limited to see if this fixes it.

Edited by Rigle

Share this post


Link to post
Share on other sites
  • 0
On 2/26/2019 at 3:51 AM, Hexcaliber said:

Not having the same issue at all, my pc is always set to 10 bit full range rgb even for SDR content(I assume you are using an HDR monitor). If you are using an HDR monitor, you should note that the game does not support HDR on the PC. It is possible if you have switched windows to HDR mode that it may be causing problems with your particular monitor.

Exactly this. So the only way around this problem would be to disable HDR mode altogether just for the sake of playing DR2?

Share this post


Link to post
Share on other sites
  • 0

I don't use HDR, but I will double check my settings.

The problem could very well be HDR-related, now that you mention it.

  • Agree 1

Share this post


Link to post
Share on other sites
  • 0

I tried fiddling around with both color depth, tv settings and the HDR level setting, but nothing works, except setting RGB dynamic range to "limited".

The problem is probably limited to specific setups, including mine. In daylight, the trees roadside often appear as black shadows.

I'm running an Nvidia GTX970 and a Samsung LED TV, but I'm not running anything in HDR mode, just regular 1080p.

Share this post


Link to post
Share on other sites
  • 0

Ok, so I have tried several adjustments, both on the pc and the tv. I have a Samsung 4K tv set to "game mode".

This is probaly not a bug or an error, but the game is definately much more sensitive to settings affecting black levels, than most other games.

I changed the colour space on the tv (from the default setting "native" to "auto") and adjusted the brightness a bit up (from 50 to 55). That enabled me to use full RGB range without having the extreme darkness in shadow portions etc. in the game. The brightness adjustment screen in the game is a good reference. The leftmost Dirt-logo should be barely visible with brightness set to 1.00. If it isn't, something's off.

So I think my conclusion is that my settings were bad, but not nearly bad enough to manifest itself into problems in other games. My settings now look better altogether in all games, so this was a useful experience. 🙂

Share this post


Link to post
Share on other sites
  • 0

Same here, full range looks so bad in some cases, but i dont change my monitors settings because of one game, so sad 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×