Jump to content

Game glitches every few seconds...unplayable

Recommended Posts

Good enough PC. ROG Maximus X, Intel Core i7-8700K @ 3.70GHz, Memory 32.0GB, Video Asus 1080-Ti, connected by Ethernet 100mbs.

First as said before, FFB is atrocious. But that's not why I can't play. Every few seconds it seems like the whole thing stops and looks for a split like it's magnified. I'm baffled. 

Playing w/Fanatec Clubsport - Forza Motorsport Wheel-fanatec V3 pedals-Fanatec Clubsport SQ V1.5 shifter.

                          

  • Confused 1

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, well known bug. It's related to USB-input. If you unplug one controller at a time (wheel, pedals, shifter) you will likely find that one (or more) of them causes the stutter. It was present in the first game as well and was never fixed. Codemasters are aware of this but can't (or won't) fix it. Something with the way the game engine handles USB-hardware is severely broken. I backed 1.0 in early access and waited patiently for a fix to this but there never was one. I immediately refunded 2.0 when I found the problem is still present and I recommend you to do the same if you can and re-buy the game later if it's ever fixed. The more people not putting up with this the better, hopefully puts at least some pressure on Codemasters to fix it. There should really be a warning when you purchase this game, because if you are affected by this you are screwed. It's a shame people have to discover this and waste time troubleshooting when it's a known problem. Maybe it's deliberate so enough time passes that people can't refund the game.

Edited by os3n

Share this post


Link to post
Share on other sites

I have same problem with similar set up and specs. Tried all sorts but no luck. I have contacted Codemasters.

If I get a fix I will let you know.

kenny.

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Kenny1962 said:

I have same problem with similar set up and specs. Tried all sorts but no luck. I have contacted Codemasters.

If I get a fix I will let you know.

kenny.

Don't hold your breath. Codemasters will probably say that they are looking into the issue but they said the same thing for the first game and then went quiet. There never was a fix and I find it very unlikely there will be one for 2.0. The only thing you can do to temporarily fix it is trying disabling various USB-hardware in device manager and hope for the best. You may also try unplugging other input related USB-devices such as mouse. It's very inconsistent though and can be trail and error every time. Refund the game if you still can is my recommendation.

Edited by os3n

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/2/2019 at 7:12 PM, Thingriz said:

Is this a fact? And there is no fix? Help Please...

Unfortunately yes. I followed this issue closely with the first game and it's the exact same thing carried over to 2.0. The only thing you can do, as I described in my comment above, is try disabling various USB-hardware in device manager and unplugging other USB-input devices and hope for the best. You will have to do this every time and it's very inconsistent. Sometimes it works, sometimes not and may not even be the same devices every time.

Edited by os3n

Share this post


Link to post
Share on other sites
Posted (edited)
Hello
I9 9900K + MSI MEG ACE + DDR4 4400MHZ 
 Corsair MP510 + TS PC Racer + TH8A + handbrake TH8RS 
 T3Pa + Triple screen, + 2 rift sensor + oculus rift Cv1.
 at stake when I unplug the TH8RS, its block more. In game if I disconnect the TS PC RACER block more.
 If all are connected to my USB prot, its block every second, Simple screen, all usb plugged its block


 

Salut 

 

I9 9900K + MSI MEG ACE + DDR4 4400MHZ

 Corsair MP510 + TS PC Racer + TH8A + frein à main TH8RS

 T3Pa + Triple ecran, + 2 capteur rift + oculus rift Cv1.

en jeu quand je débranche le TH8RS, sa bloque plus. En jeu si je débranche le TS PC RACER sa bloque plus. Si tous es branché à mes port USB, sa bloque toutes les secondes, 

Simple écran, tous USB branché sa bloque

Edited by megamandseb

Share this post


Link to post
Share on other sites
On 3/3/2019 at 9:39 PM, os3n said:

Don't hold your breath. Codemasters will probably say that they are looking into the issue but they said the same thing for the first game and then went quiet. There never was a fix and I find it very unlikely there will be one for 2.0. The only thing you can do to temporarily fix it is trying disabling various USB-hardware in device manager and hope for the best. You may also try unplugging other input related USB-devices such as mouse. It's very inconsistent though and can be trail and error every time. Refund the game if you still can is my recommendation.

@ChristinaMc I’m a PS4 user so this specific problem doesn’t even affect me, my question is why do you have a “technical assistance” box in your own forums if the issues with the franchise don’t get fixed, is there a point in any of us being here? I myself have posted an extensive list of problems with the game, and with 2 patches in, the game has gotten worse with very few of the communities feedback issues being fixed, with this second patch it’s now pointless using any of the RWD cars, since Monte Carlo has been added, all RWD cars now have terrible handling, the game is going backwards not forwards, but whatever, I’m bored of trying to contact the team, and bored of waiting for the game to be fixed, if Fire Up That Car... Again trophy isn’t fixed soon so I can get my platinum and move on, il be calling customer support to issue a full refund, I can’t remember the last time I purchased a finished and polished game brand new, not that I do usually but I used to hold Dirt close to my heart, thanks for darkening that love I had for this franchise Codemasters, unless DR3 is MUCH improved, and I mean much, I’m sure you’ll be losing more than just me as a customer, but I pray that doesn’t happen, though I’m not holding my breath... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×