Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
How to contact Customer Service Read more... ×

Dirt rally 2 crashed many times

Recommended Posts

After start the game and plaing some races the game is crashing and i see this:


the acess violation are exaclty the same, its dinput8 dll.

The same problem is after start the game, its crashed with the same error
Or in the Replays, its crashed with the same error....dinput8.dll

windows10 is absolutely new installed.
all drivers are up to date.
no problems with other racing games. (iracing/dirt4/raceroom)

DirectX is up to date, dinput8.dll is also okay

No change on "dirt rally2" Files
the game is exactly the version downloaded from steam.



Asus Sabertooth z170 mark1
I7 7700K 
16GB DDR4 2800
Xonar d2X
4X1000GB SSD

Clubsport base EU With BMW Wheel
Leo Bodnar BU0836LC For Pedals
Thrusmaster Hotas Warthog 
Oculus Rift with Touch and Xbox controller

Microsoft X4 Keyboard and X3 Mouse


i need help, i cant play this game !

thanks for reading

Share this post

Link to post
Share on other sites

dinput8.dll controls the input devices as the name suggests. Try to remove any unnecessary USB peripherals from you PC and try again.

Edited by Lollerke

Share this post

Link to post
Share on other sites

Then we must wait for the first patch. I also experienced crashing and many people too, so Codemasters are aware of it if we send the crash reports.

Edited by Lollerke

Share this post

Link to post
Share on other sites

@Wollev45 Can you try these steps please:

  1. Disabled integrated GPU.
  2. Enabled it again.
  3. Launch the game and open your Nvidia or AMD app.
  4. Detect the game and set it to be used by the GPU at high performance or anything.

Share this post

Link to post
Share on other sites

the integrated gpu are disabled 2017 😄
I dont need the Igpu

The Problem is the USB or the connected devices.

From the beginning..

I have connected to my Rig:
Oculus Rift
2 Rift Sensors
2 Touch controllers

1 Xbox 360 Controller
1 Thrustmaster Hotas Warthog-Set (2 USB)
1 Fanatec CSW 1.5
1 Pedals with Controller Bu0836Lc from Leo Bodnar


Now... its beginnig crazy...i dont understand...its funny

After starting DR2, the game is running or its running not.

: start
After one or more Races, or on the Replay, the game is crashing with the Error message from Post#1

Now, i disconnect the rift, usb and hdmi
the game is crashing @: Start

I disconnect the Sensors
the game is crashing  : Start

I disconnect the 360-Controller.
the Game is running fine, 4 Hours playtime without errors.

I connect the Rift, the Sensors, the Controller..
the Game is running fine, 2 Hours playtime without errors.

this was Yesterday...

Today 1h Pm:
I start my rig without rift, sensors and the 360 controller.
the devices are disconnected from usb.

I start dr2 and...
the game is crashing  : Start
30 mins testing, 5 errors... Really ?

I disconnect the:
Hotas Wathog System and the game is crashing @ : Start
I disconnect the pedals an the game is crashing directly after start @ : Start
I disconnect the fanatec base and the game is running...

I connect all my USB devices and the game is running...its stuttering..every 2 seconds one secound pause...unplayable.

I shutting down the computer...
I connect all usb devices.
I start the computer.
I start dr2 and the game is running for 2 hours without errors.

i shutting down the computer...
I restart the computer, no changes.
I start dr2...it crashes...

Do aou need any logfiles from me for discover the problem ?


by the way...
I have absolutely the same problems in dirt rally one. (i have buy DR @release Early acess)
DR crash to the desktop and its save dumpfiles in the game directory.
with a mdmp reader, i have see the same problems in DR from DR2.
the last entry or on eentry is a "access violation in dinput8.dll"
two dump files are here as an atachment.


i hope this files help you to finding my problems.

I love the dirt rally games and i want to play this fantastic games with a very big smile in my face 😄

Last, sorry for my terrible english (i am from germany.)


Edited by Wollev45

Share this post

Link to post
Share on other sites

Nice Support... Thank you for Nothing !

Da kann man nur den Kopf schütteln bei solch einem beschissenen Support.


Edited by Wollev45

Share this post

Link to post
Share on other sites

I have crashes too, 2-4 crashes in 1,5 hours approximately. Sometimes after the stage, sometimes before the stage, sometimes in the middle of the stage, sometimes in the options when it tries to save my settings. Wait for the first patch as I do, then write here again.

Edited by Lollerke

Share this post

Link to post
Share on other sites

@Wollev45 have you tried booting the game with only supported peripherals plugged in? So only your racing wheel, peddles and 360 controller? Using an Joystick and Rift kit might currently cause problems.

Share this post

Link to post
Share on other sites

For the moent, only thefanatec base and the pedals are connected.

the keyboard and the mouse are connected trough ps/2


no changes with the error.
i cant belive...fanatec problems ?
drivers are up to date and the problems are only, 100% and absolute only, in dirtrally and dirtrally2

Share this post

Link to post
Share on other sites

Hi Wollev45

I managed to find your crash report. Please try disabling steam overlay.

You should be able to disable steam overlay just for DiRT Rally 2.0 by going to properties on the game, general, untick "Enable the overlay while in-game".



Share this post

Link to post
Share on other sites

I have the same problem since the Original Dirt Rally. I have a Core i9-9900k and a GeForce RTX 2080. I use a Logitech G29 wheel. Only the wheel, keyboard and mouse connected to the PC. The same happened with my old Core i5 with a GTX 960. I thought it was my video card (it was a 2GB version) so I updated the whole computer.

The problem with DR2 is much worse. I cannot finnish any stage because the game breaks. I've sent about a thousand of bug reports and nothing. I've tried everything. All games overlays (steam, xbox, nvidia) are off. I've tried disconnecting the keyboard. I've tried disconnecting the mouse. I've tried running the game in administrator mode. In compatibility mode. And a thousand things more.

Every other game I play (WRC7, Forza Motorsport) runs without a problem.

I really think it has to do with the G29 wheel. But i'm using the latest driver and not using the wheel is not a solution.

Why Codemasters don't admit there is a problem.

Please HELP.

Share this post

Link to post
Share on other sites

@cafre what exactly happens when the stage breaks? Does the game just close? Does the game crash? Does the screen just go black? At what exact point is the game having the issue?

Share this post

Link to post
Share on other sites

The game closes with the same error screen as the first post.


It never happens on the start menus.

Sometimes it happens after the loading screen (just before the game shows your car in the garage)

Sometimes it happens just when the stage is starting (when your car parks before the start lights)

Sometimes it happens in the middle of the stage. Sometimes at the end.

I always send the report.

I have to open the game again and try to play again.

I've checked and all my drivers are up to date. Including Logitech GHUB.

Something important to mention. About 1 in every 12 o 15 times I try to play, the game works fine. No crashes.

Additional details.

  • I used to have the same problem with the original Dirt Rally in my old computer.
  • This problem in Dirt Rally 2.0 also happened with my old computer (Core i5-4670 and GTX 960)
  • The only things I've migrated to the new computer are the Keyboard, the Mouse, the Screen and the Logitech G29. Everything else (MoBo, RAM, SSD, Video Card, Power Supply and Box) is completely new. That's the reason I think the problem has to do with the G29 wheel.
  • I'm using a Comfort Curve Keyboard. A Microsoft SideWinder Gaming Mouse. And a Samsung 4k TV as montior.
Edited by Cafre

Share this post

Link to post
Share on other sites
7 hours ago, CM_Ads said:

@Cafre Thanks for the info. I will take a look into this for you.

So, I've been looking all over for people with the same problem. There are some comments on Reddit, but I couldn't find any similarity with their setups and mine. Not in software nor in hardware. The only thing is all of them are using Wheels to play. Different models from different vendors. 

Also I've seen a lot of people in Youtube playing with the G29. And none of them report the same error. But I don't think we can discard the hardware in general as a problem yet.

Based on the fact that I have the same problem on the old computer, I've made a list of the things I think might be the issue.

  1. Some software installed on the computer. As I usually hace the same software installed on my computers there might be something causing the problem.
  2. There might be problems with sound outputs. I'm using the TV as the sound device, via the HDMI, so I'll try changing the output to the MoBo and using some speakers.
  3. A really weird incompatibility with come of the other Peripherals. The keyboard, the mouse and the screen.
    1. I'll try with different keyboards and mouses, but I really don't think that might be.
    2. I'll try to get another monitor to test with. This won't be easy so I'll leave it as a final option.
  4. A very weird defect on my wheel. I happen to have other wheels (all of them Logitech). But I'll try.

So, based on that list, I started some tests.

1. I found in Reddit some people with the same problem, although with different Wheels. Some of them said they found the problems when they where running a VMWare VM on the same machine while playing the game.  I don't have VMWare or any other virtualization SW on my machine, but it gave me the idea that there might be a problem with software that installs virtual hardware. So:

  • I uninstalled PrimoPDF (a virtual printer to print to PDF).
  • I uninstalled Visual Studio 2019. It installs some virtual hardware for mobile development.
  • I stopped Google Drive File Stream before playing. It works as a virtual hard drive.
  • I stopped Dropbox. It doesn't install virtual hardware but it was the only other thing running in the machine at this time so decided to stop it.

Results: No luck. Same problem.

2. Just to try, I changed the G29 switch from PS4 to PS3. The wheel works fine in the game. But again the same problem. Logitech says that the wheel should be in PS4 mode so I think we can discard this as a problem.

Result: Same problem.

So no luck so far.

Now, since some weird software might be the issue. I decided to make a clean Windows install and try playing the game. Without anything else installed, just drivers, steam and the game. It's a little tedious because I have to download and install Dirt 2.0. But I'll try.

Last night I reinstalled Windows with all the drivers, and left Steam downloading the game overnight. Today I'll start testing.

@CM_Ads If I can help you with any additional information, memory dumps, hardware or software details, just ask. I'm willing to help with anything you need. I know this is no generalized problem, but the problem is out there, so please make everything you can help me solve it.


Share this post

Link to post
Share on other sites

So. Another day and a half of tests and no luck. No clear solution yet.

Yesterday'd and today's tests:

First, as I've mentioned on the last post, I've made a clean Windows install. After the setup I installed the MoBo drivers so the Device Manager doesn't show any driver missing. My new MoBo is a Aorus Z390 Pro (no WiFi). The BIOS it's upgraded to the last version (F9) and I downloaded the latest drivers.

After installing the drivers I downloaded the Logitech Gaming Software (LGM), the latest version. I went for it instead of Logitech GHub because the GHub doesn't show the wheel. I don't know why. The moment I install LGM the wheel is detected in both programs. But to have the cleanest setup possible I went for LGM alone.

So no, I downloaded Steam, logged in and started downloading Dirt Rally 2.0. I left the computer downloading overnight.

I'ts important to mention that I didn't download anything else. No NVidia Gaming Experience, no additional programs , not even Chrome. I didn't configured anything aside the screen resolution.

Also, I stopped Windows from updating.

Also. I didn't uninstall anything from Windows. I just left the intsall as is. 

This is an image of my Programs and Features window before I started playing the game.


So. A very clean Windows to start the tests.

Again, the only hardware attached is the Screen, Keyboard, Mouse and Logitech Wheel.

TEST 1: Results

So. After playing for a while, everything seemed to work fine. No crash so far. But after about 30 minutes. I was in the garage before a stage. I decided to quit the game, so I selected the Quit To Main Menu option and... First Blood. Well First Crash. The same one. Again I went into the game and played for a while with no crashes.

In the afternoon I started playing again. I opened the game and immediately crashed, no in the intro screens.

Opened the game again and it crashed during a stage.

Again, now it crashed just after the loading to the garage.

So, this doesn't seem to be a problem with some software I had installed.

TEST 2: Results

So It doesn't seem to be a software problem. ¿What now? I tried some changes related to hardware. Nothing to fancy. Just making sure everything was as it is supposed.

I disconnected the wheel from the USB 3.0 and connected it to a USB 2.0 port. Tried the game and it worked fine for a while. Then it crashed again. So the port doesn't seem to be the problem.

Then I entered the game and calibrated the wheel again. After calibrating, I found a section in the game called Device History, there was my Wheel listed, but there was another HID Device which I decided to delete. After this I was able to play for about an hour. I didn't crashed. My hopes where hight. I thought I've might found the problem. Si I closed the game, turned off the computer and went to sleep.

So today I booted the computer. Immediately started the game and... The Same Crash again. This time during the intro videos. I tried again and it crashed again, now while navigating in the main menus. Third time and the same, but now in the garage. I turned the computer off and went to work.

In the afternoon I tried playing the game with mixed results. It crashed some times, but was able to play for like an hour after various tries. After that I resume installing all my things in the computer. Software doesn't seem to be the issue.

I'm really bummed. I'm gonna try changing the mouse and keyboard. That's next in my list but I won't be able to try until the weekend. Maybe I'll try changing the audio output to the MoBo card. But after that I won't be trying anything else. I'll go back to other games.

I've found people reporting the same problem for Dirt 4 and F1 games. I understand it is not easy to catch this kid of bugs, but I really hope Codemasters gives the problem the attention it deserves.

Share this post

Link to post
Share on other sites

Bump? Was this problem solved? I can't get more than thirty seconds into a stage without this same crash occurring...please help!

Share this post

Link to post
Share on other sites
On 6/10/2019 at 1:53 AM, CM_Ads said:

@cafre what exactly happens when the stage breaks? Does the game just close? Does the game crash? Does the screen just go black? At what exact point is the game having the issue?

I have nearly this exact same problem. When I start a stage, the game seems to run fine for about thirty seconds. After that, the screen goes black, the sound freezes, it stutters for a second, then crashes to desktop with the access violation. I use the Logitech Gamepad F310.

Share this post

Link to post
Share on other sites

Hello? anyone home?? Need help please...really would love to actually be able to play the game I paid my hard earned money for...

Share this post

Link to post
Share on other sites
11 hours ago, CM_Ads said:

@Twiggers1999 this issue is being investigated internally.

ok. please let us all know what happens. I haven't been able to finish a stage since I bought the game.

Share this post

Link to post
Share on other sites

I'm 99% sure I've solved it. At least in my case.

SOLUTION: Changing the mouse or disconnecting it before launching the game.

I wasn't able to play for the las 2 weeks but yesterday I was able to try some new things. I changed the mouse and keyboard and started playing without issues. Then I connected my mouse (Microsoft SideWinder Gaming Mouse, the original one) and the crashes started again. Switched the mouse again and no problems. I played for 3 hours yesterday without an issue.

So changing the mouse before playing it's a little tiresome. Today I tried disconnecting it before launching the game, and it works perfectly. Also you don't have the mouse pointer appearing randomly during a stage.

So there seem to be a problem with some mouses, in my case it was the Microsoft Sidewinder, but this may be happening with other ones.

I haven't tried the solution on the original Dirt Rally so I'll try it later.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now