Jump to content Jump to content

Dirt rally 2 crashed many times


Recommended Posts

  • 1 month later...
  • 4 weeks later...

Just downloaded the game on Oculus Store and experiencing crashes during startup similar to what is described here. I updated my video drivers and still no luck. I run a g25 racing wheel and tried unplugging all usb devices except the rift devices and that didn't work. 

Link to post
Share on other sites
  • 1 month later...

SOLUTION!

 

Had the exact same problem as you. tried unplugging different wheel and so on.

 

My solution to this was, downlading " IOBIT Driver booster " (its free) and with that program you go to - Tools - Clear data from disconnected usb units.

and remove those that pops up. FIXED! :D

I hope this works as good for you as it did for me!

Best regards!

Link to post
Share on other sites
  • 6 months later...

Worked for months ok, all of a sudden not anymore, a. after upgrade my GTX1080 got too hot, gave more cooler spin, b. set Windows compatibility to "8.1" for my"x:\SteamLibrary\steamapps\common\DiRT Rally 2.0\dirtrally2.exe"

P.S. when I have Win10 do a compatibility check it says to set to 8.1 (so it looks for DX11 ?!)

Link to post
Share on other sites
  • 7 months later...

FIXED!

I have apparently just managed to fix the game myself after much stuffing around, well, for me at least. It was freezing after a few races with the game still running in the background. Posting my experience here just so the next person doesn't have to go through everything I just did to figure out what's going on here. 

There's a couple, maybe a few things at play here.

Firstly, if you're getting those error messages, i.e. "Access violation at address", this is your video drivers and updating my drivers removed this error for me, however the game would still freeze like it would after a few races.

Secondly, the game seems to deliver an extremely smooth experience, even if you are pushing your graphics card beyond it's limitations which makes it easy to think your card can handle everything on ultra, but trust me you're probably cooking your GPU so turn off your overclocking. If you're running a more modern card, it can handle everything on high-ultra anyway so no need to play with overclocking on, the game just doesn't seem to like it.

And last but not least, the fix that seemed to fix everything from here, updating my Nvidia Game Ready Drivers through the GeForce Experience then auto optimizing your game settings through GeForce Experience. I do believe it's the Nvidia Multi-Frame Sampled Anti-Aliasing that makes all the difference as now I'm getting better frames running the game for hours at a time with no crashes, not overheating my GPU running everything on ultra.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...