Jump to content
  • 0
Sign in to follow this  

My car AI on others screens

Question

The last couple of weeks I've had an issue where my car has an 'x' next to it on one person's screen in a league multiplayer race.  Last week someone had an 'x' next to their name on my screen.  The thing is that the car keeps lapping but it isn't in the actual place on track that the human controlled car is.

For example tonight I was coming 8th on the first lap however someone ran in to me on their screen when it showed I was 11th.  I wasn't even in that spot.

Is this a common issue and is there a fix.

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

X on the car means there are no connection to the player and car is simulated/driven by AI.

What is your NAT settings? You should have open NAT and the player who has the X on you should have it too, otherwise there will be problem like that.

Share this post


Link to post
Share on other sites
  • 0

I've been researching this but can't find where I see if I'm on open.  Nothing in the router settings which I think is where it would be?  I've seen some tutuorials about port forwarding and DMZ but this seems a bit extreme.  I've done port forwarding before but dont' expect I'd need it for F1.

Share this post


Link to post
Share on other sites
  • 0

Actually, you need to have open NAT for every peer2peer game to mitigate connection problems. It depends on your platform, how to do it, anyway, basically you have to forward all necessary ports to the target machine with the game (PC/Xbox/PS).

First answer for googling "port forwarding F1 2018" https://portforward.com/f1-2017/ (AFAIK ports didn't changed)

 

Share this post


Link to post
Share on other sites
  • 0

Does everyone that plays multiplayer have to do this.  I've only had trouble with 1 or 2 people out of the 15 I race with.

Share this post


Link to post
Share on other sites
  • 0
57 minutes ago, Cobalt765 said:

Does everyone that plays multiplayer have to do this.  I've only had trouble with 1 or 2 people out of the 15 I race with.

You don't have to do it if your router can implement uPnP properly. Most SOHO routers do, but with varying degrees of worth.

The fact that this was news to you probably means you shouldn't try PF.

MOST lag is caused by WiFi latency, it is the single most variable variable. That and the loss of available bandwidth due to a lack of QoS on the router, "best effort" is the probable unreconfigurable best case. 

Having said all that, perhaps the game does try to transfer too much data via the host (i.e. everything except the car immediately in front or behind). So yeah, everyone's (terrible) connection plays a part and I doubt the netcode is error free.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×