Jump to content
  • 0

Long Loading Screen [FIXED]

Question

Posted (edited)

Hello everyone

 

I played a lot of Dirt Rally 2.0 in the past few days and been enjoying it a lot. But one thing that really really bugs me is the fact that I get very long loading screens.

I googled that problem and I didn't really find anything. So i thought maybe I'm just impatient. But then I looked up some gameplay videos on YouTube and people get loading screens of about 15-20 seconds, while it normally takes more than a minute for me. Even a friend who plays on xbox told me that he has quick loading times.

 

I changed some ingame graphics settings, changed resolution and even audio settings, but nothing seems to be the trigger for the loading times, even though the stage loaded in about 40 seconds on 720p with everything on low (still a lot longer than it should be).

 

My PC should also not be the problem for that. I'm playing on a i7 6700k, GTX 1080 FE, 24 GB RAM (3x8 GB DDR4-2400).

Game is installed on a M.2 Samsung SSD 950 Pro, 512 GB (2500 MB/s read, 1500 MB/s write). I tried relocating the gamefiles to my slower Samsung SSD 840 Basic (540 MB/s read, 250 MB/s write) but the loading times were about the same.

 

Here is a video: 

 

First loading screen is 1min 15sec.

Second loading screen is 1min 30sec.

 

Anyone knows how to fix this problem?

Thanks in advance.

Kind regards,

Criffix

Edited by CriffixX

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 1

Hi again, I have managed to get loading level time down to approx 30 seconds.

While the game is loaded and idling, I have opened windows task manager, selected Processes, right clicked the Dirt Rally exe and set the CPU priority from "below normal" to "high".

I am using Windows 7, Windows 10 is very similar.

If the CPU Priority is not saving, there is a small program called Prio that adds the ability to save this setting.

Hope this helps, it has transformed my user experiance with this game.

 

Namorismo

 

 

  • Agree 1

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

Hello everyone

 

Thank you for all your comments. Special thanks to NamorNismo with the fix. I have not checked on this post in a while and found out a fix by myself today.

I come back and read NamorNismos message and his fix is pretty similar to mine, but mine will load a little bit faster.

 

Quote

 

Step 1: Open Dirt Rally 2.0

Step 2: Open Task Manager

Step 3: Go to "Details"

Step 4: Right click on "dirtrally2.exe"

Step 5: Click on "Set affinity"

Step 6: Disable "CPU 0"

 

 

I made some "loading-tests" and compared my fix with the one from NamorNismo and here are the results:

-measured from clicking on "select" (car) to the beep-sound after loading-

Location: Monaro (Australia)

Stage: Mount Kaye Pass (Daytime/Cloear/Dry Surface)

Normal loading time: 45 seconds

Change CPU priority on max: 16 seconds (!)

Change CPU priority on max and disable "CPU 0": 12 seconds (!!!)

Disable "CPU 0", standard CPU priority: 12 seconds (!!!)

 

All default programs are running on "CPU 0". Disabling it lets the game focus on the other CPUs and they will not get limited by CPU.
Unfortunately you have to do this manually every time you open the game.

 

Cheers everyone,

Criffix

 

Edited by CriffixX
added YouTube video
  • Thanks 2
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Hello my friend, just to let you know, you are not the only one having this long load time problem.

My load times are approx 1m 50s for each stage and its getting quite tiresome now.

I have reinstalled the game to a different SSD and the loading times have not changed.

I too have tried all the settings to minimum with no luck.

The only thing I have noticed is while I am waiting for the level to load I have noticed that only 1 core (number 3) is working to load the level, once the level is about finished loading all the other cores fire up.

My PC specs, Windows 7, intel i7 4770k, 16 gb memory, GTX 1080Ti. Samsung Pro SSD 512gb. Monitor 34" 3440x1440.

Namorismo.

PS, I dont have these problems with Dirt Rally1

 

 

 

Edited by NamorNismo
PC specs

Share this post


Link to post
Share on other sites
  • 0

Thanks for your message.

I did a PC reset yesterday an wiped all my SSDs and HDD. Reinstalled Dirt Rally 2.0 and the loading screen still takes forever. 😞

Share this post


Link to post
Share on other sites
  • 0

This can be done by using 🙂 the command shortcut.

C:\Windows\System32\cmd.exe /c start "" /High "C:\Program Files (x86)\Steam\steamapps\common\DiRT Rally 2.0\dirtrally2.exe"

Share this post


Link to post
Share on other sites
  • 0

Having the same issue, with amlmsot identical config that CriffixX. Any official solution yet? I hoped 1.3 will solve it...

Share this post


Link to post
Share on other sites
  • 0

As i said upping the CPU prioty makes a massive difference, loading screens take about 20 - 25 seconds now.

I have stopped playing the game in its current form, to many bugs and irritations.

Dirt Rally 2.0 is not a fun game to play in my opinion.

 

Share this post


Link to post
Share on other sites
  • 0

Right, better for me as well. Still using only one core. 

Share this post


Link to post
Share on other sites
  • 0

The only improvements in 1.3 are slightly shorter loading times.

Share this post


Link to post
Share on other sites
  • 0

I have to confirm shortening of the loading time and better operation of the entire DR2.

According to the tests it seems that the DR2 is used instead of a physical core unhappily HT core!

Can a DEV write an explanation, thank you.

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, CriffixX said:

Hello everyone

 

Thank you for all your comments. Special thanks to NamorNismo with the fix. I have not checked on this post in a while and found out a fix by myself today.

I come back and read NamorNismos message and his fix is pretty similar to mine, but mine will load a little bit faster.

 

 

I made some "loading-tests" and compared my fix with the one from NamorNismo and here are the results:

-measured from clicking on "select" (car) to the beep-sound after loading-

Location: Monaro (Australia)

Stage: Mount Kaye Pass (Daytime/Cloear/Dry Surface)

Normal loading time: 45 seconds

Change CPU priority on max: 16 seconds (!)

Change CPU priority on max and disable "CPU 0": 12 seconds (!!!)

Disable "CPU 0", standard CPU priority: 12 seconds (!!!)

 

All default programs are running on "CPU 0". Disabling it lets the game focus on the other CPUs and they will not get limited by CPU 0.

Unfortunately you have to do this manually every time you open the game.

 

Cheers everyone,

Criffix

 

This works very well, thank you! Later today, or tomorrow, I'll look in to how to do this from powershell, so dont have to click all around...

Share this post


Link to post
Share on other sites
  • 0

When the game will make use manually, only physical cores, I have the best results.

This can be easily with one command:  start /affinity and Hexadecimal value the correct value will be for each processor different !

Using the converter you can experiment for the best results https://www.binaryhexconverter.com/binary-to-hex-converter

Value for cpu i7 4 core/4 th: Binary 01010101 = 55 Hexadecimal

Result of the command is: start /affinity 55


Final form of the command CPU priority high:

Quote

C:\Windows\System32\cmd.exe /c start "" /High /affinity 55 "C:\Program Files (x86)\Steam\steamapps\common\DiRT Rally 2.0\dirtrally2.exe"

DR2core.JPG.49d331a77cfab0b17950e9663e0c8a18.JPG

The condition is to have a running Steam client !

Share this post


Link to post
Share on other sites
  • 0

Hi,

still I didn't get the CM the answer, will be in the following update 1.4 fixed Affinity weirdness?

Share this post


Link to post
Share on other sites
  • 0
On 4/27/2019 at 12:09 PM, CriffixX said:

Hello everyone

 

Thank you for all your comments. Special thanks to NamorNismo with the fix. I have not checked on this post in a while and found out a fix by myself today.

I come back and read NamorNismos message and his fix is pretty similar to mine, but mine will load a little bit faster.

 

 

I made some "loading-tests" and compared my fix with the one from NamorNismo and here are the results:

-measured from clicking on "select" (car) to the beep-sound after loading-

Location: Monaro (Australia)

Stage: Mount Kaye Pass (Daytime/Cloear/Dry Surface)

Normal loading time: 45 seconds

Change CPU priority on max: 16 seconds (!)

Change CPU priority on max and disable "CPU 0": 12 seconds (!!!)

Disable "CPU 0", standard CPU priority: 12 seconds (!!!)

 

All default programs are running on "CPU 0". Disabling it lets the game focus on the other CPUs and they will not get limited by CPU 0.

Unfortunately you have to do this manually every time you open the game.

 

Cheers everyone,

Criffix

 

System Explorer allows you to save your cpu affinity settings

 

http://systemexplorer.net/

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Changing processor affinity from within the software is not actually a simple thing to do.  Specifically excluding one core.  If they really wanted to they could try using

std::SetThreadIdealProcessor()

  but that again assumes they assign specific thread(s) to a specific core.  And as you know different processors have different configurations that come into play.

Edited by bn880

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×