Jump to content

DiRT Rally 2.0 - V1.2 - found a bug? Post it here!

Recommended Posts

5 hours ago, TeamCrevette said:

hi ,

bad translation  for the weather , DRY is SEC in french

it s write VIDER on game

AND my hanbrake don t work after patch !!!

Go to my post. I have the fix.

  • Agree 1

Share this post


Link to post
Share on other sites
1 hour ago, Franconen said:

Same thing for me .

DSD button box and Fanatec hub with Leo Bodnar board works perfectly after the update and not working after .

Devices are views by the game but not working .

Sincerly it's not possible such unprofessional work for a major studio like Codemasters .

If you haven't fixed it yet I made a post how to get everything working again. It's in general discussion.

  • Agree 1

Share this post


Link to post
Share on other sites

error traslate in menù: english/ italian......... Clear ( wheater ) is --------------> CHIARO, not CANCELLA

  • Haha 1
  • Disagree 1

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, ale81udine said:

error traslate in menù: english/ italian......... Clear ( wheater ) is --------------> CHIARO, not CANCELLA

and dry  is asciutto

Edited by teknoid85

Share this post


Link to post
Share on other sites
Just now, teknoid85 said:

e secco è asciutto

diglielo, almeno fai una cosa sensata a parte dare retta a sto forum di coglioni. se vuoi argomentare di rally reale o sim con gente seria vieni su facebook

  • Like 1
  • Haha 1
  • Disagree 1

Share this post


Link to post
Share on other sites

The low grip bug thing is still there, I’ve had it since the start on PS4, anyone else get it? Anyone found how to fix it yet? 

Every time I enter the second race the rear suspension locks out or goes really high and the car won’t steer or get traction on the floor, it happens in all cars but rear wheel drive cars are really bad. It doesn’t matter how little damage is on the car before the bug happens too.

The game is just unplayable at the moment, it’s a big disappointment. 

Below is a video of the bug. 

 

  • Confused 1
  • Agree 2

Share this post


Link to post
Share on other sites
Posted (edited)

Two issues I've not seen listed anywhere in the forums, nor Reddit, etc.:

  • Somehow I can't view leaderboard times by friends on other platforms. Specifically, I'm playing on Xbox One and have added a PC friend in Racenet (whose account is linked to his Steam account and linked in his DR2.0). When we try to compare our times for a specific stage and car class, we can't see each other at all, however we can see our entries as "DiRT Player" in the global leaderboard (we validated that by comparing country, position in the leaderboard and our exact leaderboard times). I can see another friend on Xbox One just fine.
  • In the Xbox achievements & stats section on my Xbox One, for all games (including the original Dirt Rally), I can see the total number of hours played. Somehow the number of hours played stat isn't there for Dirt Rally 2.0, either on the Xbox One itself or in the Xbox app for iPhone.
Edited by michaelf

Share this post


Link to post
Share on other sites

I compared the device_defines.xml files before and post update - it would appear you've changed/broken something to do with the way that devices which arent specifically named by PID/VID in the xml file are being handled by the game.

i.e.

before v1.2 - button boxes, handbrakes etc worked fine even if they weren't specifically defined in the xml file.

after v1.2 - these devices now need to be manually added in order for people to get them to work.

Share this post


Link to post
Share on other sites
36 minutes ago, michaelf said:

Two issues I've not seen listed anywhere in the forums, nor Reddit, etc.:

  • Somehow I can't view leaderboard times by friends on other platforms. Specifically, I'm playing on Xbox One and have added a PC friend in Racenet (whose account is linked to his Steam account and linked in his DR2.0). When we try to compare our times for a specific stage and car class, we can't see each other at all, however we can see our entries as "DiRT Player" in the global leaderboard (we validated that by comparing country, position in the leaderboard and our exact leaderboard times). I can see another friend on Xbox One just fine.
  • In the Xbox achievements & stats section on my Xbox One, for all games (including the original Dirt Rally), I can see the total number of hours played. Somehow the number of hours played stat isn't there for Dirt Rally 2.0, either on the Xbox One itself or in the Xbox app for iPhone.

There was a discussion about this in the old bug thread some days ago and this is do to rights restrictions with Console manufacturers and a part GDPR. 

Share this post


Link to post
Share on other sites

Might be because I'm just looking for issues after the New patch, but I think I've noticed more popping on Poland. As in foliage popping into life quite late.

 

Ps4 pro

No video to back it up, and it may have been happening pre patch.

Share this post


Link to post
Share on other sites

the sound is still cut in the middle of the sections, steam version

Share this post


Link to post
Share on other sites

fanatec wheel problems since update.  on PC.  it like disconnects and reconnects mid race.   anyone else?

 

Share this post


Link to post
Share on other sites

Unable to assign arduino handbrake after the update 1.2. The game sees the arduino device, but don't assign its axis.

Share this post


Link to post
Share on other sites
6 hours ago, MBastieK said:

Related to all new controller binding problems.

I had to edit the
(E:\[Games]\DirtRally2.0\)...steamapps\common\DiRT Rally 2.0\input\devices\device_defines.xml
file to get my Controller working again.


Maybe adding or editing the files in 
(E:\[Games]\DirtRally2.0\)...steamapps\common\DiRT Rally 2.0\input\actionmaps
can help too. I didn't do it, because I used a exisitng file in there for my virtual Joystick(vJoy) problem.

In "dxdiag" i checked the VendorID and ProductID of my vJoy-Controller and added
<device id="{BEAD1234-0000-0000-0000-504944564944}" name="ftec_clubsport" priority="101" type="wheel" />
to 
(E:\[Games]\DirtRally2.0\)...steamapps\common\DiRT Rally 2.0\input\devices\device_defines.xml
file.

Beware of ProductID and VendorID order: my: ProductID: BEAD , VendorID: 1234
I misused "ftect_clubsport" actionmap/name for first try and it worked.


I still think Codemasters did a "bug" with these files.
Actually this bug also helped me understand and solve an older individual problem, which I had with vJoy and Input-Output-Linearity. Thanks.

Greetz

Hi Crevette, we know eachother from #No Control Rally RX in PC2.

But had the same issue but this works for me after the patch. Try it!

 

Cheers

Share this post


Link to post
Share on other sites

I had the AUDIO BUG , where audio totally goes , apart from gravel sounds, no pacenotes or engine sounds..

It was annoying when it happened as i was stomping along in the Weekly and it caused me to go straight into a tree and DNF because i couldn`t hear anything.  NOT IMPRESSED !!!

  • Agree 1

Share this post


Link to post
Share on other sites

Not to worry folks, all of these bugs will be fixed by September, the patch is called WRC8 😂

  • Haha 3
  • Agree 1

Share this post


Link to post
Share on other sites
9 hours ago, callumo418 said:

The low grip bug thing is still there, I’ve had it since the start on PS4, anyone else get it? Anyone found how to fix it yet? 

Every time I enter the second race the rear suspension locks out or goes really high and the car won’t steer or get traction on the floor, it happens in all cars but rear wheel drive cars are really bad. It doesn’t matter how little damage is on the car before the bug happens too.

The game is just unplayable at the moment, it’s a big disappointment. 

Below is a video of the bug. 

 

Yes, I can confirm this bug on PS4. Also here it happens EVERY SECOND stage. 😒

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

Game still crashes, I cannot play the game normally even after 1 month, please fix ASAP:

 

Edited by Lollerke

Share this post


Link to post
Share on other sites

Playstation 4 Pro Gamer.

I think it's not a bug, it would just be an improvement. The raindrops are too big and too white. Maybe you can make them a little smaller and more transparent. Otherwise it's a great game and it's great fun. Thanks Codemasters Team

2019-03-21 09.36.03.jpg

2019-03-21 09.37.01.jpg

  • Agree 2

Share this post


Link to post
Share on other sites

Playstation 4 Pro Gamer

In New England, near the waterhole. Does the dust stand up?

2019-03-21 09.50.27.jpg

  • Agree 1

Share this post


Link to post
Share on other sites
11 hours ago, mshagg said:

I compared the device_defines.xml files before and post update - it would appear you've changed/broken something to do with the way that devices which arent specifically named by PID/VID in the xml file are being handled by the game.

i.e.

before v1.2 - button boxes, handbrakes etc worked fine even if they weren't specifically defined in the xml file.

after v1.2 - these devices now need to be manually added in order for people to get them to work.

Well, I guess that depends on what kind of controller used in the button boxes. I have two button boxes connected and they both work fine after the update, did not have to rebind anything. My handbrake on the other hand stopped working. I added a line "device_defines" file so that problem is taken care of for now.

Share this post


Link to post
Share on other sites

@ChristinaMc

Bug report for V 1.2 

Co driver missing calls in multiplayer public lobbies

I always drive with co driver on screen display disabled and have noticed since launch in multiplayer lobbies the co driver misses many calls over a vast amount of stages with any class.

I had hoped this would be fixed with the recent 1.2 patch but since it hasn't been I have compiled some footage today as an example of the problem.

The bug is very easy to reproduce, it has happened every time I play multiplayer and I have heard many others complain about it so it is not an isolated bug.

For people like myself who like to play with minimal OSD settings this bug can make multiplayer unbearable, depending on the calls that are missed.

I ran the same stage 3 times in this video and cut a section where calls are missed in public lobbies and compared this to a time-trial mode run, where no calls are missed.

Youtube video link: 

 

Video is 3 parts,

part 1 is timetrial mode where no calls are missed

part 2 is public lobby where many calls are missed

part 3 is with OSD calls turned on, its very obvious the calls that are missed here.

Sysinfo file is attached.

Co-driver transcript:

Underlined is what calls are missed from part 2 of the video

Caution crest turn 3 left long
80
6 Right long opens over crest jump
30 
crest and 5 left extra extra long over crest 
30 
5 right long opens over crest into flat left over crest
60
turn 5 left over jump crest and 6 right long opens over crest into 6 left extra long tightens 5
30 
4 right  over crest narrow 
70
5 left tightens narrow and 6 left over jump into 5 right long tightens three.

 

If CM is serious about building a eSport following for this game I should think this bug would be addressed sooner rather than later

Thanks,

Escourge
 

 

Sysinfo.nfo

  • Agree 3

Share this post


Link to post
Share on other sites

I'm having problems with the game lagging after the update. It's not a lot, but still enough to make it irritating.

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have framedrops (to half fps) too, since updated to 1.2.

The game also is using only 4 of my 8 cores.
Seen in task-manager and in config-file: 
threadStrategy: workerMap4Core.xml is only used.

Dirt Rally 1 used workerMap8Core.xml with the additional more-core options set.

Greetz

Edited by MBastieK

Share this post


Link to post
Share on other sites
Posted (edited)

For some reason when i try to play the weekly challenge with the DLC cars it doesn't recognise my season pass, despite D+ being on my profile.

 

Edit: i'm stupid. Both cars were waiting to be installed on my Xbox 

Edited by SillySinStorm
  • Haha 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×