Jump to content

DiRT Rally 2.0 - V1.2 - found a bug? Post it here!

Recommended Posts

I'm not sure if anyone else is experiencing this. But after installing 1.2 I can no longer load into a stage on career mode, it just hangs for over 5 minutes in the loading screen, it used to load in under a minute, I've attempted this after restarting the game and OS multiple times, I end up giving up with no success. Also loading timetrail is hit and miss . Sometimes it loads okay other times it just hangs and doesn't load at all. Its incredibly frustrating given that the menus are already very slugish due to the slow response times of Racenet and this update has just made the game near unplayable for me. 

I would like to enjoy the game, but its slow and unreliable at the moment.

Specs 

  • Windows 10 Pro 64 Bit
  • NVidia GTX 760
  • 16GB Ram
  • Intel 8700K

Share this post


Link to post
Share on other sites

I can confirm that the sound bug still exists. This is completely game breaking for me. A rally game without pacenotes is just impossible to play.
Sound cuts mid stage, I only hear faint gravel noise after that, no motor sound, no pacenotes. Only possible to get sound back by returning to the main menu and thus giving up on an ongoing event 😞

  • Agree 3

Share this post


Link to post
Share on other sites

@ChristinaMc

 

hello

 

there are certain stages where is written (italian)   cloudy AND clear (nuvoloso e sereno)    those stages are al wet................

also when stage is loading  when it's dry   it's written "cancella" wich means cancel.....  right word is "asciutto"

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, ChibiFlakes said:
  • Screen tearing: There's still some noticeable screen tearing, generally in all the stages. I also noticed some frame flickering. The fourth picture below represents this. It's only one frame, but it's really noticeable while playing. It seems like for one frame, the game is generating a smaller version image of the same frame over the bigger version.

dr2_001.png

Seems normal, when vSync (or modern alternatives) is off.

Greetz.

Edited by MBastieK

Share this post


Link to post
Share on other sites

Couple of minor bugs/glitches I noticed so far (PC v1.2):

1. Watersplash in New England is not rendered properly when viewed from head camera while driving. Curiously it is rendered properly when viewed from head camera during replay:

083eK40.jpg

1. Part of a mirror missing after a crash in Lancia Fulvia:

5pRkR2i.jpg

2. Some roadside sticks and poles are placed above the ground, in certain corners, in New Zealand and New England. Easily noticeable when driving in head camera:

qqGQWzk.jpg

3. The AI seem to always get stuck on a certain corner, in rainy conditions, in Holjes:

gEMq6iB.jpg

 

  • Like 1

Share this post


Link to post
Share on other sites

Just experienced the audio bug in New Zealand.  Fourth stage of this session, about half way in.  No audio apart from gravel flicking.

Damn near cost me the championship as I dont use any HUD.

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/22/2019 at 1:20 PM, McRoessler said:

well thanks! I will try it tonight and will give a feedback. 

sorry. did not do the trick for me...
FFB still the same or rather lack thereof... 😞

and in my test drive I encountered the "no grip bug" AGAIN this time with the E30 in Australia!

Edited by McRoessler

Share this post


Link to post
Share on other sites
On 3/21/2019 at 7:20 AM, McRoessler said:

Yes, I can confirm this bug on PS4. Also here it happens EVERY SECOND stage. 😒

It really does suck, this bug only seems to be affecting a small amount of people on PS4, I tried reinstalling the game but no luck

Share this post


Link to post
Share on other sites

Still not getting any luck with the Group B and Group A buying of all cars.

Also finished well inside top tier on the USA group B daily in the Quattro last night and nothing popped.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I was always first in rallycross in my group. But at the end of the rallycross event I was 20th. That means that even the riders behind me, who drove me together on the same track, even though they crossed the finish line after me, were faster.

Nobody can explain that this is normal. It's illogical enough that I'm not in the semifinals when I'm always first in my group. 12 out of 20 drivers reach the semi-finals and 6 of 12 finals. There are 4 groups. On average, 3 from each group would have to come into the semifinals.

But if I am always first with 5 drivers I would have to be at least 16th at the end. But I was 20th.

These drivers always stuck to me in the rear. So it can not be that they were behind me but the laps are faster.

Edited by VaeliusNoctu
  • Agree 1

Share this post


Link to post
Share on other sites

The AI in H2 RWD of the Historic Championship mode Back to the 80's appear to be bugged, their times do not reflect the difficulty level that you set, I did this championship on 85 difficulty level and was 20 seconds a stage off the pace, whereas at the same difficulty in H3 RWD of Back to the 80's, the AI were as they should be.

I was driving the VW Golf GTI in H2 but I've seen reports that the same thing happens in the Peugeot 205 as well.

 

Also as mentioned above, manual track reset does not work

Share this post


Link to post
Share on other sites

The game crashed now the 3rd time between 2 stages, 2 times today.

It happens always around uploading to racenet/saving.

Sometimes it crashes to dashboard, sometimes it shuts down the console alltogether.

 

Caused a more than 10 minute penalty after the 5th stage of argentina in the 2nd monthly community event.

Pretty much at half of the monthly event I dropped from 29th to around 550th place.

 

Second monthly event (from attempting 2) were a crash caused a big penalty.

It doesn't make sense to play these monthly events with that high chance of a crash at this moment.

 

Playing on an X-Box One S.

 

  • Agree 1

Share this post


Link to post
Share on other sites

Just a minor annoyance, but when selecting Automatic Windscreen Wipers - OFF, they still automatically wipe.

  • Agree 3

Share this post


Link to post
Share on other sites

So they release a 10gb patch and break more things than they fix! And they don't even have the decency to acknowledge any of the complaints or provide reassurances as to when these problems will be fixed.

Honestly, this whole game is one big bug. I don't think they have the skills to fix it. I don't think there is any talent at all at codemasters. From what I gather it's a simple minded team of feminists without a clue about rally.

Listen, this game is dead already, so how about you scrap the DiRT title which sucks btw... And create a game that is as a rally in real life? How about you attempt that, if you can that is. Because this is not a sim, it's a joke, and your company is a bad joke. Hire some talent and create a true rally game. 

  • Haha 1
  • Disagree 7

Share this post


Link to post
Share on other sites

I am in disbelief over the fact we have five (FIVE!), pages of bug commentary after the patch, and it has only been 4 days since its release. Many issues of which did not exist before the patch. Come on Codies...what is going on here? You have been releasing racing titles for decades, and the first Dirt Rally a few years back was great. Why such a struggle with V2? All you had to do was add some ‘sugar & spice’ to the original recipe, and people would have been happy.

Now this!?

For the life of me I don’t get it...best of intentions I’m sure, but implementation NEEDS to be better. At this rate we’ll be patching until 2021...fans are losing patience, and this game has most definitely marred CM’s reputation.

Was this game released prematurely and we are meant to be Beta testers? Sure feels that way IMO..........

  • Agree 1

Share this post


Link to post
Share on other sites

Top priority for me: PLEASE FIX THE AI TIMES!

I'm trying to work through career mode and coming dead last in H2 FWD class on Pro difficulty (I hear Clubman is similarly difficult). I am NOT that bad a driver.

Just makes me want to put the game down.

  • Agree 2
  • Disagree 1

Share this post


Link to post
Share on other sites
Posted (edited)

*UPDATE* removed all controller from PC. restarted PC, launched DR2 and it worked without stuttering although graphics all messed up. set graphics settings again. restarted PC again. All good now and all controllers working

 

After installing DiRT Rally 2.0 - v1.2 my frame rate is down to 10fps. Game is stuttering and unplayable. Previously I had smooth gameplay and high framerates.

This happens from the "Codemasters" loading screen all the way through the game. Menus, gameplay etc. stuttering everywhere

PC specs: Core i7, Nvidia 1070 (nvidia driver 419.35), 32GB RAM.

I uninstalled and re-installed but still the same. Any guidance on how to try and root cause and fix?

Read on some other forums where users suggest to remove the wheel. I've a G920 but it is not plugged in.

Weird thing is in the settings the game seems to think I have a XBox controller plugged in, which i dont. Just mouse and keyboard

 

Edited by FonzMonster
FIXED

Share this post


Link to post
Share on other sites

Nothing gamebreaking.. but i noticed Tarmac squeaking sounds during replays in Poland while driving on gravel surface.

  • Haha 1

Share this post


Link to post
Share on other sites

Hello ChristinaMc, developers and drivers,
I have decided to write because I am affected by a serious bug that is hardly mentioned here.


Bug Description:
At all rally stages without service area there are physics problems.

  • The car is hard to steer or has no grip and you can not drive.
  • Occasionally, the car shakes before the start and / or
  • with activated start control no handbrake is held and it comes to the early start

This applies to all rally events including the online rally events, the online rallying career and
all events in the historic rally and custom rally events.


Impact:
With this bug, stages without a service area can not be won and you have to be frustration-resistant to get to the finish.
Community events with more than one stage make little sense and are frustrating.


Additional Information:
I found out that after a restart of the stage the bug disappears, this makes the historic rally playable.
This works in the online rallying career severely limited because the restarts are limited.

On YouTube you can find some videos of this bug.
I have the Steam version of the game but other platforms are affected as well.

You could fix it relatively quickly by attaching something like a free auto-restart before each race without a service area.

I would be very happy if this bug is removed soon so I can finally play. :classic_smile:

Rallycross is not affected.

 

===============

Hallo ChristinaMc, Entwickler und Fahrer,
ich habe mich entschieden zu schreiben weil ich von einem schweren Fehler betroffen bin über den hier kaum gesprochen wird.


Fehlerbeschreibung:
Bei allen Rallye-Etappen ohne Servicebereich gibt es Physikprobleme.

  • Das Auto lässt sich kaum lenken oder hat keinen Grip und man kann nicht losfahren.
  • Gelegentlich wackelt das Auto schon vor dem Start und/oder
  • bei aktivierter Startkontrolle wird keine Handbremse gehalten und es kommt zum Frühstart

Das betrifft alle Rallye-Events inklusive der Online-Rallyeevents, der Online-Rallyekarriere und
alle Events in der historischen Rallye und benutzerdefinierten Rallye-Events.


Auswirkung:
Mit diesem Fehler können Etappen ohne Servicebereich nicht gewonnen werden und man muss Frustresistent sein um bis zum Ziel zu kommen.
Community-Events mit mehr als einer Etappe machen kaum Sinn und sind frustrierend.


Weitere Informationen:
Ich habe herausgefunden das nach einem Neustart der Etappe der Fehler verschwindet dadurch wird die historische Rallye fahrbar.
Das funktioniert in der Online-Rallyekarriere stark eingeschränkt weil die Neustarts begrenzt sind.

Auf YouTube findet man einige Videos von diesem Fehler.
Ich habe die Steam Version des Spiels aber auch andere Plattformen sind betroffen.

Man könnte den Fehler relativ schnell beheben indem man so etwas wie einen kostenlosen automatischen Neustart
vor jedes Rennen ohne Servicebereich anhängen würde.

Es würde mich sehr freuen wenn dieser Fehler bald beseitigt wird damit ich endlich mitspielen kann. :classic_smile:

Rallyecross ist nicht betroffen.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

WRX content is oficial?

Why in WRX Champs drivers name is not real? ((

Edited by Ha3aP

Share this post


Link to post
Share on other sites
Posted (edited)

I’m partway through a 2000’s career championship and austrailia appears twice,    and Poland is missing. Has anyone else experienced this? 

I started this championship before patch 1.2 so technically it’s a v1.1 or v1.0 glitch.

 

edit: on ps4

Edited by Pieman99
  • Agree 1

Share this post


Link to post
Share on other sites
7 minutes ago, Pieman99 said:

I’m partway through a 2000’s career championship and austrailia appears twice,    and Poland is missing. Has anyone else experienced this? 

I started this championship before patch 1.2 so technically it’s a v1.1 or v1.0 glitch.

Happened to me as well, Argentina twice, maybe it's supposed to be this way, but why?

Capture.JPG

  • Agree 3

Share this post


Link to post
Share on other sites
Posted (edited)
19 minutes ago, Bigsur said:

Happened to me as well, Argentina twice, maybe it's supposed to be this way, but why?

Capture.JPG

Glad it’s not just me. I did countless career championships on dirt rally 1 and never encountered 2 of the same locations . It has to be a glitch surely? 

Edited by Pieman99
  • Agree 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×